English

Headphones microphone

I’ve noticed that when I send a WhatsApp voice-message, it works perfectly with the build-in-microphone on my FP3+, but the moment I use my headphones the sound quality becomes really bad. I’ve tested it with several headphones and its the same issue. I didn’t have this issue with my previous Motorola Phone (same headphones). Anyone knows if there are any settings I can change so the headphone-microphone-quality becomes okay again? Thanks!

Welcome to our community forum :slight_smile:

Are you definitely sure that the plug sits in the FP3+ deep enough to make the FP3+ detect the microphone? If it doesn’t, the sound might still be picked up by the built-in microphone of the phone, and it might be quite a bit further away from your mouth then (resulting in worse recording quaiity than when you use it on purpose, i.e. much closer). The plug sometimes feels like it’s already clicked in, but still needs a bit more push to go all in.

3 Likes

Have you tried to plug in the headphones without the rubber protector? The plug shape may not fit through the hole entirely.

4 Likes

Yes I tried without. That is not the case, and since I also tried it with different headphones (that do work normally on other phones) it is also not the headphone. It sounds like the fairphone cannot process the sound of an external microphone very well…

No, I definitely made sure I plug it in correctly.

I use plugged Samsung earbuds (and its mic) for calls alot. Didn’t get criticism yet for calls (do not use WA to test voice messages). I wanted to know myself if the sound quality differs much between built-in and external. I used a recording app for local replay. While the sound quality was less “roomy” and louder with the external mic, (a different “profile”?) - it wasn’t particular bad quality. Less good, but not unclear or uncomfortable listening to. If you record with a local app and the Headphone Mic - and read the same text to a WA voice-message and replay this… how much do the replays of both sources differ?

It sounds like the fairphone cannot process the sound of an external microphone very well…

What is your current firmware version? and remember: contacting fairphone support about your issue is also legit.

2 Likes

Thanks for thinking along! It is not terrible quality, but it is bad quality. I am also getting complaints sometimes if I call someone with my external microphone on. Not that they cannot hear me at all, but they say it is a bit uncomfortable to listen to and sometimes they miss some words in a sentence. And I just think it shouldn’t be this way: normally the sound should improve by using good headphones with a good microphone… I recorded the difference here (and this is in a very quiet environment where I can keep my mouth really close to the microphone, it is much worse outside or if I’m in a more noisy space): https://drive.google.com/file/d/1sJ3pOA7hlMGqTZ_RXVfw_vIQ8jmQVne-/view?usp=sharing

Seems it’s not possible to access this link without a G00gle account.

1 Like

Obviously. You can easily set up one with a throwaway email if you do not want a real one.

1 Like

Well, I fear I ran out of fake telephone numbers. :wink: The telephone number is mandatory to protect my security. :wink:

I think I changed the settings so now you dont need a Google account to access the file!

1 Like

just for test conditions: the way you took the recording, was this recorded directly uploading to Whatsapp, and downloaded again, or did you record to an App on the device? I ask because I wonder if whatsapp does postprocess a file (compressing before uploading)

I did listen to the recording: the difference is stark. My own recording test fared much better (will provide a sample)

The second part of your recording done with the built-in mic is what I deemed “roomy” before and is good, but its volume is low. The headphone mic sounds “metallic”. Maybe if the input-volume of the headphone-mic is very low too, but a noise-filter is applied contrary to built-in mic (this is done through software profiles per inpout-source if I’m not mistaken), then the filter is responsible for the loudness/amplifying. I want to say it could be software.

Can you post a screenshot of your sound settings and quote the current Android version you’re on?

In the “Android 10 Bugs Wikidoc” is an item

Low and not adjustable In Call Audio Volume when using Bluetooth ( Headphones / Car ) (Bug might correspond to the “volume buttons always control media volume” bug!)

and I wonder if this applies to you - the input volume being too low. But after all you have plugged headphones, so bluetooth profiles do not play a role

Edit: my own samples are here. They’re app recordings (no Whatsapp upload/redownload), built-in is first, headphone-mic comes second. The headphone-mic (Samsung AKG cheap Earbuds) does in my opinion sound okay, a bit louder / less bodied, not as good as built-in, but not as metallic and cut-off as your headphone-mic sample.

1 Like

The phone number is not mandatory. Just checked it.

But Charlotte has changed the access anyway, so what.

Thanks Charlotte, it’s working now.

I clicked on the “microphone” tag of this forum post and another FP3 related issue came up from beginning of the year. There’s more info in there…

  1. people describing the same symptoms, sounds like “far away, distant, tinny, silent, dull”.
  2. a microphone module test that formalizes the record/playback test and

Solutions go from changing SIM cards and/or modem functions (disabling 4G standards). A user describing your symptoms to the point said the 4G mode mostly resolved his issues.



Would be interesting to dig into the software what this mode is about and its effect on audio profiles.

Edit: behind the option is VoLTE (Voice over LTE / “HD Voice”) and RCS (SMS/MMS successor). Maybe there’s some incompatability with the mobile network operator and the mics go into some kind of fallback? I’m telefonica/vodafone Germany based and having it enabled on both SIMs doesn’t have a negative effect.

1 Like

Nope, I have to correct my last statement. The problem persists at least for vocal messages (not for phone calls for whatever reason). I noticed that the “silent microphone problem” tend to appear whenever the phone connects to the internet via wi-fi.