English

Headphone speaker issue

Hello - I have a fairly new FP3 (about 1 month old) and the headphone speaker does not work anymore:

  • when receiving a phone call, I can’t hear the caller through the headphone speaker (whether using a headphone or not). The only way I can hear the caller is by putting on the external speaker.
  • when listening to audio file with headphone, I can’t hear anything.
  • when listening to audio file without headphone (hence external speaker is triggered), it works and I can hear the music
  • when I connect the FP3+ to a bluetooth speaker it works
    I tried several things without any success:
  • restart the phone
  • shut down and restart
  • turn VPN off
  • desmantle the phone and put it back (not doing much else)
    ALL I did, did NOT fix the issue.
    Thanks in advance for your help.

Hi Valerie and welcome to the community. Just note that this is a user forum, so for official help you would need to contact support directly.
Regarding your issue, to understand better:

  1. You do not hear the caller when using a wired headset? Did you test different ones, not all might be compatible
  2. You neither can hear the caller when you use the ear speaker, i.e. calling the “old fashioned way” by putting the phone to the ear?

Official support can be contacted this way

You should be able to test the ear speaker by dialing * # * # 6 6 # * # *

Edit: using above link to troubleshooting indicates also wired headphones can be tested using this number

2 Likes

Maybe there is some dirt in the headphone port. Try blowing it out, or CAREFULLY take it out with either a cotton swab or a needle.

2 Likes

Hi and thanks for the quick reply (sorry for not using the proper channel). I’ll contact support directly.
But to answer your questions:

  1. I did not test different ones - will do but note that it does not work when I’m not using any headphone (ie putting the phone to the ear)
  2. yes I can neither hear the caller using a headphone or just putting the phone to the ear

FYI, I tried to do the test dialing the key combination you suggest but I did not understand how it works/what it does…as soon as I type the last digit, the whole “code” disappears and nothing happens. Not sure if I’m supposed to hear anything at that point? but if that’s what it’s supposed to do, then it just confirms I hear nothing :slight_smile: .

Thanks again for your prompt reply.

I don’t own a FP3 so cannot exactly say what happens when dialing the code, but some sort of a menu should be seen to do different tests for the different modules.

To me your issue (actually I would say 2 different issues) should def not happen with a new phone, so due to warranty, support should be contacted.

Else for sure you can always ask here for help, it’s just no official help from Fairphone

2 Likes

Are you using the official Fairphone OS on the phone, or are you using a custom ROM like LineageOS or /e/ (which might not have the test menu one should otherwise be able to reach via the code)?

What exactly is given as your “build number” currently … you can get there by searching for “build” in the settings.

Hi AnotherElk,
Very good question! I just realized that I’m actually not using the Fairphone OS but rather the /e/ OS which I believe did not think could be different from the one natively installed on Fairphones!
I was actually advised Fairphone as a degooglised phone by a friend who provided me with a website from which I ordered my Fairphone and just discovering now that it does not have the Fairphone OS :frowning:
Hopefully it’s still supported and my issue can be fixed.
I did open a ticket on the official FP Support site…crossing fingers now!
Thanks for your help.

Well, most importantly for your case it is not an OS supported by Fairphone, so for Fairphone to help you in any way they will most probably advise you to revert to Fairphone OS first … or perhaps to send the phone in and let them do it themselves before analysing any issue.
And, while being an Android OS, too, /e/ is quite different from Fairphone OS.

The Fairphone 3 with Fairphone OS is not a degoogled phone, else too few people would buy it (sadly), but your friend is not wrong in that options exist to degoogle it to different extents.

So most probably your friend guided you to buy directly from the e foundation, to get the Fairphone 3 preinstalled with /e/ … do you recognise https://esolutions.shop/?

Not a bad choice for a degoogled phone at all (I’m using /e/ myself), but in this case your first support address of choice should be the e foundation … Support - eSolutions - deGoogled phones and services.

3 Likes

You’re spot on - that’s exactly the site my friend sent me and where I bought my Fairphone 3+ from…
OK… so heading to the provided support URL then…Thanks a million for all your help!

Good Job. I also bought new headphones but they also have same issue. I can get much about solution from here. Thanks a Lot.