Headphone mics don't work

Hey dear Fairphone community,
I honestly don’t know what else to do than ask around.
Some time ago I bought myself wireless headphones (Sennheiser CX plus). They work just fine with audio output, but they just won’t take audio in. Not during calls, memos etc. I actually got replacements 'cause I thought the mic was broken, but the new ones don’t work either.
If I connect the headphones to my Laptop the mic will work just fine. It only seems to hate my phone. I originally got the wireless headphones so I could easily take calls while working but now I always have to pull out my phone and change it to internal device (which is not really the purpose of why I got them :slightly_frowning_face:
Hope someone in here is able to help me, best wishes
Justus

Hi Jay00 and welcome to the community forum :slight_smile:

If you go to Settings > Connected devices > (Settings for the Sennheiser CX) (cogged wheel), is the “Phone calls” option enabled?

Hey, thank you :slight_smile:

Yes, thats all turned on. I already had two weeks of brain damaging Support Mails from Sennheiser. I actually have a different pair of Sennheiser over-ear Headphones and with them everything works flawlessly :confused:
Could it be that the New Headphones are too modern/New for the Fairphone? My Brother bought himself an iPhone the Same time I got the FP3 and with that it wont Work either. But there you can at least Talk into the Phone and listen through the Headphones. With Mine the FP seems to try handing the call over and deactivates the internal mic but doesnt activate the external one

OK. Just to be sure we’re talking about the right product, these are actually “CX Plus True Wireless Earbuds”? As specified here?

These use BT 5.2 but all versions of BT are supposed to support downwards compatibility so there shouldn’t be a problem with FP3 (BT 5). Just wondering if there may be a problem around implementation of BT LE (low energy) nonetheless.

Have you tried a factory reset of the earbuds? Documented here. You could try both “Resetting the earbuds” and if that doesn’t help, “factory default settings” (the latter will delete all pairing records).

There might have been a bug corrected in a firmware update. See documentation.

I also wondered whether the mic has been muted by accident, but I don’t see the function in the instruction manual. Maybe check the Smart Control app?

Yes, those are the Headphones I have. I performed 2 factory resets via the App and one directely in the earbuds. There actually is an Update that fixes the constant humming noice in the Background but it doesnt Help with my primary Problem.
I also thought they nicht bei muted because I specifically had to Tell my Laptop to use the Mic on the Buds but I couldn find any Option concerning Microphone Changes in either Android or the Sennheiser App. I even went as far as playing around with the Developer Mode trying to find anything helpful. I bought them a while Back so I probably cant Return them to the Store but of there aren’t any enlightning Ideas, I’ll try and then get different ones (mayby FP Earbuds Work better with FP?)

Interesting. I just did tests with four apps, after connecting my Jabra headset.

  • Phone (standard app): working as expected when Bluetooth is connected.
  • Sound Recorder: doesn’t offer any choice of microphone in the free version. The headset mic is not used, although audio is going to the headset.
  • Easy Voice Recorder: choice of Front or Rear mic but no mention of Bluetooth. The headset mic is not used, although audio is going to the headset.
  • Zoom: for audio, choice between phone and Bluetooth device. If the BT device (headset) is selected for audio, then the headset mic is used too.

Are you using the standard Phone app?
When you receive a call, do you hear the call signal in the headset instead of the normal ringer?

Well that should bei Standard. Usually Memo Apps dont Support Headphone mics. But I used the preinstalled Google Phone App, I tried WhatsApp calling, I now use simple Phone. All of the above didn’t Work eventhough I heard the Ring in the earbuds. The only Thing I got working was Zoom on my Laptop.
But we can actually Close this thread down by now. I Just went to the Store, got a refund bc of the continuing Problems, the Guy in Store Said it was probably a Software Bug and he wouldnt Count on them fixing it in the nearest future. Ordered myself the Fairphone Earbuds. And if they dont Work either I’ll probably reset my Phone or burn everything Wireless surrounding me in some satanic Ritual :joy:

2 Likes