English

Has anybody received the latest security update yet?

Hi,

I received too. Looks like it works now with Sosh ( orange) also/again!

Oh, it is staged. Ain’t there for me yet.

Surprisingly, for me it worked on the second check for an update. :angel:

Anyone grabbed the URL for the OTA update?

Since the update I can shot down this notification. Have you the same problem ?

You can deactivate that app.

2 Likes

How can I do this?
The update is shown for me, but I can’t install it because of TWRP. But I could load it and try to grab the url.

2 Likes

Here is an how to :

2 Likes

I’m downloading it right now.

1 Like

Same here. This the the Search Engince Choice that Google agreed to as a concession to the EC. But something seems to have gone wrong here. I will open a ticket with the support.

2 Likes

OTA URL:
https://android.googleapis.com/packages/ota-api/fairphone_fp3_fp3/996d9c3cd83bf55bcbf4674a7074885e2d66e0f8.zip

9 Likes

Thank you, I was trying to find the url in the logcat file, but could not find it? Maybe because I didn’t start the logcat before the first time I tried to download the update.

Hey! I got the update with my Orange SIM as master SIM!
They must have corrected the issue…

3 Likes

I received the FP3 A.0110 upgrade. Very disappointing! It is time for an Android 10 upgrade!

Tried multiple times the past hours. Nothing.

1 Like

I still haven’t been able to update my phone to January patches, and I read a report from someone who couldn’t update anymore because they missed an incremental patch. So I’m worried. Also, I want the February patch ASAP. How can I figure out what is stopping the update? Where is the update server located? At this point, what is my best and easiest way to get my FP3 updated and working?

Are you unlocked?
Then you can install the current firmware using TWRP:

2 Likes

Nope, not unlocked. I guess what I can do is back up my data, unlock, flash TWRP, and then one of these zips?

No need to flash TWRP, “fastboot boot” would be enough.
Then just install the ZIP using TWRP, you’ll want to use the 110 one if you want the updated firmware.

Right, but by unlocking, I lose the ability to use Netflix and such right?

Also, I don’t see a boot option for fastboot in the man page.

My fastboot version:

fastboot version 1:8.1.0+r23-5
Installed as /usr/lib/android-sdk/platform-tools/fastboot

Silly how I got that installed on Ubuntu 19.10…

On macOS with Homebrew I got this one

fastboot version 29.0.5-5949299
Installed as /usr/local/bin/fastboot