Graphic-error using google maps app with routing for bicycles

For this issue I’m not sure where to post. But as my daughter sais that it works on her Samsung S3 mini, I start here:
after getting a way in the google maps app I choose the guidance. This will work fine for the car routing and the pedestrian routing. But in the bicycle mode, the layer with the green coloured bicycle paths will be shown without scaling and very scrambled. I attache a screenshot.

As you can see, the green path is between the route and the map so that you sometimes only see a green desert with the path, but no roads, no streetnames, nothing else.

Does anyone have also this behaviour? And does it come from maps app, or fairphone, or both?


Does it on my phone as well. Very odd.
I tried doing a Google search to see if it was a more common problem, but I haven’t been able to find anyting about it. Not sure what search terms to use though.

OT: do you play the guitar of your icon? Nice idea, should take a photo of my mockingbird…

Hello, I have exactly the same problem. When I googled ‘green lines bicycle google maps’ it seems like Google introduced a new function where bicycle paths are indicated in green. ( Screenshots of this look nothing like the results I’m getting though (which look exactly like your screenshot.
Does anyone have an idea how to disable the bicyclepath layer?

Yes, I do!
Am a big Steve Vai fan as well :slight_smile:

1 Like

I have the exact same problem on my Fairphone FP1U.

Same problem here! Any solution yet?
Oh! i just found out. Just unmark the bicycle lane button in the menu . problem solved.

Same problem! This seems to be just a fairphone bug - but seeing as how I’m using my fairphone to navigate from Lands end to John O’Groats next month (1000 miles) on my bike - this is a fairly major bug! Fairphone - please advise how and if we can fix this?
It only appears with the cycling overlay turned on - and you can turn this off in the map view - BUT when doing navigation by bicycle, it’s not possible to turn this off - so your route gets completely obscured by green mess. Please help…


Same problem with bicycle navigation being unusable due to green mess on FP1U - please escalate.

Still a problem even after the latest OS update. Before and after screenshot attached. NOTE: it is not possible to turn off the ‘bicycling’ layer when in the Bicycling navigation mode. You can do it on the overview of the route, but as soon as you go into the turn by turn navigation it’s back again…
Please look into this Fairphone!

I think this issue was resolved with the latest Google Maps update. At least it’s now working normally for me (on FP1U). I had opened a case with Fairphone Support but I’ve now marked it as resolved.

I can confirm that also on my FP1 this issue seems to be solved. I hope, that this will be the same for the following updates of Google Maps.


Fixed for me since the update. Great!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.