English

GPS stopped working fp3

Hello, since yesterday i have a problem with my GPS. It suddenly stopped working with different y apps but it still shows the location icon above. I can’t find my location anymore on Osm for example. ,I’m travelling now on international trains but the problem started in the Netherlands so I think something broke. Is there something I can do, or a module I can replace? I bought this phone a few months ago soni think I still have warrenty.

With * # * # 6 6 # * # * in the dialer app, you can open the service menu, where you can start some tests, is the GPS working there?

1 Like

When i type that after i finish with the *, the dialer menu disappears and nothing happens. I also tried with another dialler app but then when I press call button also nothing happens.is there another way to enter the service menu? I have developer options open but don’t see anything useful there.

Aren’t you using the standard Fairphone software on your phone?

No, when I got it, I installed some OS but it is android based, I just don’t want and have any google stuff on it.
I have Lineage OS 17.1-20210419-NIGHTLY-FP3
And android 10

Then the test functionality doesn’t work, and before contacting Fairphone support, you would have to install the original software anyway.

1 Like

What a hassle…then I have to put all my things on a computer drive and reinstall everything later. But okay I guess that’s what I should do :frowning:
My phone has a recovery/reboot function, will try that after I put my things somewhere safe

But wait, I’m not familiar with Lineage OS on the Fairphone, maybe someone else will join the discussion and help you.

1 Like

Maybe it came with an update?
A use on /e/ experiences the same problem after the last update:

Thank you , but if it is a software problem, wouldn’t more people have the same problem? Also I think.my lineageos didn’t update when the problem started but later I found out that I needed to manually update to version 18. However i tried to do GPS test (official service test)in the original FP Os and I didn’t see any result.When i opened Openstreetmap in the original OS it found my location. Which is weird, because now I switched to Lineage OS 18 and again it doesn’t find my position. Kind of lost here…

Hello, I had the same problem on FP3+.
Turning my phone off, waiting a few minutes and THEN restarting it worked for me!

Answer found here: FP3+ / géolocalisation impossible depuis la dernière MAJ de /e/ OS - Troubleshooting - /e/ community

2 Likes

I did that before many times as I reinstaleld the phone with different operating systems but the problem remained. Now suddenly it works again but I don’t know why (am now in LineageOS 18.1)