English

GPS problem and battery drained since Android 7

Hello FP community,

Since I updated my FP2 with the FPOOS 19.02.1 I (btw thanks a lot for the team behind this update) … it was great to discover some new possibilities/option/ergonomic.

However I also remarked that the battery do last last the same. I did not change my use of the phone and the battery is getting used 50% faster. So I wonder if there are more stuff running in the background, and indeed the miscellaneous is far higher than any other activity.
(Btw, I am using one of the few parameter I changed since the update is the ‘adaptative brightness’, but it does look like it has much impact on this issue).

Another thing that changed is the GPS functionality. I am using OSMand a lot, especially for hiking (up to know it worked like a charm - thanks to the help I received on the forum). And the tracking is not as good as it used to be. The location get lost or is not precise. When I went to Faster GPS I saw that the parameters went back to default, and when I tried to change the server, it is not saved (although the apps has the privilege).

I wonder if some people experienced the same issues, and if there is some work around.

Thanks.

I noticed no changes after the update. To save power, I disable the location service altogether or I set it to power save mode which works pretty well in cities with a lot of WLANs.
For me, main power consumption is WLAN so I disable that, too, when I don’t need it.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.