GPS + navigation not working properly

Hi all,

I have been experiencing issues with my GPS and navigator for about a month now. I thought this problem would get solved once updated to the latest version but nothing changed.
Further than the icon issue (doesn’t really bother me that much), it takes ages for the phone to fix a location. I have been now over 30 minutes with GPS test on by a window in the centre of Barcelona and it has been unable to fix my location (image attached).
Furthermore, when it does give a location it is unaccurate and the compass goes all crazy. When travelling by car, train, bus, the phone doesn’t detect movement and the arrow stays frozen; therefore navigation doesn’t work.

Did anyone experience this same problem? Is it possible for such an expensive phone to have worse GPS than the former model (FP1)? So frustrating…

Thank you for your time!!

What changed a month ago? Did you install any new apps?

Check out the #gpsguide for lots of tips to improve GPS.
And a general tip: If you’re having severe GPS issues, waiting by the window is not enough. Go somewhere where you have a clear 360° vision of the sky and wait for an accurate fix there. Often that’s enough to improve GPS.

Hi Paul,

thanks for your reply.
Nothing special happened a month ago, I don’t recall installing any app at that time. I had only used the navigator app a couple of times before it happened and it had been a while ago.

Alright, so I went outside and tried out the GPS test again and it worked perfectly. It got a fix in seconds. Yet the Google navigator app is still not working. Although it does get a fix and sets up an itinerary it does not move with me or point where it is supposed to. Could this be a problem of the Google maps app? Should I try uninstalling it and installing it back again?


Thanks to EFIDroid I’m able to test things on FP Open and FP OS and while on FP Open GPS works well I seem to suffer from the same issue as you on FP OS:

I do get a fix quite fast and accurately but the curser on the map only jumps to a new position every so often instead of moving along with me.
In SatStat I enabled notifications for GPS fix and for searching, so I can see that the problem seems to be that GPS doesn’t stay fixed.

I’ve got the same GPS-jumping issue. It just gets the location once but then it does not refresh quite as often as I would wish. I couldn’t figure out any way to increase the updating intervals.

I am using Unified… with Mozilla-, WiFi- and GSM-location services. My navigation app is OsmAnd~. My OS is Fairphone Open.

How is your GSP-configuration on Fairphone Open, @paulakreuzer ?

My GPS was never working properly, so I would love to get it working now. I already put quite a time on solving it…

In strict coherence with the #gpsguide I use:

  • Faster GPS to
  • set Austrian GPS server as standard
  • set Intermediate pos to 1
  • SatStat to
  • update A-GPS data (though that doesn’t work for me since some months now - without really impacting GPS performance)
  • microG for Network Location

And in OSMAnd I set GPS wake-up interval to “Continuous” (Tap the Satelites in the top right corner to find this setting).

I’ll now install OSMAnd on FP OS and see if it helps. Maybe the other apps I use simply don’t request a continuous GPS fix. :confused:

Hello again.

So I wrote to the support request the same day I wrote this thread and they answered quite quickly (only 3 days after!) telling me I should somehow find ‘location access’ item in the Settings menu (Settings > Location access > GPS Satellites) and unpick EPO. I answered them that I couldn’t find the ‘location access’ item on the settings menu (I even sent pictures of what my settings menu looks like), and therefore had no idea how to access this EPO option. I asked them if they could please guide me through and clarify where the ‘location access’ item was. Well it took 7 days (a whole WEEK!!) for them to answer and, with all due respect, it hasn’t been useful at all (considering the problem I had):

"To optimize the location capability of your phone, A-GPS is a common
feature in mobile phones. (…) So, there are also a couple of things you can do to try and improve your GPS signals yourself:
Activate A-GPS and EPOYou can activate A-GPS and EPO here:

  • Settings -> Location access -> GPS satellites (tick the text) -> Check A-GPS and GPS EPO assistance (…)"

Please, since I wouldn’t like to wait a whole other week just for someone to hardly read my question and answer me again to follow: Settings -> Location access -> GPS satellites (tick the text) -> Check A-GPS and GPS EPO assistance, could someone please help me and tell me where to find the location access? or the GPS satellites option menu?

Thank you so much in advance.

I fear the support employee you were talking to mistook you for a FP1 user. There is no EPO on FP2, since that’s a Mediatek thing.

I tried this and it really helped me.
Check again if you can find a setting in the G%§$e Maps app to make sure GPS stays fixed / is updated continuously.
Or try OSMand. If it doesn’t work well with that either than it might be a hardware issue.

1 Like

Thx @paulakreuzer , I couldn’t find any option for continuous GPS, see screenshot…
Could you tell me where to find it? Thanks again!

First click on the hamburger menu (left bottom corner) -> Configure Screen -> Toggle “GPS Info”.
Then back on the main screen tap on the GPS info in the top right corner.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.