GPS doesn´t work on FP Open OS

Hey guys! Nice to see there are some workarounds here.

I was wondering whether someone tried these with GAPPS already? I’d like to have a functioning Play Store (mostly for apps like Spotify and Netflix, but also some more niche / local ones), but so far it keeps crashing when GPS is active.

A very nice alternative for the Play Store is the Yalp Store from Fdroid. It is small app with very little overhead. If you are only planning to download free apps (and are not using any other play services), there is no need for the whole GAPPS package.

See this thread for more info.

Hi all,

I was just reading an article @Roboe sent in another thread and this part made me think about all the work we have to do to get location working on FPopenOS:

At Google I/O 2013, Google revamped the Android location APIs and released them as part of Google Play Services. In other words, Android’s top-tier location services are now closed source. If the above history is any indication, the open source location stack will be left to rot. The added features include the Fused Location Provider, a “complete rewrite” of Android’s location algorithms, Geofencing (which lets you define locations on a map that will trigger events in an app when the user enters them), and Activity recognition, which uses accelerometer data and fancy algorithms to determine if the user is walking, biking, or driving—all without turning on the GPS.

It made complete sense to put the Maps API and Google Cloud Messaging into a proprietary app, as those services depend on Google servers to function. However, moving over the entire location stack feels like a massive power grab on Google’s part. There are now two methods to get location: the good, low power, closed source Google way, and the crappy, battery expensive, open source way. (emphasis mine)

1 Like

AFAIK microG is using less power than G%§$e as it doesn’t collect and send data.
That article is over 3 years old and things have changed.

Thanks for the precision, good to know!
I had guessed that some things had changed, but it was more the struggle to get it working that talked to me!

Yeah, this whole work to use location services is just for that. But, on the contrary of some people, I think this is good for privacy. You know, before that change, AOSP (the open source version of Android) used Google Services for location, even when no GApps were installed, because these location services where integrated into the system, and there weren’t any method to change it. That was bad. Now we can choose, :slight_smile:.

The article is referring to the network location (proprietary on phones with Google Services) and the pure GPS location (open source on every phone). microG or UnifiedNLP (which doesn’t need signature spoofing) fill the gap of network location left by Google Services (when no installed).
Of course microG/UnifiedNLP is less battery-consuming than the whole Google Mobile Services (spying) framework.

For a more technical explanation, read this:

1 Like

A question: is the GPS problem with FP OS affecting everybody or just a limited amount of users ? (to understand if it’s a failure or a known software limitation)

It only affects a few people and those usually can solve the issue with the help of the #gpsguide.

I’m having a few issues with GPS as well. I tried a few of the fixes in the wiki (Faster GPS and SatStat), but still the GPS experience is sub-optimal. Most of the times I get a fix in a few minutes, which IMHO is still not satisfying as if you enter your car it’s no fun to have to wait minutes before leaving. Just as a comparison, a couple of other phones I used (a Samsung and a Huawei) usually got fixes in 10 seconds.

My question is: is anybody having -really- fast fixes with the Fairphone 2, both stock and open OS ? Thanks

I’m using EFIDroid to have both FP Open OS and FP OS (with all Gapps disabled) and on both I usually get a fix before the app that uses GPS finished loading (e.g. OSMAnd on Open OS and Pokemon Go on FP OS).
I have to add that I almost always start using GPS when I’m outside. When I start using GPS before I’m out the door or while I’m in a vehicle it sometimes takes noticeably longer.

Hi everyone,

This is my first message around here.
I just got my Fairphone 2, and after not even a week, I decided to escape Google and moved to Fairphone Open OS. I have now the version 17.01… And unfortunately, my GPS doesn’t work at all. (It used to work perfectly when I was on Fairphone OS, it cannot be a hardware issue…)

I already read a lot of answers on this thread, but didn’t manage to make it work.
Should I install OpenGapps? Why, what is that for? (Actually I tried using the updater, but it failed) I even tried to download Google Maps, but it doesn’t help…
I changed the settings in gps.conf, still nothing. Maybe I don’t do it the good way.

If someone around could give me a few steps to follow, it would be really helpful!
Thanks.

1 Like

Welcome to the forum. :slight_smile:

First of all:

Nope! If you do that your escape failed. OpenGAPPS is the same as #dic:gapps.

Could you tell us what you tried so far? Especially of the tips mentioned in the #gpsguide.

Thanks for your fast reply. First of all, I didn’t check this #gpsguide, my bad. I will do it, try your tips, and I will write you back then.
We talk later, thank you!

Ohlala Paul, I tried to read more carefully the wiki of the forum to understand how to setup my FP open, and I realised I didn’t do much so far (basically I just installed the OS). From one article, there is always a link hiding another article, and another… I will write you back as soon as I am ready!
Cheers

So!
First thing first, I tried with my normal Fairphone Open 17.01 to open maps (with OSMand, and Swarm) but nothing worked: a pop-up with “waiting for location” appears on my screen. Then I tried to download Google maps. Same thing. However my location settings is turned on, and set up on “High accuracy”.

So I installed FasterGPS. Entered in the developper mode to make it work. I set up my location to Europe and Netherlands (where I live). Nothing changed. I changed the advanced settings INTERMEDIATE POS to 1.
Tadaaa! Swarm recognised where I am! Humm wait, no… OSMand and Google Maps don’t. I download Waze to check, same thing. “Waiting for location”. I reopened Swarm, “Waiting for location”… Arf!

With “GPS Status & Toolbox” nothing appears, except the compass.
It seems there is another problem.
What could it be?

EDIT: I just tried with SatSat. Left my phone for 2minutes next to the window and it worked. I just hope this will work also when I am moving… We will see!

Mikaël

Do you have wlan enabled? I learned that location mode works (at all/way better) with wlan enabled (as it seems to be used somehow )
(I’m using opengapps)

Hi, yes it is enabled. But anyway, I would like to use my GPS even when I am outside, when I am not connected to any WLAN…
I keep looking.

this doesn’t matter… It only has to be enabled, not connected… On the other hand, there’s also “device only” (my device is set to German, hope, the translation is correct). This is supposed to really only use gps…

Ah ok I get it. My location setting is set on “High precision” using GPS, Wifi and mobile networks (mine is set in French, I hope the translation is correct too!), but it doesn’t help.
By the way I lost again my location…

On FP Open the only way for “High Accuracy” and “Device Only” to be different is if you install microg (also explained in the #gpsguide).