GPS Distance problem with ape@map and Google Meine Tracks (Fix location issues)

I tried a lot to improve GPS reception and finally it works ok for Navigation Apps. But it doesn’t work at all with tracking apps like ape@map and Google My Tracks. The speed and differences are totally wrong displayed. Way too fast and too big distances! For example I was sailing today for two hours (347 km with an average speed of 192 km/h - Sailing World record!!).

I’ve contacted the technical support of ape@map and the problem is known with older Android versions and unknown smartphone manufacturers. I should activate "settings/GPS/“lokale Distanzrechnung” but this setting doesn’t exist?

What can I do?

Thank you for support.

I never actually tried one of those tracking apps, so I don’t have any experiences to share. But you still might want to try installing the Xposed framework and afterwards the Xposed module called “Gravity Box”. In its section of “General fixes” for MTK6589 phones, there is an option called “Fix location issue - Enable in case you notice that distance is not being correctly calculated when using sports tracking apps”.

Thank you. I’ve tried already once to install the xposed framework but failed, because I couldn’t press the Install button. This time it worked, I installed the Gravity module. If it stops raining I’ll try and keep you informed.


1 Like

I also experienced the same problems mentioned above and followed the fix given here but after installing Gravitybox it does not give an option for “Fix location issue” ! does anybody have alternatives?


Hi Spaceinvader,

attached find two screenshots, where to find “Fix location issue”.

Good luck!

Hallo Tobias. Mein Englisch ist nicht so optimal, deshalb auf Deutsch: Funktionieren die Entfernungs- und Geschwindigkeitsangaben bei Dir jetzt. Wenn ja, kannst Du noch einmal auf Deutsch beschreiben, was zu tun ist?

Thanks for your reply Tobias, my Gravity Box doesn’t give this option, see my screenshot below. I am using v.2.7.6 of GravityBox, which I think is the latest, perhaps I need an older version ?

I just realised there are newer version of GravityBox available, I was following the instructions given here:
which eventually brings you to instructions for installing GravityBox, however if you scroll further down there are newer versions available, I will give that a try.

Update again, I upgraded to v3.4.3 and now have the option for “Fix Location”, actually the Exposed Framework tool was showing me that there was an update available for GravityBox, I just didn’t realise.
thanks everyone.

Hallo web,

bei mir funktioniert mit GravityBox jetzt alles. Ich habe wie oben beschrieben das Xposed Framework installiert. Wenn das installiert ist, kann man das Modul GravityBox im Programm Xposed Installer installieren. In diesem Modul kann man dann unter Allgemeine Einstellungen dieses “Fix location issue” markieren, dann funktionieren auch die Distanzmeldungen…

Wenn Du noch Fragen hast, melde Dich.


Help! I did this and now my Sports Tracker is working fine. But my pull down menu is empty. All the settings shortcuts have disappeared. What happened? How do I fix it?

Hi Maija,

I’ve the same problem, but better like this, than without working GPS.

@Maija sorry for the long wait. I actually thought I had allready responded to your question but I must have forgotten to hit “reply”.

If you open GravityBox go to Status Bar Tweaks > QuickSettings management and - to go back to the standard arrangement in the pulldown menu - switch off the “Master switch”. Otherwize you can customize wich Setting-Toggles or “tiles” appear yourself.

1 Like

Is installing and configuring “gravitybox” and regular satellite location updates really the only/recommended solution to the dreadful GPS performance on FP? It’s a lot of hoops for a regular user to jump through for what appears to be a system issue.

Since the 1.6 or 1.8 update (I forgot) I have not had any GPS issues any more. So I don’t use any additional tricks to get (fast) fixes.

This post is about problems with tracking apps, not about general GPS issues. Also the way this fix is explained in GravityBox it doesn’t seem like it will fix GPS problems at all, it’s just about distance calculation.
For GPS problems this is the thread to read.

It does seem like both issues are a present. Tracking apps like MyTacks and Strava are pointless, which appears to be the subject of this thread. My comment stands.
Satnav is also erratic, sometimes reporting inaccurate speed, alerting for way over speed limit when not the case as well as sometimes routing from the wrong/nearby road due to location error. It’s not easy for a user to separate the two issues.

Is this really an issue with only some FP? or is it only users that care about tracking that are raising it here?

Sounds like the best solution is to solve the 1.8 won’t download issue then… :slight_smile: :frowning: I’ll chase that next… cheers.