GPS and SDCard not working, camera intermittent. Time for a new main board?

Hello there,

I’m using the latest Fairphone Open OS (the one without google play services) and my GPS doesn’t work at all. If one is lucky, you might get a location on google maps after waiting for 5 minutes or so.
I wonder if the board is damaged? The phone has been dropped (what phone hasnt?) and there are other problems such as intermittent camera (a classic problem on this model) and the SD card isn’t recognised.
Taking all these problems together I suspect something is wrong in the hardware. Can anyone advise me on what to do next? I doubt I’m still in warranty, as I’ve had the phone for a good while now.

You might still try to do a backup and test if GPS is better after a factory reset or when using LineageOS (or /e/OS).
If there’s a #fairphoneangel nearby you might try with another camera.
Did you try another SD card? Or clean the SD card slot?


I’ve tried doing everything I can with the SD Card with no luck. Even booting into the various reset and factory modes, different cards and cleaning. Very odd. I’ve not tried lineage or the like. That might be the next option.

GPS wise, I’ve no idea. It seems the phone might have been relying on Google play services and without it, location doesn’t seem to work.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.