English

GPS activates itself (Drei Austria / Italy)

gps
Tags: #<Tag:0x00007fb116c59008>

#18

Ups, sorry, I levelled you up! :smiley:


#19

still not possible, button “new topic” is greyed out.


#20

Basic is not enough.

@Rene_Sendlhofer I temporarily leveled you up to regular user. Now it should work.


#21

I thought that basic users “can use all core Discourse functions”…


#22

Hi,

Unfortunately I experience the same problem:

  • GPS gets switched on after I switch on Mobile Data
  • FP1U
  • using only one SIM card
  • Austrian network provider Drei
  • first occurred around Jan 15th 2017
  • I did not install any new apps for several weeks before this started
  • but I regulary update the installed apps (could therefore be an update issue; but it seems the problem occurs only in Austria? So maybe not)
  • two days after the problem started, I switched off every GPS permission I could find in the Settings, but it did not solve the problem (and I have been using the FP since 2014 with several permissions for apps active without GPS problems before)
  • the problem occurs even when I close all apps before I switch on Mobile Data (though I noticed that in Settings / Apps / Running I can still find a few apps running, like Fairphone updater, various Google apps like Playm Google Services etc., Battery warning, Telegram, Contacts, but no apps I would expect to use GPS data)

Hope this can be solved soon…

Thanks,
Katharina


#23

If one of you attends our next Austrian Fairphoners meetup we can do some debugging. It sounds as if this was easily reproducible.


#24

I experienced the same on my FP2. I checked in the location settings and found out that the “dialer” app - the phone app itself - was the culprit. This felt very dodgy to me, because I had a sense someone wants to track me. I was probably right with this assumption, and the “someone” being “the usual one” - means Google, because since I am using a completely Google free phone - FP Open, no GAPPs installed, I have not experienced that again.


#25

Hi there - I have the same problem (also Drei AT and FP1) :frowning:

It’s even worse with me because GPS automatically switches on when I just make a phone call.

Have to switch it off manually all the time.


#26

@Rene_Sendlhofer has opened a bug report (Thank you!):

https://forum.fairphone.com/t/fp1-gps-activates-itself-when-mobile-data-connection-is-active/25541?source_topic_id=25418

Let’s collect all we know about this in the wiki post you can find there (not editable by new users).


#27

Thanks for the link but it says thread closed a couple of minutes ago.


#28

Wiki posts can be edited after the topic has been closed.


#29

thanks - looks like I am classified new user level 0. Can’t do anything.

Would really love to help with information.


#30

I gave you Level 1! :smiley:


#31

thanks :slight_smile: still can’t write anything there though.


#32

You are temporarily Level 3 now. :wink:


#33

This is probably because the call is routed over 3G. If you want to verify this, you can disable 3G by going to Settings > [Wireless & Networks] More… > Mobile Networks > 3G > Enable 3G > Off. Obviously, you’ll want to re-enable this after testing if you ever use mobile data.

As for this suddenly appearing: It could be that Drei has starting using their frequencies in a different manner than they were doing before. As said, I can’t figure out what the exact problem is, and as I’m not experiencing the same issue, I can’t really help beyond this…


#34

thanks. Nop, still there.

Even rang 3 - they say it’s definitively not them. They blame the satelite - unfortunately they don’t have their contact details :wink:


#35

Hi,

I have the same problem with my FP1. GPS turns on automatically although all GPS settings are turned off.
I also use it with the Austian provider Drei and the problem occured first last week on January, 18th.

I hope there will be a solution soon.

Eva


#36

just learned from neighbour that he has it too - but he is with telering


#37

Hi,
So it’s not just my phone!
I have the same problem with the GPS on my FP1, since about ten days. I’m also with Drei in Austria, and I have all access to GPS turned off on the phone, in settings, in camera, on all apps where possible, and the time is set to network not GPS.
Still whenever I access my network internet, the GPS turns itself on and stays on until I manually turn it off.
I haven’t recently added any apps, but I did disable Google news.
would love to hear if there is a solution to this!
many thanks,
Rebekah