Got stuck preparing to install LineageOS

proving to myself that I’m hopelessly clueless…
I planned to install LineageOS on my FP2. Following the beautiful guidance page, I started with the part about “adb and fastboot” and got stranded early when using the terminal on Mac OS X. Which is a minefield for me, having done next to nothing with the terminal before, ever. I got as far as:
"~/adb-fastboot/platform-tools/adb reboot bootloader" (and even that only when I dragged the adb icon into the terminal window and added “reboot bootloader”). Upon which the FP shut down and started to reboot, but didn’t get further than showing the logos («Fairphone» and «poered by android»). When nothing further happened, I typed “~/adb-fastboot/platform-tools/fastboot devices”, which produced “81624fe6 fastboot”.
Here I decided I wanted to abort the whole process and return to what I had before —naïve, obviously…— trying “~/adb-fastboot/platform-tools/adb exit”. Now the result on the terminal window was considerably longer. It started with:
"Android Debug Bridge version 1.0.39
Revision 3db08f2c6889-android
Installed as /Users/ahusi/adb-fastboot/platform-tools/adb

global options:
-a listen on all network interfaces, not just localhost
-d use USB device (error if multiple devices connected)
-e …"
…and so on. “reboot” proved not to be permitted at this time, “quit” was a command not found, as was “abort”…
I kept the FP2 connected via USB but am really stuck here. What can I do to get out of this situation?

Did you have a look already here?

I would say, you successfully made Step 3.
Either you continue with step 4, or you go to step 5 for exit the mode.
Did it help?

Thanks! Let me check out that source you quoted, and I’ll be back after.

All right, therob, it looks better after having read that. As you said, Step 3 seems to have worked. Now let’s continue with Step 4 for LineageOS, since that was what I had in mind at the beginning. I’ll return to the LineageOS wiki at “Installing LineageOS from recovery” where it tells me to download the .zip file… etc.
So, yes, your reply was helpful, thanks again!
…hm, if I get lost again, I’ll just return to this topic and hope either you’ll still be awake, or somebody else will be. :slight_smile:

maybe you can also check some thoughts, which i freshly posted about my experiences with the update process:

Maybe it is not that detailed how you need, but could give a nice guideline (which was my hope)

Well, Robert, that is one URL that I saved to my Lineage directory on my Mac. The entire thread offers so much information that I will surely come back to it often. Thanks one more time.
Now back to my installation process, which seemed to go smoothly all the way, but now I have been waiting for the FP to finish the rebooting for almost half an hour… is that normal? If so, how long should I expect it to take? And if there is no change in the display and the logos stay there, what should I do?

reboot after all successful flashing? Should not more than 5-10min i would say…
Which logo do you see exactly?

Fairphone, and “powered by android”

hm…no lineageOS logo…I am uncertain

is there a way to backpaddle a bit and maybe repeat the install? the app “Dateiübertragung für Android” tells me there is no connection…

i dont know… did you disconnect the USB for reboot? And did you flashed now TWRP or already LineageZIP? maybe making a hard shutdown and reboot again (but i don’t know about the consquences…) anybody else?

I pulled the USB cable and tried the power button - looooong… no reaction. Then I tried volume-up plus power button. No reaction whatsoever. Reconnected, Dateiübertragung für Android flagged it had no connection, and so did SyncMate.

so again, you flashed TWRP or LineageOS already?

I flashed the installation zip for LineageOS

mmmm… you asked about flashing TWRP again, but I can’t see why. The wiki doesn’t say anything about flashing TWRP before the installation. Would you please explain?
and are there other ways to force-shutdown the device than the methods I tried

It is booting! wow!
I managed, after removing the battery and replacing it and pressing powerbutton for (more than) 10 sec, and pressing volume-up-and-power… to get back into TWRP and to repeat the installation of the two zips (lineage and arm), and upon “reboot” the blue bow with the moving circle appeared… I’m elated!
so what is left is testing out the new OS (new to me), but I’ll leave that for tomorrow. :smile:

(the question was just “again” to know what you did already. Not that you should do anything again).
so you tried to flash LineageOS following this , correct? Then there is stated, that you first have to flash a custom recovery software (TWRP) by using ADB (under “basic requirements”. And initially I thought, you did this. But you didn’t?!

I don’t know, if it is the only solution, but is is the easiest.
First you have to install TWRP (where you have to use ADB). Then, you can start into TWRP e.g. by pressing vol up + power button. Then the TWRP User interface starts from which you easily can flash the LineageOS zip without any further ADB commands. Only after then you should have running Lineage.
As I don’t know exactly what you did, it is hard to say how to proceed (and I also just know the explained steps and no other experiments).

I guess you have flashed the lineageOS zip directly via ADB, correct? I think that was wrong.

Do you have still access via ADB by typing fastboot devices ?
If yes, I would flash the TWRP zip and try to boot in the TWRP environment.

Meanwhile you wrote, that you managed to boot to lineage (and also to TWRP)! Great!
But this indeed says that you HAD TWRP installed already, which you did not stated clear enogh? I am confused about what you did and what not…sorry.
But good to know, that it seems to work.
Let us know if it is OK now, and maybe again a step be step what went wrong for ohter users NOT doing it…and then we close this topic?!
Gute Nacht.

1 Like

Yes, Robert, I will do that tomorrow, I will answer your questions as well as I can. Gute Nacht.

So let me answer your questions before we can close the topic.

I had the LineageOS wiki open all the time; I still find this installation guide very helpful (although it seems to be very hard for the expert in almost every field to step into the shoes of the absolute beginner and not to be afraid of making the step-by-step too detailed – the reader will always be able to skip the parts that are clear and where they don’t need help).

First off: TWRP was alredy installed, and I have used it repeatedly for backups. What made me stumble was the part about adb and fastboot, and having to use the terminal. (I can’t remember using the terminal and adb in order to install TWRP… I guess I did it using the GUI on my Mac, like this time – but I’m jumping ahead!).

The first time I got stranded yesterday was what made me call for help here, and that was because I didn’t realize that the black screen with the logos (FP and android) didn’t mean that I had arrived at a dead end. I guess that has to do with using the Terminal instead of TWRP directly. So your reassurance and your invitation to proceed helped a lot. It was step 3.2.4 in the guide «Installing Fairphone Open OS using Fastboot», that got me going again: I had already made step 3.2.3 and the Terminal window had given the digits (which I didn’t recognize as the serial number!) and the word «fairphone», and now I proceeded with typing into the Terminal (after dragging-and-dropping adb from the finder into the Terminal! you’ll remember that I hadn’t succeeded in making the adb installation work as it should): «reboot bootloader». Which it did.

From there: What I did differently from the guidelines, though (yours as well as the LOS-wiki’s) was that I transferred the downloaded zip-files into the FP’s external SD using the GUI of the app «Dateiübertragung für Android» instead of the Terminal and adb. Once the zip-files in place, I rebooted into TWRP and used the Install button. The installation itself was fairly quick and ended in «Done - script succeeded: result was… Updating partition details… Done.» and above the Home button the word «Successful». I hit the «Reboot System» button, the FP shut down and rebooted — and stayed on the black screen with the two logos. That was when I asked about the time it would take to finish that reboot.

I got tired of waiting around, so I decided to take the risk and try this and that to proceed. Things only changed after I had removed the battery, replaced it and pressed down the volume-up and the power buttons long enough once more. I got the TWRP-startup screen and repeated the installation of first «» and then «», and when this was successful, I hit «Reboot System» again. And this time it worked like a charm. In less than 5min the screen was the start for the setup in LineageOS.


This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.