Google maps switch always to dark theme to overcome heating. How to avoid this?

How can I overrule fp4 by using Google maps not to switch to dark mode?
If Iam using Google maps it automatically switch to dark mode. I can not switch it off via settings theme in Google maps. If I try this and start using maps my fp4 says it will switch to dark if I still want to use maps.
Hope you have a solution for me to overcome this annoying dark theme?

HI and welcome to the forum

By ‘you’ whom are you addressing. This is a user forum so workarounds may be discussed but I haven’t heard of it being a problem.

Maybe you have battery optimisation enabled ? which will check screen brightness etc.

There are a few reasons for this. It’s either scheduled dark mode or e.g. automatic battery saver. You’re saying you already checked the Google Maps settings, so I won’t go into those.

Hi Amoun, yes i am new in this community. So you should be, does anybody know.
But indeed I have my battery saver switched on. So that could be a possible reason.
I will switch it off and hope it is solved.
Thanks!

1 Like

Hi uppercase, Thanks for the suggestions iwill check.

Battery optimization can be disabled system-wide, or per app. Best is to do it just for Google Maps and not the whole system, if you really want to try that of course. Dark mode should not be triggered by this settings. It more has to do with idle state, putting an app into a frozen state when it’s in the background.

Dear FreK,
did you solve the Problem? I have exactly the same - and no idea how to get rid of it…
Where can I find the relevant battery settings you talked about?
Regards, Bernd

Dear all, after the last Google Maps Update the problem is gone … it obviously was just a bug.
Grrr.
Bernd

2 Likes

Hi all,

I’ve switched googlemaps on and my phone has told me it needs to cool down so goes into dark mode. It looks like this is just a googlemaps issue and not a phone issue. . . Very odd. Anyone else come across this? I’ve got a few apps open but nothing too heavy (Googlemaps, Spotify, Gmail, Whatsapp, Strava, BBC Weather, Facebook Messenger)

Thanks,
Rich

Maybe the weather changed and kept your phone cooler?

I haven’t experienced this problem (yet). I have downloaded my country map though. Maybe that saves compute cycles and heat? Just guessing.

Hi all,
I have the same problem. I don’t have my phone on battery save and my phone doesn’t feel warm at all. I can turn off dark theme when I have the app opened, but when I close and open it again I will get the same notification. I don’t want to have to switch the settings every time I open the app.
I already downloaded the new update but that didn’t fix it.
Is this a Fairphone problem or an app problem?

Thanks,
Brenda