'google keyboard has stopped' error message, driving me nuts!


I’ve installed opengapps on my FP with open OS and now I can’t do anything because I get this ‘google keyboard has stopped’ error message, just won’t go away, can’t type anything. Anyone know what’s up?

You could clear the cache/data of the google keyboard (settings > apps > all) and if that doesn’t help reinstall openGAPPs.

Thanks, tried it, and then play services started giving errors, so tried to reinstall, and the error is still here.

I just reinstalled it, or do you need to uninstall it first to wipe the cache or something? (if so how?)

Probably the Play Store error was there already to, it just didn’t pop up because of the first one.

Unfortunately I don’t think openGAPPs can be uninstalled easily (without a hard reset). At least “normal” GAPPs can’t. But surely uninstalling them first before reinstalling would be better.

I don’t use Google services, but just by searching around for the error message, I found that some people say it’s related to the download manager. Not sure if that is true, but worth trying before you do a reinstall, maybe? Keep in mind that I don’t know anything about this, just copying stuff from the Internet here. Also ensure that the Download Manger is enabled and running.

Clear cache and data

Open your device’s main Settings app.
Touch Apps or Application manager (depending on your device, this may be different).
Touch Google Play Store > Clear cache > Clear data.
Touch the back arrow Back arrow.
Select Download Manager > Clear cache > Clear data.

1 Like

mmm, at a wedding this weekend, so can’t really deal with this right now.
Phone wont even charge now, just gets stuck in recovery mode start up screen.
Seems problems just keep coming :frowning:

Sounds bad. What have you done ‘before’? (You haven’t activated Quickboot or anything, right?)

But before you read on: Forget the phone and enjoy the wedding and the weekend! :slight_smile:

There are many ways you could try to “get” your phone back. I just list them here so you/others can discuss them later. Keep in mind that some might delete the data that is on your phone.

  1. Removing the battery and trying to restart (Are you able to ‘get’ back into the normal Android?)

  2. Wiping (different levels)
    a) Wipe the system cache
    b) Wipe all

  3. Reinstalling (best to return to the official OS to see if the phone hardware is working correctly)

Ok, I was on an Island fussing with a broken phone, maybe it was a sign to disconnect :wink:
So the wedding was great!
We were in Turkey and the second day my battery was all gone and then I think the power system there must be different, because it just would start up in recovery mode screen and not charge. Once back home my phone could charge again. Same charger as always, normally it will also charge on my laptop but now it was just to dead I guess?
So don’t let your phone get without power when traveling? (maybe this is already a topic somewhere)

Back to clearing the cache data…

mmm tried clearing the cache data following the steps you described earlier, but I still can’t open Play Store. Keep getting the pop up:
Unfortunately Google Play store services has stopped.
My Location services is turned off.
Does anyone have some other idea?
If not I’m switching back to the normal OS, this just isn’t working…

Please, could you check the following to be absolutely sure:
Go to Settings,
Go to Location
Is Location grey with the words ‘Off’?
And if it is grey, please switch on and then off again.

Yes I did that, but nothing. Thanks for the suggestion!
There’s something seriously wrong with my OS, even the clock app stopped working.
I’m trying to reinstall the whole OpenOS but it’s not seeing my device so I’m gonna try just installing the normal OS now…

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.