Google chrome and play not working? Fair phone 2

Hi, I am a new owner of a fairphone 2.
I am having trouble with using chrome and googleplay store.
I can’t find anything relating to my topic on the forum for a fairphone 2.

I noticed the problem when I was setting up my phone. I transfered everything across from my old phone and was downloading apps. It would only download some? I couldn’t download Instagram and facebook. I didn’t have these on my old phone, so I thought this could be the reason?

I eventually downloaded them through the website, but I am trying to download hostelworld app and that nots working either??

Then when I try to use instagram, at first it worked, but now it won’t let me upload any pictures and it just says ‘chrome has stopped working’.
So I think the problem is with chrome overall.

Not sure how to solve this issue, everything looks up to date when I check. I have tried deleted chache data numerous times and restarting the phone, but it doesn’t seem to make a difference. It says googleplay is up to date.
I have already tried to contact customer support and looked throught the forum lots of times.
If anyone knows anything, any help would be appreciated!
Thank you
Kind regards

Just to be 100% sure a few questions first:

Are you running your FP2 with the pre-installed system or did you switch to the Fairphone Open OS? Did you run through the entire initial setup process and logged in using your Google Account? And when you say you download apps you mean from the Play Store, right?

What happened exactly when you tried to install those three apps?
That they were not installed on your old phone can’t be the reason why you can’t install them on the new phone BTW.

Thank you do much for your response.

I ran with the pre-installed system, but then I did update the system to
the latest. I thought that could be why the Instagram app is not
functioning correctly, perhaps I have to update chrome? Not sure how to do

I don’t remember logging into Google. When I set it up, it asked me to put
my old phone next to it to transfer data.

Yes, I mean download apps from the play store.

When I tried to install the apps, I click the ‘install’ button but nothing
happens. At all? Like it isn’t registering?

Thanks again for your response. Any help is really appreciated :slight_smile:
Kind regards

It might be worth investigating use of “Safe Mode” before resetting device:

Hi, I thought I had replied.
Did you get my message? Thank you for your help.
I was logged into chrome with a different account. Once switched, it worked fine.
Thank you again for your help.
Kind regards

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.