Google Apps keep reinstalling/ reactivating

I recently mad the same obervation when trying to degoogle ny Mate 9 running Android 7.
At the moment I am running out of time but I will investigate.

I believe “install-existing” depends on the Android release, not adb.

Without further knowledge I see two options.

  1. Try to get the package with Aurora or download from Apkmirror and install it.
  2. If that does not help and you need the functionality urgently, factory reset, but this is the least I would consider.

I’ll have some time on thursday an will report back.
In the meantime don’t use the “uninstall” command but “disable-user” which I have testet under android 7. It can be reversed using “enable”.

PS: I should be possible to use the “install” command. The system just does not know where to find the given package. With adb you could use the “find” comand or 'ls" and combine it with "| grep ".

These are the packages that I uninstalled:

com.qualcomm.qti.qms.service.telemetry
com.google.android.youtube
com.google.android.ext.services
com.google.android.googlequicksearchbox
com.google.android.onetimeinitializer
com.google.android.ext.shared
com.android.protips
com.google.android.apps.messaging
com.android.vending
com.google.android.marvin.talkback
com.google.android.apps.work.oobconfig
com.android.launcher3
com.google.android.deskclock
com.google.android.gm
com.google.android.apps.tachyon
com.google.android.setupwizard
com.google.android.apps.wellbeing
com.google.android.dialer
com.google.android.apps.docs
com.google.android.apps.maps
com.orange.update
com.google.android.contacts
com.google.android.syncadapters.contacts
com.android.facelock
com.android.backup
com.google.android.calculator
com.android.chrome
com.google.android.tag
com.google.android.tts
com.google.android.gmsintegration
com.google.android.partnersetup
com.google.android.videos
com.google.android.feedback
com.google.android.apps.photos
com.google.android.calendar
com.android.providers.partnerbookmarks
com.google.android.gms.policy_sidecar_aps
com.google.android.backuptransport
com.google.android.apps.youtube.music
com.orange.aura.oobe
com.google.android.inputmethod.latin
com.google.android.apps.restore
2 Likes

Which of these is really necessary for receiving SMS and why? Can I dump com.google.android.ims (Carrier Services)?

I don’t know. I linked to the post where I got the info from.
The internet didn’t come up with much on that for me either.

1 Like

On my FP3 I have deactivated …

com.google.android.gsf
com.google.android.gms
com.google.android.ims

… and can still send and receive sms.
I am using the Lineage sms app.

There may exist contradictive information, maybe it even depends on android version or vendor.

2 Likes

Just uninstalled the three packages. For gms I got:

FP3:/ $ pm uninstall --user 0 com.google.android.gms
Failure [DELETE_FAILED_DEVICE_POLICY_MANAGER]

and had to go to “Apps for device managment (Security and Location)” first and disable device management “Find device”. I seem to remember that I had already done this… :thinking:

:exclamation: I can still receive and send SMS using QKSMS.

Edit.: The section in the settings for system updates is gone! That should be no problem though, when Fairphone releases stock images…

1 Like

@Stefan
You could as well do a “install-existing” to get it back, then deactivate it via app settings and if you’re in the mood for an update check simply activate it temporarily. After that you’ll immediately get the system update menu back …
This is how it works for me.

1 Like

Just to clarify, here my recent experiences with the update process:

  1. Keep an eye on VPN / firewall software to not block internet access for the following services.

  2. You need Google play services activated for the update menu to appear.
    com.google.android.gms

  3. You need Google services framework activated otherwise the update check will not really work.
    com.google.android.gsf

  4. After the update disable both of them if you don’t want them to run by default. Deactivating com.google.android.gms only succeeds if you disable it as a device admin (Even if you disabled it before it registers itself again after the update.)

6 Likes

Same issue on FP3, havent figured a solution yet.

I moved your post here.
How to deactivate Google Apps for good is described in this topic.
I did that myself, including Google Chrome.

What I’ve done it’s based on the @AnotherElk message above.

I’ve installed from F-Droid :
Same as AnotherElk, except

  • I’ve installed Open Camera (really good aps)
  • Simple Contacts
  • SImpleKeyboard, but I think I’ll install AnySoftKeyboard which is open source and really useful keyboard (i’ve this app before flashing back my phone)
  • Amaze
  • Firefox (from Aurora Store)
  • K9mail
  • NewPipe (frontend for YouTube, really good)

I’vnt installed Lawnchair because I didn’t understand what Launcher do (so I’vnt uninstalled it), and because it’s not maintained anymore.

I’ve uninstalled all the apps I’ve uninstall anotherelk. And now, I’ve just realized that I’ve uninstalled dialer without reinstalling one. I’ll edit to say what I’ll do. (for the moment, i can’t call and be called :stuck_out_tongue: )

I’ve modified this parameters :

  • Applications and Notifications > By default applications Application on home page > Show Google App (off)
  • By default applications, I’ve put VLC and QKSMS
    (maybe i’ll give a try to other Telephone apps or Signal for SMS, i’ll see after)

All works fine, except maybe the call :3

I’ve tried, and that doesn’t work. Same for Emerald Dialer of course.

I’ve reinstalled the com.google.android.dialer because I need to be able to call for the moment. But I encounter another problem : I can’t hear my cocaller when I call, but he can hears my voice during a call : the sound of him doesn’t come to me.

To be sure, I’ve given again all the permissions to Google Play Services, but it’s still broken. I’m still investigating.

Did you install the September 21, 2018 variant of the App, not the newer one? That’s important.

1 Like

Yes, choosing that version really matters, the other doesn’t work properly. Now I remember that that was important to attend the call when the phone was blocked. I commented in the other thread that setting Lineage Phone as defaulf app can be relevant too.

1 Like

I tried removing some apps using adb but i got “Failure [not installed for 0]” even though the app is installed. Does anyone know a way to fix it?

Welcome to the community forum.

Can you post a screenshot of the complete adb command and the error message?

terminal-error

That’s it there with some apps failing and some working, but all the apps that failed are installed.

Assuming this is Linux …
If you used the adb command your Linux distribution already had installed or offered to install via packet manager or Software Center of some sort, please try again with the adb command from the current Android SDK Platform Tools.

Else …
“Uninstalled” Apps may still be listed in the App list with a note that they are not installed for the current user. If that would bother you …

Could anybody please explain me how to do this? Which buttons I have to press?
I can’t find that. Or is it just working on stock Android and not with the /e/OS Android?