Google Apps keep reinstalling/ reactivating

Well, it would still need another app to do the “phoning home” for it, right? If both apps voluntarily work together they don’t need to run as the same user/dev key. One could simply open a local socket which the other talks to or use a myriad of other mechanisms through which apps can communicate with each other.

But that means if you trust all the apps that CAN do internet connections, then you don’t need to worry too hard about the ones who cannot. They could still collect all sorts of data about you but they cannot “call home” without a messenger.

For most google apps “google play services” is this one-fits-all messenger, and most google apps/services won’t work anymore if you uninstall google play services.

One problem that I ran into is system services that are not apps. As such, they can not be uninstalled or disabled, since they are device drivers. But they still can access the internet (in fact you can’t deny it since the access restrictions policies only apply to apps, not to operating beneath that layer)

Google apps rarely sink “that low” (scnr) - but unfortunately Qualcomm does, as I have documented here.


Hello AnotherElk,
the situation, that an uninstalled App is still shown in the app list but with the notice that it is not installed for the current user, is caused by updates of this app which were installed before uninstalling the app.
The app and the message will disappear, if you uninstall all existing updates.
Uninstalling these updates should be possible in Settings - Apps


Nice. Thanks.

Hello s99h,

I tried to reinstall an App with “cmd package install-existing” following the information in your post.
I wanted to do this on an phone with Android 7.1 installed
But I received the answer:

cmd package install-existing
Unknown command: install-existing

I checked the help of “cmd package”. The help does not include any information about “install”.
Do you know if the availability of “install-existing” for the Package service depends on the Android version?
Or on the ADB version installed on the PC?

Do you know any way to reinstall a (Google) App on Android 7.1, which has been uninstalled with the

pm uninstall …


I did not succeed with the

pm install

command. No matter what switches I tried.

I recently mad the same obervation when trying to degoogle ny Mate 9 running Android 7.
At the moment I am running out of time but I will investigate.

I believe “install-existing” depends on the Android release, not adb.

Without further knowledge I see two options.

  1. Try to get the package with Aurora or download from Apkmirror and install it.
  2. If that does not help and you need the functionality urgently, factory reset, but this is the least I would consider.

I’ll have some time on thursday an will report back.
In the meantime don’t use the “uninstall” command but “disable-user” which I have testet under android 7. It can be reversed using “enable”.

PS: I should be possible to use the “install” command. The system just does not know where to find the given package. With adb you could use the “find” comand or 'ls" and combine it with "| grep ".

These are the packages that I uninstalled:


Which of these is really necessary for receiving SMS and why? Can I dump (Carrier Services)?

I don’t know. I linked to the post where I got the info from.
The internet didn’t come up with much on that for me either.

1 Like

On my FP3 I have deactivated …

… and can still send and receive sms.
I am using the Lineage sms app.

There may exist contradictive information, maybe it even depends on android version or vendor.


Just uninstalled the three packages. For gms I got:

FP3:/ $ pm uninstall --user 0

and had to go to “Apps for device managment (Security and Location)” first and disable device management “Find device”. I seem to remember that I had already done this… :thinking:

:exclamation: I can still receive and send SMS using QKSMS.

Edit.: The section in the settings for system updates is gone! That should be no problem though, when Fairphone releases stock images…

1 Like

You could as well do a “install-existing” to get it back, then deactivate it via app settings and if you’re in the mood for an update check simply activate it temporarily. After that you’ll immediately get the system update menu back …
This is how it works for me.

1 Like

Just to clarify, here my recent experiences with the update process:

  1. Keep an eye on VPN / firewall software to not block internet access for the following services.

  2. You need Google play services activated for the update menu to appear.

  3. You need Google services framework activated otherwise the update check will not really work.

  4. After the update disable both of them if you don’t want them to run by default. Deactivating only succeeds if you disable it as a device admin (Even if you disabled it before it registers itself again after the update.)


Same issue on FP3, havent figured a solution yet.

I moved your post here.
How to deactivate Google Apps for good is described in this topic.
I did that myself, including Google Chrome.

What I’ve done it’s based on the @AnotherElk message above.

I’ve installed from F-Droid :
Same as AnotherElk, except

  • I’ve installed Open Camera (really good aps)
  • Simple Contacts
  • SImpleKeyboard, but I think I’ll install AnySoftKeyboard which is open source and really useful keyboard (i’ve this app before flashing back my phone)
  • Amaze
  • Firefox (from Aurora Store)
  • K9mail
  • NewPipe (frontend for YouTube, really good)

I’vnt installed Lawnchair because I didn’t understand what Launcher do (so I’vnt uninstalled it), and because it’s not maintained anymore.

I’ve uninstalled all the apps I’ve uninstall anotherelk. And now, I’ve just realized that I’ve uninstalled dialer without reinstalling one. I’ll edit to say what I’ll do. (for the moment, i can’t call and be called :stuck_out_tongue: )

I’ve modified this parameters :

  • Applications and Notifications > By default applications Application on home page > Show Google App (off)
  • By default applications, I’ve put VLC and QKSMS
    (maybe i’ll give a try to other Telephone apps or Signal for SMS, i’ll see after)

All works fine, except maybe the call :3

I’ve tried, and that doesn’t work. Same for Emerald Dialer of course.

I’ve reinstalled the because I need to be able to call for the moment. But I encounter another problem : I can’t hear my cocaller when I call, but he can hears my voice during a call : the sound of him doesn’t come to me.

To be sure, I’ve given again all the permissions to Google Play Services, but it’s still broken. I’m still investigating.

Did you install the September 21, 2018 variant of the App, not the newer one? That’s important.

1 Like

Yes, choosing that version really matters, the other doesn’t work properly. Now I remember that that was important to attend the call when the phone was blocked. I commented in the other thread that setting Lineage Phone as defaulf app can be relevant too.

1 Like

I tried removing some apps using adb but i got “Failure [not installed for 0]” even though the app is installed. Does anyone know a way to fix it?