Google Apps can't be reinstalled

Whoops! Sorry. I saw my other posts in the list and obviously got confused! :smiley:

I for my part installed the upgarde and and then the storage upgrade but still no luck. Hopefully @Marco will post a status update soon. It’s frustrating to have a not working phone. All my contacts are in google, so I can’t even access my contact :angry:

No. I didn’t see the email. It just popped up on my phone that there was a software update. So it brought me to the updater and I went forward with that. So I never saw the the ‘pre-updater’…

Any official fix or workaround yet?

1 Like

Where would we see news on an official fix?
Here?
https://fairphone.zendesk.com/hc/en-us/sections/200366029-Announcements

1 Like

A Fairphone Employee will surely post it on the Forum as soon as there is one

PS:

2 Likes

Thanx allot!! This was the workaround that helped!

OK, after downgrading my FP1 to 1.6 i had to upgrade to the pre-update 1.8.5 first, but after that the 1.8.5 update worked and i didn’t get stuck at the gapps loop :blush:

1 Like

Thanks a bunch! This did the trick for me.

1 Like

Hi all,

I’m absoluteley not a techie.
I started yesterday with the upgrade and immediately after that reading on the forum.

How can i downgrade to 1.6?

I was in version 1.8 after having repartitioned myself.
The upgrade with the fairfone updater didn’t work so I upgraded manually with to the version with ‘unified’ filestorage.

Now i’m in 1.8.5 but i’m stuck in the GApps loop.
As the downgrading to 1.6 and then upgrading to the new 1.8.5 seems to work, i would like to perform this.
HOW???
I downloaded the 1.6 updater. But i can’t get it working. When i try to install it manually from SD-card in recoverymode the phone doesn’t recognize any folder on the sd-card.
Someone help?
thanks,
Marijke

1 Like

Hey Higoshi,
could you explain which way worked for you that well? I’m still in the loop and it gets a bit annoying:)

Best,
Jonathan

Hey again,
so now I tried to downgrade my phone to 1.6 with the Fairphone Upgrader app. It downloads a while, asks for a reboot. After booting again it still runs on 1.8.5 -.- what am I doing wrong?

Hi there,

in this post, everything is described:


Hope you get through!

Thanks Man!!! Works also for me!! :smile:

Dear all,

I know there are a lot of posts in this thread as well as in the update 1.8.5 thread.
I spend last evening finding a workable solution. There is only one solution (for now): manual downgrade using the ‘bricked’ procedure. I described in detail in reply #82 - Google Apps can’t be reinstalled - what you can do to get out of the gapps update loop.

If you feel uncomfortable with the flasher software, then wait for an official repackage of v1.8.5.
If you don’t mind installing some extra software and are willing to go the flasher/bricked option, see reply 82.

In short the procedure is: flash 1.6 unified using SP flasher -> update to 1.8.5 using FP update -> install gapps using FP update -> done!

Don’t try to install any other version through the recovery mode, it won’t help you since there is no way to install gapps afterwards reliably (e.g. through recovery). The recovery in FP1 isn’t good enough. We need a reliable ClockWorkMod Recovery or similar for FP1 but there isn’t one.

@Kephson has a slightly faster method, but then he (or someone else) needs to publish a ‘scatter’-file for the V1.8.5 image for FP1.

On the bright side: if you go the flasher route, you will automatically have a FP1 with Unified storage. (in other words: 1 big storage disk).

Caution once again: BACKUP! and use this method only if your stuck in the loop and feel comfortable with flashing.

I urgently need an official repackage of v1.8.5. - I use my phone for both private and business purpose and it’s totally spoiled after the update:

  • calender with all private and business appointments deleted (major problem for me!)
  • swipe function gone (makes me answering emails quiete slow)
  • google playstore disappeared
  • weather and news app broken (needs some installations again and again and again and …)

Maximum user annoyance reached… If you ever think about an update - please don’t do it! :frowning:

1 Like

@F_Barrenbach, help us help you:

  • what version are you on now?
  • did you do a manual update, if so from what version?
  • did you have a unofficially repartioned device? (the 4GB hack using Meteos)
  • did you make a backup of your data before the upgrade?
  • do you use google as a calender and contact store (log into www.google.com/calendar and www.google.com/contacts on a pc to check), if so not all is gone

It seems that you didn’t succeed in installing gapps, correct? All but the first will resolve itself if you manage to install gapps. The first will also resolve itself if and only if you use google as a contacts/calendar store.

I have FP1U, Kola Nut 1.8.5 ; update by activating the Fairphone Upgrading App yesterday evening, about 10 p.m. - noticed first installation failed, did it again. Then it worked, clicked on Google App package - install - agree to licence - waited half an hour.

No unofficially whatever.

No backup. Didn’t expect any problems for my apps.

The calender is still available in google, but I can’t synchronize it with my FP calender any more - “No rights for synchronization with this server. Contact your server admin.” (whatever this means).

@F_Barrenbach OK, am I correct in saying that you have no working google apps (most importantly play store)?

If so, then you have a different problem then most of us in this topic. You came the official route from FP1U and still got stuck. Are you in what most of us call the google apps reinstallation loop? (every time you reboot your phone wants you to reinstall google apps?)

I can see that this is very annoying for you, luckily your data is still intact, you just can’t connect to it. As frustrating as it may seem, you are in way better shape than most…

I am reluctant to advise you what to do other than trying to reinstall google apps as described by FP. All the other routes will cost you more and you may end up spending a lot of time trying.

A backup wouldn’t have hurt, but in your special case it wouldn’t have helped you either… you need to reconnect to google and then everything will magically resolve itself.

(@anon12454812 @Marco first in the wild failed gapps update coming from FP1U not using the manual recovery???)

1 Like

Hi,

Any news on the v1.8.5. repackage? I am on the GAPPS install loop after doing manual updates to v1.8.5 and then V1.8.5 unified partition. I had changed the partitioning way back and v1.8.5 would not install through the updater, complaining about not enough space in /cache.

Would rather wait for an official version, instead of going the flashing the phone route, if a solution is coming some time soon.

1 Like

For the people who want to flash their phone with SP tools with 1.8.5, here is the scatter file which was build with the Mtk Droid Tools:

For me this file worked with SP Flash Tool v3.1312.0.139 and the MT65xx drivers for FP1U.

2 Likes