New software update Kola Nut 1.8.5 is ready


If you unofficially repartitioned your first edition FP1 yourself in the past, I’m afraid you will keep on having issues. Read more here how to solve this: New software update Kola Nut 1.8.5 is ready


Hi rick,

“keep on having issues” is a bit frustrating. I hoped to read a better solution.

I’m absoluteley not a techie.
I started yesterday with the upgrade and immediately after that reading on the forum.

I was in version 1.8 after having repartitioned myself.
The upgrade with the fairfone updater didn’t work so I upgraded manually with to the version with ‘unified’ filestorage.

Now i’m in 1.8.5 but i’m stuck in the GApps loop.

As the downgrading to 1.6 and then upgrading to the new 1.8.5 seems to work, i would like to perform this.

I downloaded the 1.6 updater. But i can’t get it working. When i try to install it manually from SD-card in recoverymode the phone doesn’t recognize any folder on the sd-card.
Someone help?


Yeah, it sounds like we’ll have to do some jiggery pokery to factory reset. I don’t know, sounds like I’ll need to buy a new phone as I don’t have the time or energy to do this.

1 Like

is it necessary to install “all” google apps with the Google Updater Widget or can i just download the play store and then download myself the apps I want to have (whatsapp, maps etc)? Can I sync my google contact list with my fairphone without having the google apps?


Dear all,

I know there are a lot of posts in this thread as well as in the update 1.8.5 thread.
I spend last evening finding a workable solution. There is only one solution (for now): manual downgrade using the ‘bricked’ procedure. I described in detail in reply #82 - Google Apps can’t be reinstalled - what you can do to get out of the gapps update loop.

If you feel uncomfortable with the flasher software, then wait for an official repackage of v1.8.5.
If you don’t mind installing some extra software and are willing to go the flasher/bricked option, see reply 82.

In short the procedure is: flash 1.6 unified using SP flasher -> update to 1.8.5 using FP update -> install gapps using FP update -> done!

Don’t try to install any other version through the recovery mode, it won’t help you since there is no way to install gapps afterwards reliably (e.g. through recovery). The recovery in FP1 isn’t good enough. We need a reliable ClockWorkMod Recovery or similar for FP1 but there isn’t one.

@Kephson has a slightly faster method, but then he (or someone else) needs to publish a ‘scatter’-file for the V1.8.5 image for FP1.

On the bright side: if you go the flasher route, you will automatically have a FP1 with Unified storage. (in other words: 1 big storage disk).

Caution once again: BACKUP! and use this method only if your stuck in the loop and feel comfortable with flashing.


@MDP @TheoGB see post Google Apps can't be reinstalled and Google Apps can't be reinstalled.

Based on the technical skills needed of what you already tried you should be fine going the flasher-route.

@JonathanSchreiber yes, unfortunately google apps is a one package solution… there are a couple of google apps that need to be installed as an android upgrade instead of just installing it as you would with normal apps.

Thanks for your work and investigation in this problem.

For myself I would feel comfortable enough to go the flasher way. But I’d like to get some update from @anon12454812 and @Marco on this topic, when we can expect a fix!

I there any update of you progress?

A “we are not ready today, but we guess we will have something by friday” would be at least something :wink:

1 Like

@SHuber Since you are where you are (in the gapps loop or you did a manual upgrade or you used the Meteos repartition), you will probably need an unbrick procedure anyway.

If there is an option to fix the gapps installer for the stuck-peoplem that would fix most of the problems… but I am unaware of such an easy fix.

The only other option I can see FP (@anon12454812 or @Marco) providing that would work is a ClockWorkMod port for FP1 or similar (so we can use Recovery to get out). Since the cache partition isn’t big enough for a new update and some of us have already repartioned again while going to 1.8.5 they (FP) are out of easy options.

A worst case scenario would be a ‘bare minimal’ version (under 120mb) so the cache partition becomes an option. Then repartion once again and then back to 1.8.5 as planned.

@daveboschma Thanks for your reply. In your post your instructions you mentioned

Offtopic: I think something still needs fixing, because I now have a
recovery that is not accepting my external SD, that didn’t magically go

Did you find a fix for that? I would prefer to have a fix where I can be sure that I don’t have setup my phone from scrap again :smile:

That’s what I said about the need for a better Recovery like CWM. To my knowledge 3e recovery simply can’t handle the external SD. Only if such a recovery becomes an option and we can the flash gapps using recovery will you be spared another setup from scratch.

thank you for your help!i’m gonna try it now although i don’t feel comfortable at all with the flasher software. Maybe the good thing is that i absolutely have no idea what this software does and therefore what can go wrong.I’ll keep you informed if it worked fine for me or not.

@MDP It’s a piece of software that forces your phone to reinstall itself by telling it where to store what data, while it is sending that data over the cable. You can visualize this as multiple recovery flashes in one go, with a repartion on top. You will end up with a almost factory-like 1.6 FP1U in a matter of minutes.

The only thing that can go wrong is if your pc crashes during flashing or if you disconnect battery or cable while flashing. That would be bad… (although I am not sure if you could just retry if that happened, and I am not volunteering to try…)

1 Like

Maybe this is a completely stupid idea, but as I mentioned earlier, I’m not a techie.

Can’t I just go back to factory settings and then do an official fairphone update?
I have the fealing that I have to recustomize my fairphone anyway

Good idea or not?


I had the problem that the file was not found.
I kept the screen active and it worked out!

  • strange :wink:
1 Like

I moved a post to an existing topic: Google Apps can’t be reinstalled

Error: “Unfortunately, Android keyboard (AOSP) has stopped.” - After updating to 1.8.5 from 1.6 via the pre-update-solution. What to do?

I got the notification for the update. I tapped on the notification and the app told me I was on Kola Nut 1.8 and could upgrade to 1.8.5. (I did read the words pre-update solution, I didn’t think that applied to me, being on 1.8 already.) I tapped Upgrade. Within 10 seconds I was told to restart the phone for the next step. I tapped the Restart button. Phone was restarted, I saw the upgrade icon and process, and the regular boot sequence screen. This went very fast! I saw a notification for upgrading the app store, which I ignored because I don’t want the app store.

But how can I see which version I am on? The upgrade went very fast and I don’t see any difference. I don’t remember how the previous launcher looked (I do remember a lot of talk about the new design). My icons were still in the same place on the home screens. I don’t remember installing a different launcher… How can I check?


Still a very happy FP (2nd batch) user!

Edit: when I started the FP Updater process manually, it said I am still on 1.8 and now I can update. It’s downloading now, taking more time than the first step. So the first step was really a pre-update solution. OK, slightly confusing, but it’s updating now… And yes, now I have to put all the icons back on the home screen. Not a big deal. But how can I check my version?

You can just open the updater app again. It should tell you which version you have installed right now.

Hi, I was installing the update yesterday evening. Had to restart the phone twice, after the second restart I got the screen saying “Kola nut 1.8.5 successfully downloaded” (i think it was that, not installed) and then there was a button to restart the phone again… not sure if this was the step for installing google apps? Anyway… I left my phone to get on with the installing on its own and when I looked at it next it was in recovery mode… Then I stupidly clicked on “update device with adb sideload” - now all I see is the das android image and the message "Now send the package you want to apply to the device with "adb sideload “…”.
Is there any way I can get back to main menu? Volume Up/Down buttons do nothing, and the Power button only makes message dissappear and then appear when I click it again. Is there something else I can do to save my files? When I connect the phone to my computer it doesn’t recognize it…
I’m not particularly tech-savy but think I could handle it if I get clear instructions of what to do! :wink:
Hope somebody can help!