Google Apps can't be reinstalled

Hi Stefan & others,

  1. The Kola Nut for first batch is actually Kola Nut for non-unified partition which will not erase your data and partition layout will remain the same after update.

  2. If you have run the Storage Upgrader instead and thus have the unified partition afterwards, you have just updated to Kola Nut and don’t need any other package. (Here happened some error in first weeks’ package: Fairphone assumed everybody to have run first upgrade as of (1) and only afterwards run optionally the Storage Upgrader, now applying this Storage Upgrader is enough if you want to get unified partition.)

  3. If you have already upgraded to unified partition before (the official one provided by Fairphone starting with 1.6 or you just own Fairphone1 2nd batch which already comes with unified partition), then you would want to upgrade using Kola Nut for Fairphone1 2nd batch, also known as FP1U.

This means:
If you have manually done any repartitioning before and want to upgrade your OS you might want to run the current Storage Upgrader. It will repartition your system, which means you will lose your data, so do a full backup first. Afterwards you have both: an official storage layout and Kola Nut installed at the same time.


I think I’m about to give up on Fairphone. Stick it in a box and send it back. It’s not been a great phone from day 1. But now its almost not a phone anymore.

I have an original FP1 that was running some older but not that older version, 2 partitions with the annoying problem of not being able to install or update apps. No weird patches, no hacks, just FP software, plus the usual stuff from the Play store.

Yesterday i went on a merry dance something like this:

  • upgrade to 1.6 (using old fairphone updater app)
  • Repartition storage option (in the new updater app) - lots of pain, cycles around etc
  • upgrade to 1.8.5 - blue screens for ages, lots of reboots with no success
  • ran storage fixer from bitly link
  • upgrade to 1.8.5 - success
  • install google app - fail, in a forever cycle, often with the no command error, but sometimes with a android installing action, but then the phone restarts and we are back to install google apps again.

Also a it no longer mounts as USB drive, i can foresee a lot of problems fixing it.

I’ve tried running the storage fixer again, rebooting, trying again and again. I’ve tried to display always on hack (what!?) but nothing gets it unstuck.

Fairphone support looked at the disk-space used after repartitioning and as it says 13.40 GB not 13,37GB they suggest that I’ve used a unsupported partitioner.

Now I’m worried that they are washing their hands of a problem that they have generated. Has anyone else has the same problem? Is this a general problem that fairphone and blind to? Is there a non-warranty voiding solution?

You can always run manually any time the FP1 Storage Upgrader 1.8.5. It will wipe your data, but you will end up with recent Fairphone OS and support partition layout. You should be able to install Google services from the Fairphone Updater afterwards without ending in a loop.

If you’re given an error code by Google you can look up the meaning on pages like

Thanks for the thoughts. How do I run the FP1 Storage Upgrader 1.8.5? I need to copy the file to the phone right?

The phone no longer mounts as a USB device. It thinks it does but neither of my computers show the phone as connected.

Oh there are no error codes displayed… Is there a log that I could take a look at via the phone?

I believe you have two options

  1. When you can start Fairphone OS normally, it should be available in the Fairphone Updater App probably inside the advanced options. But I cannot tell any further details here, because I don’t see them any more.
  2. By the manual upgrade as mentioned and linked before by @paulakreuzer in article 264. You must have adb installed e.g. from, you download the Storage Upgrader zip file on your computer, you reboot your phone into the recovery mode, you then connect your phone via USB to your computer, and then you choose the option “adb sideload” (similar wording, look for the “sideload” keyword in the recovery menu), and then you send your downloaded Storage Upgrader Zip(!) to your phone by issuing "adb sideload ".

(1) Sadly the Storage Upgrader isn’t available as the advanced settings in the updater app.

(2) this option sounds like exactly the sort of thing that FP support warn me about doing that would void any warrenty/support - doing stuff to the system that isn’t directed by FP - and i guess would also require the phone working with USB connections, which it currently doesn’t seem to.

Well, the Software you would install is officially provided by Fairphone. Fairphone offers even some recommendations on this page when installing manually. The phone will be visible to your computer, i.e. the required command “adb sideload” when you select “apply update from ADB” in the recovery.

I found through experiments that I needed an SD card inserted, and I need to download with the USB power plugged in but install with the wire removed.

In recovery mode I wiped everything i could. I reinstalled 1.8.5 for the nth time, a couple of times and then installed google apps.

It seemed weird incantations and combinations of things works, why having the SD card plugged in makes the storage work I really don’t know.

Now it works, anyone want to buy a FP1? Small dent in corner

Cool that you have made it work out :slight_smile:

what is that?

That is great! :wink: That is something @keesj should definitly look into: You say the Google Apps install was only possible with an SD card?

I wonder, btw. how you did the upgrade to 1.8.5. without sd card?

I don’t really get it and by now I am kind of annoyed.
Here is what I did:

  • Fairphone of first batch without unified storage
  • at some point, I unified the storage with the fairphone updater (I think it was with 1.6)
  • time passed by
  • 1.8.5 released
  • I did the initial update
  • something went wrong
  • applied manual update of the 1.8.5 again
  • problem remains
  • fix came out (permanently granted root)
  • applied fix successfully
  • the state remains after reboot. Still not able to install Google Apps (Download starts within the fairphone updater but then suddenly the download stops and the updater returns to the screen before where I can hit “install” again.

Isn’t there a Gapps package that I can download and flash manually?
I am looking for a solution that solves this without wiping the whole thing.

If you unified your storage in 1.6 then you didn’t need to unify it again in 1.8.5 so you didn’t need the fix either.

I’m afraid no.

You could first try just wiping the updater app’s cache and data.

I didnt unify the storage again. I picked the update file for devices with already unified storage (for the manual update)
The fix was presented in another thread as to solve the google apps issue.
However clearing data of the fairphone updater brings no solution at all.

This fix was for people who installed the buggy 1.8.5 storage upgrade before it was retracted on May 20th.
It did solve the Gapps problem for these people but it was never meant for people who already unified the storage before 1.8.5.

Btw, what exactly did you mean with:

Did you successfully update to 1.8.5 or didn’t it work yet? (The updater app should look like this)

Yeah, looks exactly like this. And yes, 1.8.5 is successfully updated.

And with something went wrong I mean I cannot install google apps. It fails every time I try it in the updater.

Have you tried to run the update to 1.8.5 again (go to the Fairphone Updater’s Advanced Mode and click “Current Version Fairphone OS 1.8.5” and then “install”)?

In some cases something goes wrong during the update process, which is fixed by rerunning the update.

After I flashed it manually I did not re-run the installer.
Will it work although the updater app says my firmware is already the newest?

That’s what I’m saying. Click install although it says that your current version is 1.8.5! :slight_smile:

I encounctered a problem which I could not find discussed in the forum up to now:

  • I get the error message “The process was stopped” --> “OK”.


  • I often notice the message directly after enabling WiFi, and I think it only appears, after the Playstore did an automatic update of itself
  • before the message a have grey WiFi symbol --> Message --> automatic update of playstore (–> sometimes message dissappears) --> blue WiFi
  • Problems just popped up after I updated with the FP-Updater from 1.6 --> 1.8.5 + installed successfull the GAPPS afterwards
    (for completelyness I did one additional step: 1.6 --> Pre-Update 1.8.5 --> GAPPS --> 1.8.5 --> GAPPS)
  • I have not applied the UnifiedStorageUpgrade yet
  • I can use GooglePlaystore + calender sync like normal, just the error message seems weird…

Any ideas? Wiping the cache from PlayStore-App (do I lose anything?)?
Cheers, Robert

Did you already download any app from the play store after the update? Usually that makes the wifi symbol stay blue and it might solve your other problem as well.

If you are planning to update your storage which is recommended you don’t need to try something like wiping the gapps cache, because you’ll have to reinstall gapps afterwards anyway. (Actually the storage update wipes everything so you should make a thorough backup first.)