Google Apps can't be reinstalled

Dear all,

I know there are a lot of posts in this thread as well as in the update 1.8.5 thread.
I spend last evening finding a workable solution. There is only one solution (for now): manual downgrade using the ‘bricked’ procedure. I described in detail in reply #82 - Google Apps can’t be reinstalled - what you can do to get out of the gapps update loop.

If you feel uncomfortable with the flasher software, then wait for an official repackage of v1.8.5.
If you don’t mind installing some extra software and are willing to go the flasher/bricked option, see reply 82.

In short the procedure is: flash 1.6 unified using SP flasher -> update to 1.8.5 using FP update -> install gapps using FP update -> done!

Don’t try to install any other version through the recovery mode, it won’t help you since there is no way to install gapps afterwards reliably (e.g. through recovery). The recovery in FP1 isn’t good enough. We need a reliable ClockWorkMod Recovery or similar for FP1 but there isn’t one.

@Kephson has a slightly faster method, but then he (or someone else) needs to publish a ‘scatter’-file for the V1.8.5 image for FP1.

On the bright side: if you go the flasher route, you will automatically have a FP1 with Unified storage. (in other words: 1 big storage disk).

Caution once again: BACKUP! and use this method only if your stuck in the loop and feel comfortable with flashing.

I urgently need an official repackage of v1.8.5. - I use my phone for both private and business purpose and it’s totally spoiled after the update:

  • calender with all private and business appointments deleted (major problem for me!)
  • swipe function gone (makes me answering emails quiete slow)
  • google playstore disappeared
  • weather and news app broken (needs some installations again and again and again and …)

Maximum user annoyance reached… If you ever think about an update - please don’t do it! :frowning:

1 Like

@F_Barrenbach, help us help you:

  • what version are you on now?
  • did you do a manual update, if so from what version?
  • did you have a unofficially repartioned device? (the 4GB hack using Meteos)
  • did you make a backup of your data before the upgrade?
  • do you use google as a calender and contact store (log into and on a pc to check), if so not all is gone

It seems that you didn’t succeed in installing gapps, correct? All but the first will resolve itself if you manage to install gapps. The first will also resolve itself if and only if you use google as a contacts/calendar store.

I have FP1U, Kola Nut 1.8.5 ; update by activating the Fairphone Upgrading App yesterday evening, about 10 p.m. - noticed first installation failed, did it again. Then it worked, clicked on Google App package - install - agree to licence - waited half an hour.

No unofficially whatever.

No backup. Didn’t expect any problems for my apps.

The calender is still available in google, but I can’t synchronize it with my FP calender any more - “No rights for synchronization with this server. Contact your server admin.” (whatever this means).

@F_Barrenbach OK, am I correct in saying that you have no working google apps (most importantly play store)?

If so, then you have a different problem then most of us in this topic. You came the official route from FP1U and still got stuck. Are you in what most of us call the google apps reinstallation loop? (every time you reboot your phone wants you to reinstall google apps?)

I can see that this is very annoying for you, luckily your data is still intact, you just can’t connect to it. As frustrating as it may seem, you are in way better shape than most…

I am reluctant to advise you what to do other than trying to reinstall google apps as described by FP. All the other routes will cost you more and you may end up spending a lot of time trying.

A backup wouldn’t have hurt, but in your special case it wouldn’t have helped you either… you need to reconnect to google and then everything will magically resolve itself.

(@anon12454812 @Marco first in the wild failed gapps update coming from FP1U not using the manual recovery???)

1 Like


Any news on the v1.8.5. repackage? I am on the GAPPS install loop after doing manual updates to v1.8.5 and then V1.8.5 unified partition. I had changed the partitioning way back and v1.8.5 would not install through the updater, complaining about not enough space in /cache.

Would rather wait for an official version, instead of going the flashing the phone route, if a solution is coming some time soon.

1 Like

For the people who want to flash their phone with SP tools with 1.8.5, here is the scatter file which was build with the Mtk Droid Tools:

For me this file worked with SP Flash Tool v3.1312.0.139 and the MT65xx drivers for FP1U.


@Kephson thanks for the scatterfile, I have updated my post to refer people to this option if they want to save a step in the proces.

dear Dave,

i would like to try this solution but the drivers aren’t installed.

can you explain (very detailed) how i can install it?


My FP did not stuck in a re-installing loop. It just ended with a couple of spoiled apps.

I tried to re-install everything again and - for some reasons I don’t know - all things are just fine again, now:

  • swipe function: runs
  • News and weather: runs
  • Play store: back and runs
  • old calender app: back and runs after installing new google calender app, and synchronizing it in the background

Puuuuha… I’m released… after in total 4 hours of bug-fixing. But my FP is running again perfect as I has been used to it, that’s the main point.

@daveboschma : Thanks a lot for your support! :smile:

1 Like


  • Download the drivers. I found a cleaner source for the drivers:
  • Unpack
  • Boot phone into recovery (you may need to select update from adb in recovery for your phone to show itself to windows)
  • Connect to PC.
  • Windows should now say either that it is installing a android phone (or something similar) or ask you for its drivers.
  • If it asks for drivers point to the files in the usb_driver subdir (by selecting the android_winusb.inf file)
  • windows should now see the MTK6589 phone.

After installation of the drivers power down your phone (for example by taking cable and battery out) and proceed with flashing. If you still can’t flash, nothing happens so you’re still save. Something went wrong while installing the drivers. If this happens come back here (try reinstalling the drivers by right-clicking the android_winusb.inf file and press install in windows explorer).

In short: the only risky step is when your computer does see the phone and SP flasher starts flashing. Then be very still for a moment.

1 Like


what do you think about this idea?


@MDP sorry to spoil the fun but you need a bit more than a factory reset. You need a downgrade or a reflash.
You are right about the part were you need to recustomize the FP.

As they say in Dutch “je kunt niet alles hebben” (roughly “you cant win them all”).

Thanks a lot for your good explanation. But what is the MTK driver in Windows necessary for? Why do I need it to flash the phone? I’m flashing the firmware of Fairphone, or not? I have no Windows around to flash but Linux. And with this adb works just fine. But only adb, and adb sideload pushes the Fairphone OS nicely on the phone, and the phone tries its best to install it - but fails :frowning:

MTK diver is necessary to use the SP Flasher tool under windows. I do not know if there is a linux equivalent. ADB is not good enough as it doesn’t work based on the scatterfile. As far as I know ADB can’t repartition the phone, something SP flasher was designed to do.

EDIT: the highly informed people of tell us that there is no know equivalent of SP Flash. Find yourself a Windows machine… (or wait for a different solution).

Do you know what is this Scatterfile necessary for? Never heard of it before. And it’s only a few bytes.

@Amber, It is a map of the memory chip in the phone. It tells SP flasher where to write which image. Think of it as the Memory chip version of a partition table. One small change and you’ll overwrite a part you do not want to…


Thanks for explanation. By looking for MTK Droid Tools I’ve found an article on in german language which explains this and the use of SP Flasher as well.

Jippie Jippie!!!
I think it worked for me as well.
It took me hours (and several missed phonecalls) and will take me some extra hours to get my phone working as i was used to.
But what a relief!!!
Thank you all contributers to this forum and special thanks to @daveboschma!
the extra info on how to install the driver (Google Apps can't be reinstalled) was very helpful!



@MDP, you’re most welcome. You almost had me worried that something went wrong… It became very quiet here. :wink: