Gmail address autofill not working after Kola nut update

This page (Gmail contacts do not sync “Gmail contacts do not sync” from Dec 2014) pretty much perfectly describes my issue I think – after I upgraded to Kola Nut last night (yes, I know, it is 2018 and the above post is from 2014, I am behind…), my gmail contacts do not sync.

My problem…
Like above, or more specifically, when I opened Gmail to use for the 1st time since updating, and compose a new email, the text prediction works for typing but when I start to type an email address, NO predictions come up whatsoever. I’d actually rather gmail didn’t pull contacts from my phone to use, I just want it to do what gmail does on my computer browser – use its inbuilt gmail memory to predict which email address I want to use from the load that I usually use…

What I’ve tried…
Since this issue came up I have gone to settings/DEVICE-Apps/Gmail and both cleared the cache and cleared the data for the gmail app; then switched phone off and on again, but no change. I have also gone to settings/ACCOUNTS-Google and done “sync now”, no luck. When I upgraded to Kola Nut I also uninstalled a load of other apps and I think maybe uninstalled updates to google play store (ie restoring it to factory settings), but Google Playstore still opens alright and I don’t see why that should change anything.

Past help threads don’t/can’t help…
Now aside from this, the person that helpfully answered the above post from Dec 2014 refers to another string (, but when I click on that link it says “Sorry, you don’t have access to that topic!” – why? It still seems pretty relevant to me (although indeed, it might not help)… This is REALLY unfair – why are you doing this to me Fairphone!?!?!?! I have spent the last 5 years telling everyone I ever meet how GREAT you are and not even asking for commission though LOADS of my friends now have fairphones :wink:… (although most have FP2 rather than my FP1 so all a bit stumped on this one…). Perhaps that topic is not available because it gave bad advice? Or is it just unavailable to ME – which is what the error message implies.

Either way, all I DESPERATELY want is to have my gmail working as it did before because this is driving me insane, even after a few hours.
Please please please please PLEASE help!!!

Thank you!!!

That topic is in a now closed area of the forum (not visible to non-moderators (and leaders?). This is the answer to that question:

(emphasis by me)

Let us know if it works for you too.

Hi Stefan,

Thanks so much for your speedy response! And also posting that reply up (presume it is unavailable as it is deemed too old and you don’t have space on servers for ALL posts ever?)

Unfortunately I did already do that - “click the first button and check everything you want to be synced”…

So… as that didn’t work did that old advice mean UNINSTALL the google app completely (then reinstall)?
Also, what would “related apps” be? any google app (I’ve got ‘Google +’, ‘Google (search)’ and ‘Google settings’)? But to be honest, i don’t use them so happy to delete! I was too scared to uninstall PlayStore - I can’t remember if this came already installed?

Thank you again!

Some forum categories have been archived because they were leading to confusion and problems when people tried to use instructions written in these categories on systems that that the instructions aren’t applicable to. Also note this forum is a community forum, and all users including the community moderators are not Fairphone employees.

More on topic: Did you already reinstall Google Apps via the updater? If you haven’t, make sure you’re connected to WiFi, open Fairphone updater, and tap ‘Enter Advanced Mode’ > ‘App Stores’ > ‘Google Apps’. Sometimes ‘Enter Advanced Mode’ doesn’t show up initially - I’ve found that waiting, restarting the updater and/or tapping the left button below the screen area make it appear.
In some cases you’ll also need to clear app data for Google Play Services, and possibly toggle Settings > Data usage > [menu key] > Auto-sync data off and back on again to get your data synched properly and made available on your phone (e-mail suggestions require properly working synchronisation, if I recall correctly).

That topic is in the old bug reports category, which was superceded by and is thus deprecated and hidden.

After each update you need to reinstall Google Apps if you want to use them (I for one don’t use them and that’s why I did not install them after the last update). Google Play Store is bundled with Google Apps. Usually there is a widget on the homescreen that lets you install Google Apps, or you need to go to the Fairphone Updater.

Have you tried to remove the Google account in Settings > Accounts > Google > [Your email address] > ⋮ > Remove account? You can add it again afterwards.

Edit: As @Johannes points out, the widget might not be available anymore.

If I recall correctly the widget no longer works.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.