Ghost inputs on FP4

I haven’t done a factory reset since the black-screen problem has arisen. But once I find the time I’m gonna perform the hardware fixes as described above first due to the other ghost-input related issues. I’ll report back afterwards whether this has an effect on the black-screen issue as well.

Yeah, I’ve found reports about that in my research, known as the dimming bug / issue. I’ve only had it happen about 4 times that I noticed, and all within the last month, without any updates (using custom ROM, myself). Look into that and see if it aligns with your issue.

1 Like

I wouldn’t bother with the hardware fixes seems hit and miss. Did the latest update not fix the issue for you? Are you on a custom rom?

I’ve gone into that pretty extensively further up in this thread in this post and this post.

Are you using a screen protector? If not maybe your screen has a defect. Were your ghost touches all in a vertical line down the center as in Ghost inputs on FP4 - #524 by davcri

Could you draw an example of where you are having input problems post patch? Or do these areas move around?

I have not experienced this issue pre or post ghost touch update nor the blackscreen issue.

As for the screen protector - yes, I have the official FP privacy screen protector applied to my display.

For the early ghost touches I can’t vouch for, as I didn’t have any display visualization enabled back then. But later on the focus was along that line, causing erratic vertical movement, but it also contained some clear outlier strokes from that main center line to the left and right areas of the screen as well.

As for the sensitivity issue I’m dealing with now its a bit harder to visualize, as I basically have to figure it out by ‘trial and error’ by taping and moving my finger around with visualization enabled to see where it registers and where it doesn’t. It’s not always exactly the same areas, but its usually close to that center line as well.

Also sometimes an area doesn’t register quick tapping, while moving into it from another area with a slow and firm motion works. But earlier today I had a case, where I moved across a spot at the top center, slightly offset to the right, and the stroke stopped registering at one point and started again at another, with the behaviour being reproducible at that spot for 15 seconds or so.


Certainly. Mine’s one of them. Like everyone else, I guess, I see some diminished touch-screen responsivity after the recent patch, that’s to be expected I suppose.
It’s impossible to estimate the number of faulty devices on the basis of forum contributions, but as always, it’s good to remember that very few users are going to write in just to say everything’s fine :thinking:


Yep. And that’s why the “fix” isn’t actually fixing anything, they’re attempting to hide the known symptoms from view, and then calling it fixed to move on. Very transparent attempt at obscuring the fault without doing much about it.

That’s why I am so frustrated and worried, terrified at what I’m seeing the response being. It took 18 months for that reaction to happen, with an issue as violent and disastrous to the user as this. The reaction was a quick and dirty patch that’s more of a smoke bomb than a fix.

Now, there’s already reports about unresponsive displays, an apparently entirely different issue on the surface, obviously. But it isn’t! It is the same, still unsolved, now hidden issue of ghost inputs.

It’s being treated like an entirely different issue all the same, so what do you think the reaction time for that is going to be? Another 18 months? Since it seems less of an issue not being able to input, than the device autopiloting itself, maybe even longer than that. Who knows.

Certain apps are now unusable even without a hidden ghost input needing to be the cause. The system tries to detect and block inputs that it believes to be the ghost - a game that needs rapid swiping will be unplayable with that patch, even if the ghost isn’t visiting in that moment, simply because the legitimate input of the user is blocked by the system as a false positive. Arguably, it’s made the issue somewhat worse because it’s not just every once in a while (hi ghost), but the system itself constantly limiting the possible inputs 24/7, ghost or not.

It really feels like they tried to smokebomb us and pretend everything’s good now because they didn’t communicate that this was just a quick temporary mitigation patch for the actual solution to be worked on, they said this is literally solved now, everybody move on.
ANY programmer tasked with, and able to, create a “fix” like that knows, it’s not a fix.

On that topic:
I also found ghost input reports with FP3, so none of this should have seen new from the start, and it still took 18 months to get here. I’m not sure if the issues on 3 were ever as big as on 4, or if affected FP3 devices were ever actually fixed, to be fair. Just thought I’d mention it. Did you know FP5 is about to release…?


You may well be right, we’ll have to see. I’m not a gamer but I can imagine any diminution of responsivity would be a bad thing.

As to the FP3 there was this, for instance. Again in some cases solved just by tightening some screws, but that thread was marked “solved” after a patch. I don’t remember any subsequent problems with unresponsive screen that time around.

1 Like

In the update feedback thread I believe others with screen protectors installed have mentioned issues with input since updating. It could be the reduced sensitivity + screen protector is causing some taps to not register.

I was hesitant to report this, but - it’s been four days now, since my post that I’m replying to, without any ghosts visiting. I’ve had my phone act up, violently, multiple times an hour at least. Barely any 10min segments without spirited interruptions. Given that context…

Fourth day, no ghosts. Extensive use. I didn’t do, change, or update anything. All I can say is, nothing spooky happened ever since I’ve just let the last violent ghost play out. It was in a safe environment / app, Navigation, just scrolling through the map for minutes on end, observed but uninterrupted by me.

Given past experiences, it’s probably not going to last forever. But, reboot, multiple recharge cycles and extensive use (including watching “The Spirits Within”, funnily enough) all worked fine.

I hesitate to suggest others try that, but, might as well I guess…? I mean, no idea if the specific movie afterwards is important to make it last, your results may vary. Maybe, my spirits were purged alongside the phantoms in the movie after they had already lost interest when I didn’t shoo them away again that morning. Sorry, it’s just so funny given the plot of that movie.

Figures. The day I post this, the ghost is returning.

1 Like

Ghost input has been a constant problem for me. Not sure if it was there initially (phone came with Android 11) or started with the first upgrade which was to Android 12.

However, with the upgrade to FP4.SP2.B.086.20230729 which I’ve been running for some weeks now, the problem has almost completely gone. It has happened only 3 times since the upgrade, whereas it used to happen very many times per day, often corrupting text I was writing, and even screwing up google maps when the phone was in the car cradle with nothing going anywhere near it.

It’s now very much better - thanks for that fix.


I’ve once again opened it up, and had a look why the ghost inputs had become so violent again despite 4 days of perfect quiet (mentioned in my last posts).

Removing the isolation tape, I noticed that it’s now 4 patches of exposed copper. The original, big one, one smaller one, and two more microscopic ones (unsure about those). Across the entire width of the cable. Checks out with the violent ghost, as it started deviating from the center line and has increasingly hit the left half of the screen, as well.

That means, it looks like despite the tape on there, it still gets worse? I put on tape again, in case metal shavings in the glue or whatever could have bridged the copper. But I’m not seeing anything.

Currently, I’m so done with the entire concept, I just want a working device and I stopped caring about any and all sustainability or repairability factors. Congratulations on that, Fairphone. Valuable learning experience for me.

As for installing update:
Even if it didn’t render a lot of apps unusable on my device, as of right now, e/OS/ doesn’t even have an update available with the “fix”. And, knowing how it works, I fully expect that “fix” to not be effective on my device anyways, as it will probably just shift the symptoms around as soon as the hardware has degraded too far like in my case.

Hi community!

I have acquired my new FF4 in May 23.
Since a couple of weeks now, there seems to be interferences with the touch screen. Just like if a ghost was touching it :ghost:. And it seems to be located at the bottom half of the screen. It results in randomly and fastly taping strange texts, exiting apps, hitting the back button and so on…
Is there anything I can do?
Is there anybody who have add a similar issue?

Thanks a lot :pray::pray::pray::pray:

Hi and welcome, moved your post and yes you are not alone. The recent update should have solved have you installed that already? If yes and its not fixed contactsupport

1 Like

Thanks yvmuell!
It’s a relief that this problem was solved already.
This might be a stupid question but how do I install the update? This is something else than Android I suppose.
Thanks :+1:

What do you mean? The update beging referenced in this thread is specifically for Fairphone’s stock ROM. Custom ROMs may or may not have implemented a similar workaround already.
Note that there are some inofficial hardware-based tips you could try to resolve this issue as well, AS tgere seems to be a correlation between the degradation of the connection between the core module with the display and the ghost inputs. Just read through the thread to find those. :wink:

Just open the Settings app (cogged wheel) and choose System > System update as usual, to update Android on your phone. If you don’t see an update available, be patient, some networks sometimes get updates a bit later than others.

Thanks AndreasChris even if I must admit I didn’t understand much of your reply :sweat_smile:

My question is : how do I install FP4.SP2J.B.086.20230807 ?

When I try to update the Android version, it says my device is up to date and there is no other updates available. Last update was on 5th of June with Android 12.

That’s why I was thinking it was something else but I don’t know what :thinking:

Thanks a lot!

Thanks OldRoutard!
This is indeed what I tried first.
But there’s no update available since my last update on 5th on June.
Would you say that 3 months is a bit later ?