Ghost inputs on FP4

In the update feedback thread I believe others with screen protectors installed have mentioned issues with input since updating. It could be the reduced sensitivity + screen protector is causing some taps to not register.

I was hesitant to report this, but - it’s been four days now, since my post that I’m replying to, without any ghosts visiting. I’ve had my phone act up, violently, multiple times an hour at least. Barely any 10min segments without spirited interruptions. Given that context…

Fourth day, no ghosts. Extensive use. I didn’t do, change, or update anything. All I can say is, nothing spooky happened ever since I’ve just let the last violent ghost play out. It was in a safe environment / app, Navigation, just scrolling through the map for minutes on end, observed but uninterrupted by me.

Given past experiences, it’s probably not going to last forever. But, reboot, multiple recharge cycles and extensive use (including watching “The Spirits Within”, funnily enough) all worked fine.

I hesitate to suggest others try that, but, might as well I guess…? I mean, no idea if the specific movie afterwards is important to make it last, your results may vary. Maybe, my spirits were purged alongside the phantoms in the movie after they had already lost interest when I didn’t shoo them away again that morning. Sorry, it’s just so funny given the plot of that movie.

Figures. The day I post this, the ghost is returning.

1 Like

Ghost input has been a constant problem for me. Not sure if it was there initially (phone came with Android 11) or started with the first upgrade which was to Android 12.

However, with the upgrade to FP4.SP2.B.086.20230729 which I’ve been running for some weeks now, the problem has almost completely gone. It has happened only 3 times since the upgrade, whereas it used to happen very many times per day, often corrupting text I was writing, and even screwing up google maps when the phone was in the car cradle with nothing going anywhere near it.

It’s now very much better - thanks for that fix.


I’ve once again opened it up, and had a look why the ghost inputs had become so violent again despite 4 days of perfect quiet (mentioned in my last posts).

Removing the isolation tape, I noticed that it’s now 4 patches of exposed copper. The original, big one, one smaller one, and two more microscopic ones (unsure about those). Across the entire width of the cable. Checks out with the violent ghost, as it started deviating from the center line and has increasingly hit the left half of the screen, as well.

That means, it looks like despite the tape on there, it still gets worse? I put on tape again, in case metal shavings in the glue or whatever could have bridged the copper. But I’m not seeing anything.

Currently, I’m so done with the entire concept, I just want a working device and I stopped caring about any and all sustainability or repairability factors. Congratulations on that, Fairphone. Valuable learning experience for me.

As for installing update:
Even if it didn’t render a lot of apps unusable on my device, as of right now, e/OS/ doesn’t even have an update available with the “fix”. And, knowing how it works, I fully expect that “fix” to not be effective on my device anyways, as it will probably just shift the symptoms around as soon as the hardware has degraded too far like in my case.

Hi community!

I have acquired my new FF4 in May 23.
Since a couple of weeks now, there seems to be interferences with the touch screen. Just like if a ghost was touching it :ghost:. And it seems to be located at the bottom half of the screen. It results in randomly and fastly taping strange texts, exiting apps, hitting the back button and so on…
Is there anything I can do?
Is there anybody who have add a similar issue?

Thanks a lot :pray::pray::pray::pray:

Hi and welcome, moved your post and yes you are not alone. The recent update should have solved have you installed that already? If yes and its not fixed contactsupport

1 Like

Thanks yvmuell!
It’s a relief that this problem was solved already.
This might be a stupid question but how do I install the update? This is something else than Android I suppose.
Thanks :+1:

What do you mean? The update beging referenced in this thread is specifically for Fairphone’s stock ROM. Custom ROMs may or may not have implemented a similar workaround already.
Note that there are some inofficial hardware-based tips you could try to resolve this issue as well, AS tgere seems to be a correlation between the degradation of the connection between the core module with the display and the ghost inputs. Just read through the thread to find those. :wink:

Just open the Settings app (cogged wheel) and choose System > System update as usual, to update Android on your phone. If you don’t see an update available, be patient, some networks sometimes get updates a bit later than others.

Thanks AndreasChris even if I must admit I didn’t understand much of your reply :sweat_smile:

My question is : how do I install FP4.SP2J.B.086.20230807 ?

When I try to update the Android version, it says my device is up to date and there is no other updates available. Last update was on 5th of June with Android 12.

That’s why I was thinking it was something else but I don’t know what :thinking:

Thanks a lot!

Thanks OldRoutard!
This is indeed what I tried first.
But there’s no update available since my last update on 5th on June.
Would you say that 3 months is a bit later ?

FP4.SP2J.B.086 was announced on 21 August but there seem to be at least two variants distributed to different network operators. The one I received has a different number at the end. Your network operator may not have received theirs yet, this often happens because adjustments need to be made.

Check out the topic that yvmuell already pointed to.

If you indicate your country and network operator maybe somebody with the same operator will confirm. I’m in France with Free.


Thanks OldRoutard, I’m in Belgium with Proximus
Is there somewhere I check a list of countries and operators in regards with the update release?

1 Like

Looks like the latest update fixed the ghost input. It has been a while since I notice it. If anything, it is significantly reduced.

Lucky you…no such luck here…it’s still not very good

(Not my choice of words but the censorship here is off the charts, apparently everything is potentially offensive or something)

Waiting on replacement,but they aren’t really fast at fp.

1 Like

Still getting ghost inputs. Potentially not as severe, but still getting them.


running here FP4 with e/os 1.14.

Also experiencing the ghost inputs.
Very annoying, hopefully there will be a solution quickly…

Also mailed the support team…

1 Like

The problem is almost gone for me now that I have installed the update, but now I have run into a new issue: Two finger zoom no longer works reliably. Has anyone else encountered this issue?

1 Like

Yes. A lot of people are experiencing issues with touch sensitivity after the update. See this thread discussing the update for more.