Ghost inputs on FP4

I cant see your drafts so it was published when I quoted and I cannot know that you wanted to change it later

The FPs are all very well supported by many Custom ROM.

Guess it’s part of the propriety firmware provided with the update?


Wow, I’ve been silently following the thread and only now I’m realizing the level of covering up being attempted here. I guess I was too focused on the duct tape hacks…
Do you actually have data to support the claim that the majority of the phone doesn’t have issues?
500 replies is not 500 phones but I’m sure most people with the issue won’t bother signing up to the forum and commenting on the thread.
If there’s units that are not faulty, why do the replacements received eventually turn out to have the same issue?
I don’t know what do you get for defending Fairphone so hard but you should tell the CEO that your strategy is doing worse to the brands image…


I haven’t had any ghosttouches since the update. It’s only when the phone is on the table that I have trouble zooming. But I can live with that. I am satisfied.

1 Like

I can support that part of your statement, as I’ve peraonally had this issue slowly getting worse for months now, but haven’t spoken about it on this forum until a few days ago.

On another note:
I did observe one unintended input along the middle of the screen despite the update just a few minutes ago, but it was only one short strike before being suppressed and in no way comparable to the erratic inputs from before:

The touch inputs being disabled across certain screen regions pretty regularly is becoming the bigger issue now.


One more thing I haven’t mentioned before, which thinking about it could be related to the connection between main board and screen degrading over time (and hence the ghost input problem). Maybe some of you guys have experienced this in combination with your ghost inputs as well:
I’m also experiencing the issue of the screen sometimes suddenly turning black without actually turning off. All other functionality is retained when this happens (e.g. audio output).

The same (or similar) issue has been described in this thread by @jaxom, which has unfortunately been closed since with no update as to the resolution of the problem:

I haven’t done anything about the issue so far, since it could always be resolved by simply turning the screen off and on again. Note that I also haven’t refitted the screen yet, which I intend to do due to the ghost-intput and irresponsive touchscreen stuff shortly.

Has anyone else who experienced ghost inputs also had this problem on top?

1 Like

This sounds more like a android software problem to me. Are you using different launcher or something?

Nope, the device currently runs the stock Fairphone launcher. I did disable the Google App (Search, Voice Input, etc. - not Google Play Services) and use DuckDuckGo for my standard search stuff, but I don’t think that should have any bearing on this. Also it does not happen on any specific app, but pretty randomly all across the board.

It’s not frequently enough to make the device utterly unusable, but it can be a bit annoying nonetheless.

1 Like

And it persists through a factory reset?

I’ve had four violent ghosts yesterday. One of which was going on for close to 4 minutes, because the device was in a safe enough state (navigation) that I just let it run its course without interfering, curious as to how bad it’s gonna be.

Since that one, the device has not been acting up too much again, I even put it to the test by watching an entire movie on it in the evening, without any issue. Not the best movie experience, but it served a different purpose after all.

Im with you there, mostly. But I would refrain from speculating in that direction without actual hard evidence to back that theory up. I didn’t mean to insinuate such, either, sorry if that’s the impression that you got.

Because IF I were to speculate, let’s look at the facts we got. They’re a community Moderator (not Manager, Moderator) which still suggests they’ve been involved with FP as a product longer than most (any?) of us. Their profile confirms that, including that they’ve been using FP2, and FP3 before FP4, meaning they probably also have been using the FP4 specifically before most (any?) of us, as well. Their contributions here consisted of trying to help for the most part, until the two, three last posts which unfortunately came off as possibly discrediting our experiences here. But that you can also interpret as their own years of experience simply being at odds with ours, indicating that there absolutely are devices out there that are functioning properly long term.

Long story short, what’s the speculative conclusion? I suspect that the first few batches of devices / components off the line may have been fine. If only the later batches ended up having issues, that would explain the discrepancy of some, maybe even many, not having had any issues while now, all or most devices / components produced within the last year or so, have turned out faulty. No actively ill intents required.

I haven’t done a factory reset since the black-screen problem has arisen. But once I find the time I’m gonna perform the hardware fixes as described above first due to the other ghost-input related issues. I’ll report back afterwards whether this has an effect on the black-screen issue as well.

Yeah, I’ve found reports about that in my research, known as the dimming bug / issue. I’ve only had it happen about 4 times that I noticed, and all within the last month, without any updates (using custom ROM, myself). Look into that and see if it aligns with your issue.

1 Like

I wouldn’t bother with the hardware fixes seems hit and miss. Did the latest update not fix the issue for you? Are you on a custom rom?

I’ve gone into that pretty extensively further up in this thread in this post and this post.

Are you using a screen protector? If not maybe your screen has a defect. Were your ghost touches all in a vertical line down the center as in Ghost inputs on FP4 - #524 by davcri

Could you draw an example of where you are having input problems post patch? Or do these areas move around?

I have not experienced this issue pre or post ghost touch update nor the blackscreen issue.

As for the screen protector - yes, I have the official FP privacy screen protector applied to my display.

For the early ghost touches I can’t vouch for, as I didn’t have any display visualization enabled back then. But later on the focus was along that line, causing erratic vertical movement, but it also contained some clear outlier strokes from that main center line to the left and right areas of the screen as well.

As for the sensitivity issue I’m dealing with now its a bit harder to visualize, as I basically have to figure it out by ‘trial and error’ by taping and moving my finger around with visualization enabled to see where it registers and where it doesn’t. It’s not always exactly the same areas, but its usually close to that center line as well.

Also sometimes an area doesn’t register quick tapping, while moving into it from another area with a slow and firm motion works. But earlier today I had a case, where I moved across a spot at the top center, slightly offset to the right, and the stroke stopped registering at one point and started again at another, with the behaviour being reproducible at that spot for 15 seconds or so.


Certainly. Mine’s one of them. Like everyone else, I guess, I see some diminished touch-screen responsivity after the recent patch, that’s to be expected I suppose.
It’s impossible to estimate the number of faulty devices on the basis of forum contributions, but as always, it’s good to remember that very few users are going to write in just to say everything’s fine :thinking:


Yep. And that’s why the “fix” isn’t actually fixing anything, they’re attempting to hide the known symptoms from view, and then calling it fixed to move on. Very transparent attempt at obscuring the fault without doing much about it.

That’s why I am so frustrated and worried, terrified at what I’m seeing the response being. It took 18 months for that reaction to happen, with an issue as violent and disastrous to the user as this. The reaction was a quick and dirty patch that’s more of a smoke bomb than a fix.

Now, there’s already reports about unresponsive displays, an apparently entirely different issue on the surface, obviously. But it isn’t! It is the same, still unsolved, now hidden issue of ghost inputs.

It’s being treated like an entirely different issue all the same, so what do you think the reaction time for that is going to be? Another 18 months? Since it seems less of an issue not being able to input, than the device autopiloting itself, maybe even longer than that. Who knows.

Certain apps are now unusable even without a hidden ghost input needing to be the cause. The system tries to detect and block inputs that it believes to be the ghost - a game that needs rapid swiping will be unplayable with that patch, even if the ghost isn’t visiting in that moment, simply because the legitimate input of the user is blocked by the system as a false positive. Arguably, it’s made the issue somewhat worse because it’s not just every once in a while (hi ghost), but the system itself constantly limiting the possible inputs 24/7, ghost or not.

It really feels like they tried to smokebomb us and pretend everything’s good now because they didn’t communicate that this was just a quick temporary mitigation patch for the actual solution to be worked on, they said this is literally solved now, everybody move on.
ANY programmer tasked with, and able to, create a “fix” like that knows, it’s not a fix.

On that topic:
I also found ghost input reports with FP3, so none of this should have seen new from the start, and it still took 18 months to get here. I’m not sure if the issues on 3 were ever as big as on 4, or if affected FP3 devices were ever actually fixed, to be fair. Just thought I’d mention it. Did you know FP5 is about to release…?


You may well be right, we’ll have to see. I’m not a gamer but I can imagine any diminution of responsivity would be a bad thing.

As to the FP3 there was this, for instance. Again in some cases solved just by tightening some screws, but that thread was marked “solved” after a patch. I don’t remember any subsequent problems with unresponsive screen that time around.

1 Like

In the update feedback thread I believe others with screen protectors installed have mentioned issues with input since updating. It could be the reduced sensitivity + screen protector is causing some taps to not register.