English

Getting rid of OpenGapps leads to bootloop into TWRP

Hi!

I am running LineageOS 17.1 with encryption, opengapps and Magisk installed without problems. I tried to get rid of opengapps as mentioned here. I wiped the system partition and after rebooting into TWRP I tried to use the file manager to find the data inside /data but it was empty and I figured it cannot be displayed because of the encryption. Well than I installed the new LOS build and Magisk, wiped the cash and rebooted into system which caused a bootloop after entering the encryption password. It always reboots to TWRP.

After that I wiped the system partition again and reinstalled the LOS build without Magisk, because I read in some forums that Magisk can cause such loops. Anyway the phone keeps on bootlooping until I flash opengapps. After that everything works fine.

Note: The phone does not enter the system optimization phase but reboots during the LOS - bar is displayed.

Is there a way to get rid of opengapps without performing a factory reset (what I mean with that is I do not want to wipe the user data or get rid of the encryption)?

Thank you and have a nice evening!

Did you try this more recent one from the thread you linked to? …

https://github.com/opengapps/opengapps/issues/551#issuecomment-619477753

Sounds reasonable to me in theory.

1 Like

Good morning.
No, I flashed a more recent buid. I’ll try as soon as I get some free time with my phone :wink:
Thank you!

what do you think about that?

Wiping System should delete all files in /system … how would a file in /system/addon.d survive?

https://github.com/opengapps/opengapps/wiki/FAQ#18-is-it-necessary-to-reinstall-open-gapps-every-time-i-update-my-rom

"Is it necessary to reinstall Open GApps EVERY time I update my ROM?

Probably not. If your ROM supports addon.d backup functionality (most ROMs do), it’s not necessary to install Open GApps with each ROM update - as long as you don’t manually wipe the System partition."

… meaning that Wiping System should delete the file in /system/addon.d.

That’s what I thought too, but I don’t know enough about it…

@AnotherElk thank you very much for your commitment and fast help. It’s nice to see that knowledgeable and motivated users like you are active in the forum!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.