English

Get error "App not installed" on Lineage OS 15.1 with MicroG when trying to install an Apk file

Hi Community,
I’m new here and I don’t know if this is the right forum for my question.
Anyway, the title says everything.
I made a dirty upgrade from LOS 14.1 for microG to LOS 15.1 for microG. All my apps are saved and everything works so far.
But every time I try to install an apk file I get the error “App not installed”, just after one second. I tried giving the package installer more privileges in the privacy manager and installing from sd-card and with another file manager.
After two hours of researching I need your help, because I didn’t find any guides how to solve my problem.
I hope you can help me
thank you
quwepiro

Well, if nobody else comes up with something I have an answer … but a rather unpopular one, I believe :slight_smile:

Well, thank you.
But I already tried making a dirty upgrade and making a clean upgrade.
And it didn’t fix it.

How exactly did you do the clean upgrade?

I wiped System, Data, Cache and all the other stuff through TWRP. Then I installed the lineageos Zip file.

And dirty: I just installed the Zip file, over my existing lineageos installation

Sounds good to me.
The only thing I encountered after installing 15.1 was that I couldn’t install APKs from Internal storage, I had to install them from the external SD card.

Did you perhaps incorporate your SD card into Internal Storage instead of keeping it set as external storage? I don’t know how APK installing would behave then …

Can you try to install an APK via #dic:adb ? … http://adbshell.com/commands/adb-install

Sure I already tried installing from external SD card. Same error.
But when I install apps through another app, e.g. F-Droid Privileged Extension, the app installation works only through a file manager doesn’t

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.