🇬🇧 🇩🇪 Mobile network keeps disconnecting

for several weeks now I have a problem with the mobile connection of my Fairphone: it keeps disconnecting when I use it for mobile data transfer (e.g. browser, facebook). In these cases, the network status sign changes from H or H+ into a red x, the blue bars disappear. After some minutes, they reappear and a G or E shows up. When I try to use the browser at that point, or even just try to make a phone call, the connection breaks down again.
I tried several things, including reboot, turning on flight mode and turning it off again, removing SIM and/or battery, disabeling WiFi - however, the problem remains the same. It takes some hours until the phone “recovers” an works for a day or two. Then, the same issues come up again.
Mainly when I am travelling (by car, train, etc.) I am not able to connect at all - even when moving within the city, where mobile network connection is not an issue. But I also experience the problem while using the phone “stationary” within buildings.

Thanks for any comments.
Kind regards,

1 Like

Just to be clear, does this also happen when there’s a good 3G network coverage and you are not moving?
And I assume you do have a data plan, you did not change the country (i.e., you are neither roaming nor your APN settings have been messed with some way), and the problem never occurred before?

Just two quick ideas:

You could try to disable 2G (I do that using a GravityBox toggle in the Quick Settings, can’t find the option in the settings on the fly).

You could also boot to factory mode and see what the radio test section gives you.

1 Like

Thanks for the reply, humorkritik.

Yes, this also happens from time to time when I am not moving and there is 3G coverage.
No, I did not change the country and I assume there was no modification of APN settings.

My guess is on of the last Fairphone Updates. The problem occured after one of them in late Jan or early Feb. Yet, no one else seems to have similar issues…

Next time the network disconnect I will try your suggested steps, thanks!

1 Like

Regarding the FP OS update: which version are you running? You can check in the Fairphone Updater app.

Did you install any apps in the period you mentioned? Maybe some communications app, VoIP, messengers, cloud apps?
Maybe some app is trying to access some settings and interfering with your 3G radio settings.

If you want to fiddle a bit*, you could install a backup app. (I use TitaniumBackup, which has a confusing UI but does a good job.) Make a complete backup and then de-install apps which you installed since early January, one by one, and see if the problem persists. Or you could simply do a full reset, see if the problem persists, and restore apps one by one from the backup and check if the problem turns up again. I’d avice not to restore any Google apps and system apps - just restore their data, if needed.

(*) Read: e.g., a Saturday afternoon. With a good cuppa and some soothing music.

Today I noticed that the network strength bars were at zero. Next minute they were at 5 (full strength) then 30 seconds later they were at zero again. When at zero the phone is dead (ie all calls go straight to voicemail), when the network bars show it works normally.

So the network connectivity is unstable. I moved the SIM to slot 2: same thing happens. I put another SIM (different network) in the empty slot - same thing happens with both SIM cards simultaneously. They fade in and out together. The problem has got steadily worse throughout the day with zero connectivity more often than not now.

So it is not the network or the SIM card that is at fault. That leaves the phone. Hardware or software? Hopefully software as I don’t want to send my phone for repair AGAIN.

The next thing I’m going to try is a factory reset, but before I do has anyone else had this problem?

@JPL: seems to me we have a similar problem. The connectivity is great at one moment, and none at the next, with various steps from H+, H, G and E in between. I also checked both SIM slots.

@humorkritik: I’m running Kola Nut 1.8
Unfortunately I am not that talented in technical stuff, so doing a backup, doing a reset and reinstalling the apps sounds to me like a lot of trouble (even though I don’t have any other plans for Saturday afternoon :wink: )
I Nonetheless I tried the suggestion of disabling 2 G (yes, I managed to install Gravity Box - woohoo). The problem persist. Yesterday was a bad day for my phone (while there are days where I have no issues at all).

1 Like

@Sarah_hh Hi - yes I saw your post but thought it was just 3G that was the problem. With me the entire mobile network connectivity fades in and out. I reset to Factory Settings but it didn’t do any good so I think it’s a hardware problem. This is annoying as it will be the third time I have had to send it for repairs and it is now out of warranty.

A bit offtopic: How can it be out of warranty? The first FPs were shipped in December 2013 so the earliest warranty to expire is in December 2015, am I wrong?


Oh yes - it is two years. I thought it was one year for some reason. That’s good news. Thank you :smiley:

Fairphone support have since been in touch and advise I install the storage upgrade, so I’ll try that later and report back.


@JPL in fact, its the enitre Network as well - no phone calls possible, no connection at all.

Can you tell me where to finde the storage upgrade?


  1. Back up all your data because your phone will be wiped https://fairphone.zendesk.com/hc/en-us/articles/201190847-How-to-backup-and-restore-your-Fairphone
  2. Charge your phone up to 80% or more
  3. Click on the Fairphone Updater app. It will tell you what version of the operating system you are using. In my case it was Cherry 1.6. If you are still on 1.3 you will need to update to 1.6 first - click on Fairphone OS within the Fairphone updater app and follow the instructions to upgrade to 1.6.
  4. Assuming you already have 1.6, click on the Storage Upgrade option and follow the instruction. Afterwards you’ll have to reinstall Google Play and all your apps again.

It seems better for me, but connectivity is still fading so I thing it’s a hardware problem. Worth a try though.

Oh I forgot to say - you need to be on a wifi connection because it’s a big download

And if you are on 1.8 you need to downgrade first.

1 Like

Careful! Although it says otherwise, the default backup and restore app will not backup everything. You will lose settings and notes, etc. If you want to do a thorough backup, use Titanium Backup. (@humorkritik can probably tell you more about this)

Let’s start with the important bit:

This is odd and should definitely not be the case if it would be a hardware issue. I assume you ruled out that it’s due to a certain location, position in regard to other devices, walls, windows, etc. - so I guess either something is happening to your network, or you have got some strange software problem.

If it’s the network (which is not very likely, but still a possibility), your service provider could probably know. You could contact them and ask if they have complains from your area. If they are doing service stuff or (if you are on a “virtual” provider or Vodaphone/ePlus in Germany) if they have ‘roaming’ problems in your area, you are surely not the only one affected.

If it’s the software, well:

It takes a lot of time if you do it my way, but is not very complicated. And there are other options: if you don’t have objections regarding data security and privacy, I guess Google can safely backup all your apps, photos, and probably even music on their servers, aka “the cloud”. There should be tutorials for that on the interwebz. :smile:

If you like to retain full control of your data, TitaniumBackup might be your friend. I could try to walk you through the process, to the benefit of others like @JPL if you are interested - but I should really be working right now… :wink:

For the last three days the problem has not recurred. I am still watching in case it does, but it seems that doing the storage upgrade fixed it. Fingers crossed…


Ah, interesting. @Sarah_HH, if you are on 1.8 (Kola Nut) and did not apply the Unified Storage thingy, you are bound to downgrade to do it (and backup first!). But you could also try those other link-to-sd-card solutions which are somewhere on the forum, and see if that has any effect. Preferably, after doing a full backup, first. :smile:

1 Like

so, after some days off I tried to solve the problem by following your recommendations.
But, I’m afraid the solution installing the storage upgrade on 1.6 cherry won’t work for me, as I’m using the FP1U. Am I right?
I wiped the entire phone and reinstalled it, using 1.6 cherry, but still the mobile network keeps disconnecting…

Installing the unified storage upgrade should only not work if your storage is allready unified. You can check it by going to Settings > Storage and check if you only have internal storage (and sd card if you have one) or also a phone storage.

I think all Fairphones of the second batch (=FP1U) indeed were shipped with a unified storage partition. [Source]

1 Like