Function of Physical Camera Button (feature request)

the physical camera button has puzzeled me for a while now. As far as I know it has very little to do. When the standard photo app is not on the button does nothing, when the screen is locked it does nothing. Only inside the camera app does it actually take a picture. The button should have a global meaning in my opinion. Would it be possible to have a configuration option for it somewhere (in the future patchlevels)? I would like this button to take a picture even when the phone is locked (without visible aiming), by one button press. Sometimes I see a cat or a deer and unlocking the phone starting the photo app takes too long. This button could help. Alternatively, it could start the photo app and then do the shot when pressed a second time, that’s not much slower. If such things are technically possible…
But, even if it did something else, like take a screenshot while the cam app isn’t running but the phone is unlocked, now that would be at least some functionality. Btw. I know about snapshot apps, I don’t like the ideas so far (gestures and this sort of thing) and I don’t want to install a dedicated app when this is an operating system level thing (what a buttons does) and I’m happy with the default picture taking app other the above ^^. So, a config item would be nice. If anyone does know how to configure the button in a different way, then I’d appreciate the information.


Pressing the camera button for about one second actually does start the Camera app (while the phone is unlocked). I think it has always been this way.


Sometimes it does, sometimes it doesn’t. But also: One second is way too long considering that a short press has no function. What exactly is the hold-release move distinguishing itself from?

Heaven forbid that a short press on that button has a function, as often as I accidentally start the camera because I don’t turn off the screen, put the phone in my backpack, and the button is accidentally pressed in my backpack before the screen turns off automatically, and the camera just happily eats my battery waiting for me to take a picture of the beautiful darkness :smiley: …


Well, that’s why I requested a configuration module for the button, not new defaults. What you discribe has never happened to me and I certainly have never started the photo app by accident. The way things are it takes ages to start on purpose. So, I would definitely choose the short press to do a thing while you could deactivate the button’s global action entirely and only use it in the camera app.

1 Like

You’re right, of course, configuration by the user would be best :wink: .

Well, actually there is a way to configure the behavior of the camera button but the options are very limited and hidden in a settings page I discovered using the Activity Launcher app; following is the procedure to open that settings page:

  1. open Activity Launcher and select “All activities” on the top of the page;
  2. scroll down until you find the app named “ProgrammableButton” tap on it and long-tap on the activity name, then select “Create shortcut”;
  3. a new shortcut will be created on the desktop, tap on it and a window will open in which there’s a list of possible actions you can assign to the camera button;

You can test immediately the behavior of the selected action (displayed on top of the list of actions) by selecting the action you want to try and then push the button for more than a second until you feel a vibration, then the action will be executed :wink:

Bye! :slight_smile:


I had already written a feature request to the Guardian Project that i want the ObscuraCam to start with the programmable button, they answered they “will consider it for future updates of the App”.
Unfortunately the ObscuraCam is not in the list of assignable actions of the programmable button. The available actions are ignore, camera, and several settings.


I don’t know how ObscuraCam works but if it’s able to receive the standard intent for camera requests you should simply configure the button as normal camera and then a popup should open to let you select the default camera app to use, then if you can select ObscuraCam and by checking “Always” you should get what you need.
Bye! :slight_smile:

1 Like

I recently got my FP2, and being used to my previous 7 year old phone which fits in the palm of my hand, I would like to configure the camera button so that it works like the power button. Maybe even switch functionality of the camera and power button.
I can’t however see which assignable action using @DjDas’s solution or if it’s even possible.

I guess this is not possible with this configuration tool, furthermore even though you could use some other automation app or xposed module to make the button be able to put the phone in standby (from screen on to screen off), AFAIK the same is not achievable to awake the phone since it is done in hardware (or at most in some kernel driver)
Bye! :slight_smile:

If you press the on/off button twice when the phone is locked, you have instantly the camera active.

Thanks for that Tip, that reliably solves my main problem. Pressing the power button twice worked really well in all situations.

Hi DjDas,
thanks for the tip and sorry for the delayed response. I tried this app on various versions of the OS and it never successfully did what you describe on my phone. No shortcut was created. But even if it worked: none of the options sound like what I would wish for.
The double press on power however, is good enough. So, now this camera button is merely a very mild annoyance to me, because it has practically no function. Or rather, it has a function, but it is so unreliable that I won’t use it. But, maybe it will eventually get a new life if I figure out this Activity Launcher…

2 posts were split to a new topic: Some questions about the camera & button

I tried the Activity Launcher, but it still requires a long hold press and
the action happens upon release, so you can hold the button indefinitely
and nothing will happen; as it was before. This is problematic. If you
release to soon, it might not perform any action at all, so – to be sure
– I press longer than necessary and try to guess the release time well
enough, sort of bounded from below. This is the worst possible way to make
a button work. So unpleasant, that I would actually prefer this button to
not exist in the first place.
I did not discover a setting in activity launcher which changes that
behaviour. But, I’ll keep playing with it…

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.