FP5 refusing to boot

Hello everyone,

I recently purchased an Fairphone 5, it has been a great phone thus far. When I received it I immediately put IodeOS on it. This worked fine, however I wanted to which back to FairphoneOS (mainly due to some unstable apps/missing faceID). I followed the steps on managing the bootloader and how to install FairphoneOS. I unlocked the bootloader, fastboot was enabled. I was in the bootloader and I ran the shell script found within the Fairphone installer.
It was going well until it suddenly gave me this error:

I followed the steps, I unplugged the phone and took the battery out. The phone immediately turned off of course, however now it no longer wants to boot at all. Pressing the power button (or any combination of buttons) does nothing at all. The screen remains black. Taking out and putting the battery back in doesn’t resolve the issue either. I have yet to try a complete disassembly of the phone however.

Any advice on getting it back up? This phone is less than a week old and having it be dead (albeit, probably due to my own doing) is more than just upsetting.

Thanks for any tips and advice!

1 Like

So pressing power+Vol down for several seconds will not boot the FP in fastboot?

I doubt its a HW issue and that disassambling will benof any help, however will neither harm.

Edit: reg the error, did you unlock critical as well?

Pressing Power+Vol down does nothing no.

I did also unlock critical using the fastboot command listed on the site. (Before I ran the shell script)

I’m kinda stuck on what to do since my laptop doesn’t find it was it’s not turning on

When you cant boot in fastboot or recovery by pressing /holding the respective button combinations for a few seconds, I fear you will have to contactsupport

Shoot, well thanks a bunch for your help & swift response!

Any update on this issue from support? I’m having this exact issue with my FP5 and only recently submitted a troubleshoot request.
It’s best to assume that yours is stuck in EDL mode, just as mine is. As far as I’ve read, it’s recoverable through software however the files required to do so are not public. Same case for the FP4 as well.

Support replied just today, their response wasn’t much use.

They told me to enter recovery mode via the settings menu in Android… If I could enter android, I wouldn’t have made the request

They offered to repair it in a facility, I’m going to take that offer as I don’t have any way to flash firmware myself. If you got anything, please do say!

I found it difficult to find info on this issue, however this here looks like the best page to keep an eye on: Is this an edl loader for 001970E1 / QCM6490? · Issue #477 · bkerler/edl · GitHub

Since you’re opting to send yours for repair, are they charging you for shipping? I’m a US customer so if so then I’m in for a hefty shipping charge.

I’m in doubt they will help you at all and will ask you to handle this through the reseller you bought it.

When you bricked it by flashing other ROMs, yes you have to pay everything. For the FP4 in EU it was around 40-50€ in total.

@jaschutte caution, in case Cordon wants to change the core module at your costs, refuse this and ho back to support to handle this… That happened at the first FP4 cases…

1 Like

That’s disappointing considering Iode installed completely fine meanwhile the shell script Fairphone themselves provided is what messed up and caused this issue, as far as I can tell. Nonetheless, having my reseller handle it and only paying for shipping would still be a good outcome.

1 Like

Thats odd,so same error message?

@FrancescoSalvatore is FP aware of any errors in the fastboot file that can cause this?

Yes, I received the same error message (except for serial #, of course). I saved stdout to a text file, I’ll upload it once I’m home in a couple of hours!

1 Like

Yeah exactly, it’s very odd

I’m trying to convince support that this does fall within warrenty, as if this is an issue on their part, it definitely should

Here’s the output of my flash attempt. I might try reading through the shell script to see if I can find anything.

I think I found the source of the problem.
There’s currently a bug with Arch Linux’s packaged android-tools that causes the exact error that terminates fastboot: 34.0.4-1 breaks fastboot (#4) · Issues · Arch Linux / Packaging / Packages / android-tools · GitLab
Checks out because I ran this on Arch. Looks like Arch is screwing people over right now.

I’m unsure of how this is supposed to play out for FP. It’s not directly their fault, but neither is it the end user’s…? FP could’ve included minimal android tools with their firmware package to prevent this (and I’m not sure why they included them for Mac & Windows but not Linux), however it seems not even they caught this issue.


Why would the IodeOS shell script work though? I use a barebones EndeavourOS install on my PC (essentially just Arch but with an installler)

Interesting research though!

1 Like

I’ve yet to look at Iode’s script myself, but I would guess that their script uses fastbootd for half of the installation. Couldn’t say for sure though, since either way it uses the fastboot program.

I took a look at it and it looks like Iode’s script flashes the super partition along with other partitions as a bundle under a single fastboot command (fastboot --no-reboot update iode-someversion-img.zip) instead of a bunch of individual flash commands. It’s likely that the bug doesn’t occur when flashing super this way rather than by itself.

Iode includes minimal android-tools in their update package. Their fastboot program most likely doesn’t contain this bug.
Can’t believe that I explained this already for FP’s package then completely miss it now, lol.


Found fastboot’s core dump from my flash attempt. Here’s the backtrace. Understanding the backtrace is beyond me, so if anyone can make heads or tails of it we’d love to know what specifically went wrong with it!

FP hasn’t gotten back to me yet, however my reseller already offered to have it repaired as long as I pay to ship it to them. I’ll likely go with this option unless FP offers the same but also cover shipping.
@jaschutte Any updates on your end?

Nope, nothing to report here. I send them my address but they have get to get back to me. I also tried arguing that it does fall within the warrenty, but nothing on that end either.