FP5 cannot connect to a PC via USB

So, I’m frustrated; just got my FP5 and there does not seem to be any way I can connect it to my PC via USB to file transfer. Background:

Literally got the phone a few hours ago. I did not put any accounts or even a SIM card in it yet. I let the phone update its software to the newest version.

What happens:

I plug the FP5 and my Win11 PC with the USB cable· the phone initially flashes like when it’s connected to the charger, but gives no notification of the connection established. I manually navigate to the USB preferences and hit the “charge connected device” handle: it goes to “switching” for a bit, but it always returns a “Couldn’t Switch” error. Due to this, I cannot access the menu just above to enable file transfer. Also of note is that in the Device Manager of my PC the phone is not visible at all.

What I’ve done in trying to solve the issue:

-Tried 3 different cables, one of them brand new that I specifically bought to test the phone with. Yes, they can be used to transfer data and yes, they do work perfectly with my old phone which is immediately recognised, asks for access and is navigable through the file explorer.

-Installed the Adb drivers linked in FP’s support article.

-Activated developer mode & USB debugging and accessed the setting for default behaviour when a USB connection is established to “File Transfer”; still nothing.

-After these, I did a factory reset just in case (I anyway haven’t added anything to the FP) and retried everything to no avail.

I’m honestly lost and dumbfounded. Is there any way I can access my phone?

What actually do you select? File transfer only? You must not switch to “other device”.or what its called in the upper part

Activated developer mode & USB debugging and accessed the setting for default behaviour when a USB connection is established to “File Transfer”; still nothing.

What means nothing? Its not kept or the device is not seen?

Is is actually charging?

No, no.

On the very bottom option titled “Charge Connected Device” under “Power Options” is the one I’m referring to, not the “USB controlled by” part that has you give control to the PC.

By nothing, I mean that there’s no different result. The same thing happens; phone connects, gives the flash, there’s no notification, it cannot start charging from the PC limiting me from picking the “File Transfer” option under the “Use USB for” part of the options.

And no, it’s not charging at all. The phone would die if I did not get a new charger to charge it with in a simple plug.

Went and bought yet another cable and this one worked like there was never a problem in the first place (which I guess there wasn’t).

Just in case anyone bumps on this thread again on a future date, the cable I bought, used and worked immediately (instantly charging, able to file transfer etc.) is the following:

Joyroom 3A Fast Charging Data Cable USB-A to USB-C.

Unfortunately USB-C does not have a standard for what data/charging and other specs.
I’m happy changing cable worked

I got the phone to install another OS on it, namely Calyx and now I cannot unlock the bootloader. I’m getting “waiting for any device” on the “fastboot flashing unlock” stage. Yet another cable swap?

Yes or just a bootloader driver issue on windows

Seems like something like this happening to me too.

Just updated my phone yesterday to the newest version and wanted to use unicersal android debloater after getting home but now my phone does not want to connect to my pc, so i cant use adb.

Using the same cable as last time (a month or two ago) and tried a different one i know worked. Tried both windows (10&11) and nixos + ubuntu.

Just the same for me, since last update, my FP5 is not able to connect to Android Auto through USB cord nor to my windows 11 PC. It was working fine before the update. I changed the cord with no better result.

When trying to connect to Android auto, it simply does nothing exept charging.

When trying to connect to windows 11, I have the file explorer opening and closing as long as I keep the USB cable pluged.

Android version: 13
Build number: FP5.TT4C.A.154.20240320

Please make a quick fix, this is really annoying or tell us how to get around this issue.

1 Like

So fairphone broke usb access to the fp5 with the newest update. sigh I hope we wont have to wait 3 month for a fix

I activated developper mode and USB debug mode, my FP5 does nothing special when connected to my Windows 11 PC: it charges and indicates that USB Debug is activated. If I change USB connection to file transfer, the same has before arrives: windows explorer is unable to stay open. It tries to access the phone and stops immediatly, doing a retry just after.

We the user cant make quick fixes, did you report to support?

I persoanly wrote support. no response yet :coffee:

1 Like

Without developer or debug mode on I just connected my phone to a Win 10 PC with data transfer. There were some initial issues in the dialog where you can choose what to do: When I first tried to switch to data transfer, indeed everything was greyed out and nothing happened. Then I disconnected the phone again and plugged it back in, choose the connected device to control the connection which it told me was not possible, but then the data transfer mode was activated and worked.

Thanks for the reminder, I’ll get in touch with the support

Well, it doesn’t seem to be a general bug. My FP5 is on the latest update and can still connect to my Windows 10 Laptop without any problem.

1 Like