FP4 won't turn on (including bootloader) after trying to install /e/OS

Hello! I think I might have bricked my phone, but I’m not sure.

I will try to give a detailed step by step of what happened:

  1. I prepared my FP4 for a new OS install (removed Google accounts, etc)
  2. Tried to use the Easy Installer but it couldn’t detect my security patch (I probably should’ve stopped here ahah)
  3. I moved to manual install
  4. I got to the point where I was in the bootloader and tried to run flash_FP4_factory.sh found in the folder I downloaded here (version 1.11)
  5. Once I ran the command (slightly modified using this), the output said something like “buffer size inconsistent” or “can’t format partition”. Then it said to “Unplug the phone from the computer, remove the battery, load the bootloader and try again”.
  6. I tried to do that but as soon as I removed the battery, the phone never turned on again. No normal boot, no bootloader/fastboot (with the volume down thing).

It’s weird because I didn’t do the thing that mostly bricks FP4s which is locking it again after installing the new OS.
It seems I just have a phone that is only missing an OS or somthing like that. I’m not an expert, sorry.

If I can give you any more details, please let me know. I have contacted support to see if I can send it to France for repair, but I’d love to have it fixed quicker that that :frowning:

Thanks for the help in advance!

Update: I had ordered a spare battery from FP, tried that today and still nothing :confused:

Hi filipesm

One question for my understanding: You say in point 6 that the phone never turned on again. Does it mean that you can’t see anything on the display or does it mean that it starts with a message or does it show the “dead” android symbol (green android laying on the ground)?


1 Like

So you are using MacOS on your PC correct?

Have you reported it in the e community forum as well? Maybe the chance is a bit higher to get a response over there.

And maybe elaborate in detail what you did exactly when you say

That means you powered off the phone and then you plugged in the charger while holding Vol-Down?

Disconnect the USB cable, turn off your Fairphone, then connect the cable and hold the volume down button. After a few seconds, you’ll see the fastboot mode.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.