FP4 Wifi issues

I’ve had my FP4 for a good few weeks now and I’ve noticed some annoying issues so far. One of them being the wifi behaviour.

For some context: I run a Ubiquity Unifi setup at home with two UAP AC Lite and one UAP 6 Lite.

I’ve noticed that the FP4 is having issues with roaming between AP’s and issues with it even connecting at all when I get back home. It always switches back to the metered data connection and requires me to manually select the already detected wifi network even though it is set to auto-connect.

No other device I own has this kind of issue.

I suspect there might be some SW/FW weirdness at play, but maybe I’ve got some config wrong.

Another annoyance though not as critical is that the FP4 seems to only support 1x1 MiMo. This shouldn’t be as even my 10 year old thinkpads support 2x2. This seems kind of odd to me.

Hi, welcome to the forum! All I can tell you at this point is that roaming between my Fritzbox APs in mesh works without issues. I know this doesn’t really help you. But just letting you know there are instances where it does works.

1 Like

I have similar problems at home with my devolo mesh. Even when I switch off mobile data it doesn’t connect with wifi. I have to tap off and on manually to connect with wifi .

Both me and my girlfriend has the same issue, i use Ubuntu touch and she uses stock android, both having the same issue. We have an ubiquity dream router.

@Cayusse @Marius_Gripsgard

I suppose you do have the option to set it to connect automatically for the router you have problems with ~ is it the same for all other router ~ like when you are out and about?

I have a same issue with an Drytek AP903 with the latest firmware. It will in time disconnect from the WiFi. It will go from 2,4GHz to 5GHz to disconnect. I do not experience any issues with my notebook or other devices.
I use an other Drytek AP902 on a other floor in my house. Without any issues on any device.

The AP are being controlled with “Central AP” of a Drytek router.

Hi and welcome to the forum, have you tried

  • Giving the 2.4 an 5 (GHz) different SSIDs
  • Do not use automatic connect at least on one band.
    ?