FP4 - very privacy-friendly custom ROM iodéOS

My easy solution: :slightly_smiling_face:


Update concerning the OEM unlock option:
I did the Update 3.0->3.1 yesterday. Since then it’s possible to unlock the OEM option in delevoper settings again. I did not check it directly before the update. Anyway it’s available again.
Do you think it’s worth resetting the phone and trying to lock the bootloader?

Hi. I saw that Iodé has some really nice things like the ad blocker and A12 and I’m interested in trying it. But I have some concerns. Can I go back to Fairphone OS with no Problems (everything works like google play services) or is that not possible?
Thanks for your help.

You can go back however as Iode uses their own avb custom keys you would have to delete them, and it might make a a bit more difficult… Whatever you do be very careful with locking the bootloader, currently its very easy to brick the FP4… There are several Posts around this here in the forum

Can’t I just let the Bootloader unlocked? Because I wouldnt have a that big risk to brick the FP4. And is iode compatible with the ultra wide angle camera?

Yes it can stay unlocked and no as far as I know, accept e/OS no Custom Rom can currently use wide angle, discussed here in detail

A post was merged into an existing topic: Install /e/ on a Fairphone FP4 - “FP4” (beta)

Today a wiki “Apps compatible with iodéOS” was started. Have fun with it! :slightly_smiling_face:

Since my last post, the apps list has been filled quite well. :slightly_smiling_face:

How to setup an iodé phone to protect your child?

Our latest update (iodéOS 3.2) provides great new functionalities to protect your kids on their phone.
You don’t want your kids to play a certain game? You want Facebook or TikTok completely out of their phone? Set a password, a few restrictions from the iodé blocker, and consider it done.

IodéOS is now completely open source ! :tada:


With the new version iodéOS 3.3 yes! :slightly_smiling_face: It will be out soon:

It is solved with open camera app (OC):


and build instructions are written now…

1 Like

Black Friday (until Sunday) at iodé! :slightly_smiling_face: :tada:

The “small” FP4 now costs 543 € instead of 659 €, for example. It is even cheaper than Fairphone (579 €) itself. The “big” FP4 and the FP3+ are also in the Black Friday offer.

1 Like

Update iodéOS 3.3 (now open source!):

  • 24/11/2022 (build 20221121):
    • The wide-angle lens now operates with the preinstalled camera app (OpenCamera)
    • Improvements in the blocker user interface (iodé app)
    • LineageOS synced with September security patch included
    • All apps updated

Ive had iodeos installed since 3.1, all has been pretty good but the iodeos networking app would reboot my phone if i launched it since the 3.3 update. But phone worked fine if i didnt launch it. until…after ota update from iodeos 3.3 to 3.4 my fp4 rebooted fine one time. I then opened the iodeos networking app to see if new update fixed the aforementioned issue. The phone froze and rebooted. It then stuck on the opening.iodeos splash screen. Then I tried to reboot and it stuck on iodeos splash screen and sent me to recovery. in Recovery i tried.to reboot and it says cant load android system data may be corrupt etc. Etc. what to do? What fix would work so i dont lose all my data? Or can i downgrade back to 3.3 without losing my data via sideload update? There may be an offending app, but I cant boot to safemode even if i wait for the iodeos animation and then hold the vol. Down button still it will not load safemode. It just restarts phone to the bootloader.

have you checked the Iode Community especially reg. the app issue (btw which one is the networking app?). Have you tried multiple times 7-10 to reboot from recovery, this might force to change the slot. not sure if its possible to start in safe mode when you are in the bootloop state.
Downgrade will mostlikely always cause a data loss.

Thanks, I went through about a dozen successive boot , iode splash , recovery, boot , iode splash , recovery cycles. The slot never changed and unfortunately neither did that pattern. I am still unable to get into my os to find the offending app. I can’t believe there isn’t a safemode built into iodeos.
The iode networking app I am referring to is the one to the left of the iode news app. The iode networking app is a white circle that says io on it. It acts as an adblocker/hosts file firewall.

@fizzstep Android has a safe mode, the moment you see the boot splash (not the vendor logo), hold volume down, after a moment you should feel it vibrate, then let go. The system should then boot and say “safe mode” in the bottom left. It doesn’t always help, but give it a try to get your data off, then maybe do a fresh install. And make backups in the future! :wink:

Hi thanks,
If I hold vol down and wait for iodeos logo there never is a vibrate, so I have no cue to let go. I just keep holding and it reboots to recovery. The phone vibrates when it gets the initial fairphone splash screen so we know the vibrate should be working.
I tried holding vol up too no luck. I tried holding vol up and vol down simultaneously …still no luck why isn’t there a Linux entry point if these hardware methods do not work?

Have you modified the system in any way, like installing Magisk?

What happens if you turn the phone off and connect it to your PC via USB while keeping Volume Down pressed? It should boot into fastbokt mode so you can change the active slot with fastboot --set-active=[a|b]. The current slot is written on top of the screeb.