FP4, USB-C headset adapter and Rode smartLav+ lavalier microphone

I saw several discussions here about FP1, FP2, FP3, FP4 and the smartLav+ and/or similar microphones

I tested the following combination:

  • FP4
  • Fairphone’s USB-C to Mini-jack adapter (ACADAP-2ZW-WW1)

with two different microphones:

  • the headset from a Samsung Galaxy Note 3
  • the Rode smartLav+

I used the Open Camera app for these tests. I chose the “external” audio source in Open Camera settings

What I observed:

  • using the headset, the audio from the external mic was recorded
  • using the smartLav+, the audio from the internal mic was recorded

It appears that the mini-jack or the Fairphone are looking for the impedance of the headphones. If they don’t see that impedance, they know there are no headphones and then they assume there is no mic present either.

Is there any way that the firmware or operating system could be patched to recognize the impedance of the mic even when the headphones are absent and only the mic circuit is complete, as in the case of attaching a smartLav+?

If that is not possible in software, then I can see two solutions:

  • use the soldering iron to create an adapter with a couple of resistors that goes in-line between the mini-jack and the lavalier, simulating the presence of the headphone output
  • don’t use the Fairphone USB-C mini-jack, use a full function USB audio device connected through a USB OTG or USB hub

I created a separate topic for this because the previous topics look at the earlier FP versions and because some of the threads became quite long too.

1 Like

I tried five other adapters similar to the Fairphone USB-C to 3.5mm adaptor. Four of them work with the Rode smartLav+, one doesn’t.

Working USB-C to 3.5mm adapters:

  • Manhattan 2-in-1 (has 3.5mm and USB-C passthrough socket) UPC 766623153355
  • Samsung EE-EC10J
  • onit F00833
  • hama 00200318

One device did not work at all. When this device is connected, neither the internal microphone nor the external microphone are recording correctly. Therefore, I suspect this device may not follow the CTIA TRRS wiring pattern or maybe the sample I received was faulty:

  • equip 133474

Given that so many other devices are working, I feel that if Fairphone can not make their device work with some software workaround then they should stop selling it. All the devices are about the same price so it feels wrong that people who buy the Fairphone-branded device will lose time on something that doesn’t work with their lavalier.

Why? It’s working perfectly with most headphones, as it is designed for.

1 Like

Given that all these devices have a similar price, it may not be economical for the Fairphone engineers to make their adapter perfect.

If they stop selling it then they can focus their energy on other improvements to the phone itself. Such improvements may be more profitable for them than trying to fix this adapter.

If the Fairphone adapter is no longer listed for sale, customers are more likely to buy one of the third-party adapters that doesn’t have this limitation.

You cited only the first part of my sentence. I still think, that the adapter works as it is designed, so no changes are necessary, it can just be sold as before. It‘s just not made to use a single microphone.

1 Like

Nonetheless, there is probably some subset of users who are inconvenienced

All the devices are roughly the same price. I don’t think any subset of users gets an advantage from buying the Fairphone branded device, but there is a subset who suffer a disadvantage, even if they only discover that some time in the future when they buy a Rode lavalier.

I tried an external USB audio device connected through an OTG

First I tested the OTG with a USB flash drive to make sure the OTG is working.

Then I connected a PreSonus AudioBox USB96 device. It has two XLR mic inputs wired to the left and right channel, presented to the application as a single stereo audio source.

I tested it with OpenCamera. OpenCamera completely ignored it. All recording and playback was done through the phone’s internal mic and speaker.

I think I tested the same setup some time ago with a Samsung Note 3 and LineageOS 14.1-2017… (Android 7.1.2) and it worked with the Diktofon app.

My FP4 has LineageOS 20-2023… (Android 13) which has changed the audio API quite a lot since Android 7. Has anybody else successfully used a full USB audio device with latest LineageOS / Android? I don’t think such an issue is specific to Fairphone but if it can be made to work, it provides another useful alternative to the problem with the Fairphone headset adapter.