FP4 Root Access is possible, maybe a bit risky

Thank you!
For now I don’t want to replace stock OS with . Did it when using an old Samsung S3 → CyanogenMod. But with the new FairPhone I would try it with stock OS first. Just Magisk is mandatory. When later changing to another OS I have Titanium Backup to save my data.

Your tutorial: I am stuck at point 1. How do I patch the downloaded stock boot.img with Magisk?
Where can I get the boot.img? [EDIT: Sorry, overlooked the link in FP4 Root Access is possible, maybe a bit risky - #43 by hirnsushi]
I know how to handle Linux but I am quite unexperienced in flashing phones.
Any problems to get the Fairphone recognized by my Linux PC?

You have to install the Magisk app to your FP4, select :inbox_tray: InstallSelect and Patch a File and choose the boot.img.
Don’t use the old boot.img that’s linked there, you can get newer ones here.

Depends on your distribution, but generally not a problem. You’ll need the Android platform tools for adb and fastboot, but those should be packaged already. If they don’t work without sudo you might need android-udev-rules as well.
Some USB-cables / -ports can sometimes be a problem with fastboot but that’s not Linux specific and can only really be solved by trial and error, other than that you should be fine :slightly_smiling_face:

3 Likes

Ok, will try when I have bought my Fairphone. Will take some time. But I am quite sure that I return here then.

2 Likes

@H_Verweij @cortomalese

I installed Xposed, however when searching for modules it couldn’t find anything. Is there no module officially available? I didn’t knew this risks to brick a device, too.

Hi. In Magisk I have activated Zygisk, then I have installed LSposed-Zygisk release and I have all kinds of modules in LSposed app, such as GravityBox (R). AFWall+ is recognized too, or Greenify

Just to be sure: This does work with the official rom from fairphone?
currently I restore the image, install the update, do one reboot, boot from an older image and patch the current image, and reboot. patching directly after install and before reboot would save quite some time.

It does, I’ve successfully used it with both CalyxOS and stock FPOS :+1:

1 Like

Tried it with my present phone (HTC U11). It’s easier than expected. Both, adb and fastboot, are available as packages from ditribution.
sudo apt install adb fastboot
was all I had to do.

Connection worked on the first try. Later this year I’ll buy my Fairphone 4. Thank you!

2 Likes