FP4 Root Access is possible, maybe a bit risky

Latest boot.img in case someone needs it :point_down:


I’ve just made the last update.

  1. deactivate Zygisk and reboot ;
  2. unistall Magisk (restore images) ;
  3. apply OTA update without reboot;
  4. reinstall Magisk in the inactive slot and reboot;
  5. activate Zygisk and reboot;
  6. all things seems ok !

For me I tried the same, however and as in the previous OTAs it did not work for me without having to re-root afterwards :frowning:

Please some advice with bugs after updating to 079 and rooting with Magisk.

After rerooting, Fairphone 4 in unstable state, lots of errors and problems. By mistake, the 069 version boot image patched with Magisk Manager was flashed, I did not follow the instructions not to reboot the device after OTA to patch Magisk into the update slot. Please help.

Device is now running proper boot.img with Magisk patched, however damage is done.

dmesg and logcat show countless errors of the type no such file or directory, selinux audit avc denied file not found, insufficient permissions, access denied.
Symptoms are: boot loop sometimes, 3 navigation buttons not working, no sound, no notifications, application switcher does not work or is buggy, settings are forgotten on every reboot, developer settings do not open, mobile data cannot be disabled, can’t launch application info from launcher, apps crashing, general buggyness and weird behaviour.

I figured it had to do with broken selinux context but according to dmesg these are loaded correctly.

Does not matter for the problems if I am booting boot.img with magisk patched or not.

Something is seriously wrong, already early up in the boot process. Perhaps paritions are tampered with?

Can I reflash or fix it in a way while keeping /data and internal /storage? Will a factory reset help partition or faulty update problems?

dmesg log: https://pastes.io/ybfcqsb7ag

That sounds like some of the usual problems you get when not running the right boot.img, are you sure you are on the right version system- / boot-wise? :thinking:

No to both, a factory reset doesn’t restore the partitions if they actually got modified, you would need to reflash the system.

Personally I’d back up everything and start over, it usually isn’t worth it to search for the error if you can’t fix it right away, you often just push your issues to the next update.

Oh and welcome to the community BTW :wave:

1 Like

Hi. I cannot root the phone after applying this update. After patching the boot.img and booting from it, Magisk says that it is not installed. Tried with Magisk 23, 26.1, and 26.3. I also tried to boot from my previously working boot.img (B.079) which took longer to boot and had some bugs, but still: Not rooted. Bootloader is unlocked.

Moved your post here maybe read above. Also today a new update was published so did you really try with this older one?

Software update: FP4.SP2J.B.086.20230807

Btw: welcome to the community

Thank you for moving and your quick response! Yes, I tried with B.086 as B.089 does not seem to be available for me and I could not find it anywhere else to download. I also read through this thread, but several suggestions (e.g., “boot first only, do not flash” or “check boot slot”) did not help. Before I have to wipe my data and go back to B.079, I just wonder whether this can be fixed.

Hi. I solved the issue that I created myself. After reboot, I installed the latest Magisk (26.3), although Magisk 26.1 was already installed, but hidden. This new Magisk did not show that the boot.img was patched. By chance, I just spotted that my hidden Magisk app is back and after opening it, it requested to perform additional steps. (You may know what I mean.) After this, the phone was rooted again successfully.


I was trying to root my phone, but I am currently in a bootloop.

I followed the steps described by hirnsushi in post #43.

I used the boot.img B.069 even if there were more recent releases because it has been 4 months since I last updated my OS,
and the method described to know my Build number didn’t help me.

I entered this boot.img in Magisk
I transferd the patched boot.img on my PC
I rebooted to fastboot,
booted with the patched boot.img (without flashing it)
Waited for the device to boot (took a bit longer)
Opened Magisk (did not get the Additional Setup ask), chose direct install and rebooted.

Got in a bootloop : after 2 or 3 loops (fairphone image > unlocked warning, no /e/ image, back to Fairphone image) I land on recovery page (try again/factory reset, or back arrow that sends me to the page where I can choose between reboot, update, factory reset or advanced, where I can enter fastboot/booloader/recovery/etc

I tried to change slot but it did not help.

I need to root my phone in order to image all my data, hidden somewhere after a factory reset not wanted (nor consented by me) but that’s another problem I’ll see later.
First I need to get out of that bootloop.
Can somebody help me please ?

Welcome to the community :wave:

I’m not sure I follow you, are you running /e/OS? :thinking:
If that’s the case you shouldn’t be using any of the stock FPOS boot.imgs.

If the data was on this phone rooting won’t help you, after a factory reset that’s gone for good.

Thank you fro welcoming me

Oh… okay. I am let’s say a bit lost, so I’m trying everything I can…
My intention was to try a tool like diskdigger but it needs to work on a rooted phone.
Now I end with a bootloop so I try to come back to previous state…

Yes I am running /e/OS. I did not understand I could not use those boot.img sorry…

I’m afraid you won’t have much luck with disk digger, since newer versions of android enforce encryption for userdata and you don’t have access to the decryption key after a factory reset. So any data you could recover using such a tool would be nothing but an encrypted mess without that key…

1 Like

Okay, this is what I am discovering reading more and more about it.

I wanted to try this method (on stackexchange) that requires root, that is why I was trying to root my FP4 - But now I am more and more afraid the encryption won’t be decryptable…

Yeah, as @AndreasChris already said, that won’t help you.

Even if you could get at that encrypted data, without the keys you won’t be able to decrypt anything, and those are stored in the keystore and get recreated on a factory reset (not that you would be able extract the keys without the reset either).
Basically if you can’t boot into Android userland you are out of luck, accessing anything from before a reset, that’s completely out of the question.

That data is gone, sorry.

Wow. Okay.
UserLAnd ? Well I am ready to try anything… before saying bye to a hundred of gigas of photos and work in Signal app. That’s pretty much all, but everything to me.

Well if you have a solution to get me out of that bootloop without doing another factory reset, it would already be great.

But if you judge it irrelevant for that topic, you can delete my posts. Thank you for your answers.

We might be able to get you out of the bootloop somehow, but if a factory reset has already been performed and assuming it worked as it should’ve, we won’t be able to recover that decryption key. There were some recovery games you could play, back when decryption keys of phones were usually stored in flash memory, but with newer devices equipped with some kind of TPM (aka dedicated crypto and key-store hardware), that became basically impossible. Performing another factory doesn’t make much of a difference at that point.

Signal does have a backup functionality that can be set up. If you have copied the backup file at some point and still have the passphrase for that, you can at least restore your messages up to that point, but otherwise I’m sorry for your loss. Unfortunately it’s those kind of stories that make me take regularly backing up my data seriously… :frowning:

Ah sorry, by that I mean a fully booted system, but there’s nothing to try here.

You could flash a stock /e/ boot.img to get out of the loop, but that will just get you back to the state after the factory reset, there’s no way to restore your data from before.

The only way forward is a fresh install, sorry.

Yes I know… And as I don’t store my data online (cloud) I am pretty careful about backups.
But of course this is when my phone became too full to keep up with huge Signal backups.
So I “just” lost a month of data, but of course it was the most important and the densest.
First I was pretty relaxed because I was sure I had a desktop version of Signal, but I don’t know how, I discovered it was disconnected 2 months earlier.
As Signal don’t keep any backup of data elsewhere (this is what we ask for), I know that it is only stored on my phone memory.

And most precious part was in “24h before erased” stories so I can’t ask recipients to help me. I saved all on “notes for myself” which is what I wanted to get back, not with a Signal backup but with what was shown directly in the app.

Anyway. I am mourning over right now. Because I know it is out of my reach and abilities.
Thank you both for your explanations :pray: