FP4 Root Access is possible, maybe a bit risky

Thank you!
For now I don’t want to replace stock OS with . Did it when using an old Samsung S3 → CyanogenMod. But with the new FairPhone I would try it with stock OS first. Just Magisk is mandatory. When later changing to another OS I have Titanium Backup to save my data.

Your tutorial: I am stuck at point 1. How do I patch the downloaded stock boot.img with Magisk?
Where can I get the boot.img? [EDIT: Sorry, overlooked the link in FP4 Root Access is possible, maybe a bit risky - #43 by hirnsushi]
I know how to handle Linux but I am quite unexperienced in flashing phones.
Any problems to get the Fairphone recognized by my Linux PC?

You have to install the Magisk app to your FP4, select :inbox_tray: InstallSelect and Patch a File and choose the boot.img.
Don’t use the old boot.img that’s linked there, you can get newer ones here.

Depends on your distribution, but generally not a problem. You’ll need the Android platform tools for adb and fastboot, but those should be packaged already. If they don’t work without sudo you might need android-udev-rules as well.
Some USB-cables / -ports can sometimes be a problem with fastboot but that’s not Linux specific and can only really be solved by trial and error, other than that you should be fine :slightly_smiling_face:


Ok, will try when I have bought my Fairphone. Will take some time. But I am quite sure that I return here then.


@H_Verweij @cortomalese

I installed Xposed, however when searching for modules it couldn’t find anything. Is there no module officially available? I didn’t knew this risks to brick a device, too.

Hi. In Magisk I have activated Zygisk, then I have installed LSposed-Zygisk release and I have all kinds of modules in LSposed app, such as GravityBox (R). AFWall+ is recognized too, or Greenify

Just to be sure: This does work with the official rom from fairphone?
currently I restore the image, install the update, do one reboot, boot from an older image and patch the current image, and reboot. patching directly after install and before reboot would save quite some time.

It does, I’ve successfully used it with both CalyxOS and stock FPOS :+1:

1 Like

Tried it with my present phone (HTC U11). It’s easier than expected. Both, adb and fastboot, are available as packages from ditribution.
sudo apt install adb fastboot
was all I had to do.

Connection worked on the first try. Later this year I’ll buy my Fairphone 4. Thank you!


I’ve uploaded a boot.img for the latest FPOS release A.142 patched with Magisk 25.1 for people who want to skip the first two steps :slightly_smiling_face:


Just a little add for those who might do it directly after receiving the FP4.

I got this after the first reboot after flashing the patched boot.img

After I hit OK and it rebooted, Magisk was not installed anymore. (Probably an A/B slot issue)
I reflashed it and did it on the described way. The message in the screenshot I never saw again.

So just hit cancel and follow the described way. :wink:

1 Like

I used the boot.img in the CalyxOS installation file (FP4-factory-22307020.zip). That zip includes a image-FP4-sq3a.220705.003.a1.zip, which contains the stock boot.img. I patched that one, booted from it and was able to direct install via Magisk app. Thanks!


Thanks for reminding me, I should probably change the wording of those instructions to be a bit more general. And that link to the boot.img still points to the oldest one available :see_no_evil:

Glad everything worked fine for you :+1:

Edit: Updated :slightly_smiling_face:


I’ve uploaded a new FPOS-A.163-magisk-boot.img, patched with Magisk v25.2, for people who want to skip patching the boot.img.


Patched FPOS-A.170-magisk-boot.img, in case someone needs it :slightly_smiling_face:

1 Like

Where did you find A.170?
On Fairphone 4 Kernel Source Code — FAIRPHONE open source documentation are only up to build A.142.

Thankfully there are at least updated factory images available (but I just pulled the patched image directly from the phone in this case :nerd_face:)

Thank you.
If I want to use the A.170 patched by you I think I have to “direct install” that file with Magisk.
Magisk 25.1 (or 25.2) does not offer that, There is only one option available “Install” → “Select and Patch a File”. If I understand you that’s already done with the file from FP4 Root Access is possible, maybe a bit risky - #236 by hirnsushi

Now I’m stuck.

Are you following the instructions above? :thinking:

You only need to download the patched boot.img and start with the 3rd step in the instructions.
If you don’t have direct install available, have you fastboot booted a patched image?

Yes, I am at point 5.

But there is no “direct install and reboot”.
In Magisk I selected “Install” (upper right corner).
Install shows
(-) Method
( ) Select and Patch a File

That’s all. Nothing like “direct install and reboot”.
It’s Magisk v25.1 (2022.6.19).

What shall I do?

If you don’t have direct install available, have you fastboot booted a patched image?

Yes, that’s what I have done.

Sounds like you aren’t booted into a rooted enviroment … :thinking:
I’ll have to check if everything’s fine with the image I uploaded, give me a second.