FP4 No longer connecting to home WiFi with WPA3 security since Android 12

Since upgrading to android 12 yesterday (UK on the Zevvle network which is an EE network share) I’ve not been able to connect to my home WiFi. It is two FritzBox access points in the same mesh with both 2.4 and 5 GHz networks.

I’ve tried forgetting the network and adding it again however that hasn’t worked. I’ve also changed the privacy option from randomised to device MAC however that hasn’t helped either.

When trying to connect I get the notification saying "could not connect to WiFi network “(network name)”, but not other explanation about why.

The network is not hidden as per one of the other threads.

Only the first attempt to connect would show up in the FritzBox logs.

I had the WiFi security set to “WPA2 + WPA3”, switching the mode to “WPA2 (CCMP)” allowed my Fairphone 4 to connect. Switching back to “WPA2 + WPA3” and it still connects, though at the WPA2 security level.

Although I’ve mostly solved it in my case, it would be useful to know if others are having issues with WPA3 on Android 12, and for this to potentially help others.

Edit: I’ll add that I tried resetting the Fairphone network settings, restarting the phone, and clearing the non-connected device list from the Fritzbox as well before changing the security to see if they would work first, and they didn’t.


Yes I can confirm this, just now tried to connect to a public AP wich uses OWE and WPA3 and it didn’t work with my Fairphone 4 (Android 12). Had no problem connecting with my eBook reader.

I can only connect if the network is not hidden. Other than that it still works. But it’s annoying to change your network because one device is unable to behave normal.

I’ve encountered the same issue on my FP3(+).

I recently switched from WPA2 to WPA3+WPA2 transitional and the phone won’t connect any longer. I removed the network settings, even rebooted both the AP and the phone.

There are some similar reports in (now closed forum threads) on the FP3. Since this affects FP4 and FP3, I wonder - may this relate to a bug in a shared SW component?

Hi and welcome, the FP3 and FP4 dont share Software and for the FP3 this is not new and known since a long time.

1 Like

Just been adjusting my home WiFi network. Went why am I not using WPA3+WPA2 option, let’s get that enabled. Fairphone 4 doesn’t connect all other devices seem to. Scratch head. Search online and find this thread that I created. Arg annoying it hasn’t been fixed yet.

For FritzBox user => Try WPA2 AND ENABLE PMF… if it fails to connect, PMF is the issue which is required for WPA3…

Some wifi chips (or driver?) doesn’t support PMF for some reasons…

Looks like PMF is available. Optional for WPA2 and required for WPA3.

WPA2 with PMF seems to work. No immediate connection issues so far.

Sus… this is unfortunately where my roads ends… I’ve had the same issue with some ROMs for Sony XZ2C and therefore still use WPA2 (without PMF) …

For me the fix was to completely forget the network on my FP4 and then add it through the QR code in my Fritz!Box (or from another device that can share the connection). Also with a hidden network it works fine now for a few months.

1 Like