FP4 - Iode OS - bootloader issues

Due to the openess of the fairphone 4 towards other ROMs, I decided to install a different ROM on my phone with these official instructions: iodéOS installation - iodé
Here printed:

Update the stock firmware to the latest
Unlock your phone by following the instructions from Fairphone website
adb reboot bootloader (or press VOLUME DOWN and plug phone while it’s shut down)
(FP3) fastboot oem unlock
(FP4) fastboot flashing unlock
(FP3) fastboot flash boot recovery for FP3(+)
(FP4) fastboot flash recovery recovery for FP4
(FP4 only) In order to relock bootloader: fastboot flash avb_custom_key avb_custom_key-FP4.bin
press POWER+VOLUME UP until reboot in recovery
From recovery => Factory reset => Format Data/factory reset
From recovery => Apply update => Apply from ADB => adb sideload <rom.zip> iodéOS for FP3(+) | iodéOS for FP4
(FP3) fastboot oem lock
(FP4) fastboot flashing lock

I am now stuck after the last step, as the phone did not decide to restart, but to stay in the bootloader menu with the bootloader locked. Fastboot doesnt recognize the devices as well. And starting the phone does not lead to anything.
Do I have any options or is the device just bricked?

Welcome to the forum :wave:

I assume you already tried:

  • Getting into recovery by choosing Recovery mode or using fastboot reboot recovery
  • Unlocking the bootloader again fastboot flashing unlock

If that’s the case then indeed your device is probably bricked. You’ll find a number of topics in this forum from people in a similar situation.
Your best bet is to #contactsupport, the price to fix it is apparently roughly 30.- € and you’ll have to send your phone in for repair.

I currently have two questions about the issue that the phone is corrupted when the bootloader is locked again.

  1. are there two hardware revisions of the FP4?
  2. Is it related to the last stock SW update of FP? 103.20220221 - February2022

In the 103.20220221 there is an interesting message in the changelog:
“Addressed an issue that was causing an incorrect message to be shown when trying to toggle the bootloader unlock function and no internet connection was available.”

It seems to me that those of us who have not had or are not having any problems have been using the previous version of the SW. 0132.20211027 The October 2021 version.

All the problems now being reported seem to be on the latest stick from February 2022.

Somehow it smells like it. Especially because of this changelog…
All PRoblems are reported by people who haven’t had their phone that long, or are on the new stock

And this does not only concern iodé, but also /e/OS and also the change back to stock. Even there it has massive problems.

I have the feeling most phones brick (at least so far) when going back to FPOS. It seems still only Version FP3R.A.099.20220112 is available for manual installation and I would say that already in February many tried to go back so they would not have been on the march Version before . At least for the FP2 you always had all Versions available for manual installation.

So yes there are severe issues, but maybe different.

Yvonne, you are right.
But I see something different.
If the FP4 had stock (any old version), was supplied with the February update via the OTA updates, then iodé or /e/OS was installed, caused problems when re-locking the bootloader, then went back to stock, then the February update was very well already on it.

And then there are of course the same problems with the FP stock image when the bootloader is to be locked again.
No matter which image, whether stock or custom ROM.

I see a connection

1 Like

I agree… But the problem was very stupid… The script lets the B slot active, instead of the A one, at least it dit it for me, so the phone will bootloop, not having the OS on the B slot :confused:
Hopefully, that can be changed by a simple command in fastboot
fastboot --set-active=A
But i was very afraid I can’t boot it anymore…
I’m gonna tell FP support this issue, and if you encounter another person that has the same problem, feel free to link to this message, or re-explain it if you want (I don’t go frequently on the forum these days)

Spread the message before some people send it to support for that reason ! :skull::joy:

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.