FP4: Google-free Android

great news! :star_struck:
Since /e/OS is a fork of LineageOS, do you think a version of LineageOS will be released at the same time as this version of /e/OS ?

EDIT - It seems that this will be the case:

I don’t see how my quote says that it will come at the same time. But it will come.

2 Likes

I misinterpreted your answer then, I thought you were explaining that it happened like that when FP3 versions were released. Sorry :frowning:
I’m just trying to understand how the development of /e/OS works : since it’s a fork of LineageOS, is it necessary that LineageOS is up and running before developing /e/OS ?

By the way, /e/OS for FP4 has just been released: Install /e/ on a Fairphone FP4 - “FP4”

What about Corona Contact Tracing Germany? It’s a CWA fork using microG.

1 Like

Yes, that fork works very well besides the official German App, but not every Corona tracing App from every country had the luxury of having such an unofficial degoogled fork.

Ah, perhaps I could have repeated some context to be clear.

What happened was that while LineageOS already was in the works by committed enthusiasts on the Fairphone 3, /e/OS was ported to the phone independently by developers of the e foundation, and /e/OS came first, and then LineageOS porting efforts on the Fairphone 3 profited from the work done for /e/OS to get LineageOS official (in their terms) … there’s a short mention here: [ROM][UNOFFICIAL] LineageOS 16.0 for FP3.

So, what I was saying was that either by the LineageOS port succeeding by itself, or by the /e/OS port succeeding and thus being available for reference (since /e/OS is based on LineageOS), official (in their terms) LineageOS should somewhen be available on the Fairphone 4.
Today /e/OS became available for the Fairphone 4.

2 Likes

Yes, it is! And no problems at all installing eOS on FP4 - thanks to all who did it! :slight_smile:

2 Likes

same experience as @bjoern52. installation went smoothly. only app that does not seem to work is osmand+

1 Like

Have you tried the FDroid version?

@Discostu36 i tried three versions. f-droid latest, the one before and the one from /e/ apps store. all of them crash.

1 Like

Yes, OsmAnd is crashing all the time.

And in Camera/OpenCamera the panorama function has disappeared.

All other apps seem to run ok.

Yes osmand crashes

But organic maps is working

That makes sense.
Never used /e/ OS, but from what I’ve been gathered on this forum, it seems its not as complete nor free-to-customize as LineageOS is, by a long shot. I’ve also read complaints about system being buggy. Are people really that eager to install it ?

I suppose it benefits from ‘commercial’ support

I’ll wait for a week or two and finish what I started on vanilla FPOS and if Lineage is out by that point I switch to that.
Otherwise I’m going to install /e/ and just remove the stuff I don’t like. While I don’t agree with a lot of their decisions, it’s still a step closer to the state of FOSS I want my phone to be at.

Ahah and I’ll be following closely, please post about what you did when you install it :smiley:
Out of curiosity, do you remove all google services ?

So I know that LOS has its own recovery. Do you know if e/os has one, too? Or will I probably still have TWRP after flashing e/os?

According to the installation notes

fastboot flash recovery_a recovery.img
fastboot flash recovery_b recovery.img

installing /e/ will overwrite your current recovery.

/e/ is degoogled anyway, so less work on that front :slightly_smiling_face:

2 Likes

Going a bit out of topic here, and I’m sorry for that, but can google maps be installed and more importantly run properly on a degoogled OS ? That’s pretty much the only google app I can’t really live without… I tried to get it to work on my Zenfone8 with microG on top of LineageOS, could launch the app but never managed to get the location dot to show up.

Dont know but I use Magic Earth (maps App preinstalled in e/OS) instead without using e/OS maybe worth a try

1 Like