FP4 - gcam-port

You are right, it seems to be not sufficient.
I reinstalled photos from play store and removed it with

pm uninstall com.google.android.apps.photos

After that gcam asks for the gallery app (f-stop in my case). With other words: It works now, even without GCam photos preview.

Thanks for the helpful tips.

4 Likes

What is that your using there?

Here you can get the newest version (actually 0.4):
https://gitlab.com/CalyxOS/calyx-fdroid-repo-apks/-/raw/main/GCamPhotosPreview/GCamPhotosPreview-common.apk
The version in your link is the initial version without the menu, to can edit, delete, etc… directly in preview

1 Like

i think you mean iodéOS
It is a custom ROM for FP4

I got my Fairphone 4 yesterday. Can I install another camera apk to test the difference with the standard camera app from Fairphone? Which apk do you advise? Can you provide a link? Thank you so much.

1 Like

Hi and welcome, you can and links to the GCam ports are already included above im one or the other post, just test which you like best, for me its Nikita over BSG, example pictures here

1 Like

Hi All,

I hope someone has found a solution to this.

I came from a Google Pixel phone to a Fairphone. I just love the Google Camera App. Then I found someone had a method to bring it over to the Fairphone. Happy days!

Except…about half the time, when I open the Google camera app, the camera doesn’t work. No image is seen, no image is captured if you click on the button.

The only “solution” that I’ve found these days is to restart the phone (and wait a minute or two). Other things I’ve tried:

  • turning phone on/off
  • switching to another app, then back to the Google Camera app
  • killing the Google Camera app, and restarting it
  • killing the Google Camera app, and starting the Fairphone Camera app.

I haven’t tried getting the console messages to see if there’s any logging that’s going on.

Anyone found a good solution (or a camera app that beats Googles (when it works)?

Which one exactly of the many GCam Ports do you use?

edit: moved your post, please also see above.

Edit2: else do some reading in the forum reg alternatives etc.

https://forum.fairphone.com/search?context=topic&context_id=94955&q=FP4%20camera&skip_context=true

This file is no longer available. I am very interested to get a config file. Is there an updated version somewhere?

No, sorry. Don’t use a FP any longer

Which phone did you switch to, out off curiosity?

I’m using the snap version from this port without any issues:

Keep in mind to set “Surface List” of the 0,6 camera module to “from HW FULL”.

2 Likes

Where I ll find this “surface list”? I can t find it in settings.

I installed MGC_8.7.250_A11_V11 by BSG on my FP4 and Im not sure which interface is preferred for FP4. From default I had set Pixel 3 and photo looks like made with fish-eye effect. What should I change?

You need to switch from the wide angular lense to the normal one

BTW, the latest stable version is MGC_8.7.250_A11_V15a

see BSG: MGC_8.7.250_A11_V15a

Pixel 6a with iodéOS
Half of the price for double of quality, I think that’s also a Fair Phone :wink:

I often say the Fair bit of the phone refers to the and success in ensuring better working conditions and wages for miners and factory workers, not the end user of a mobile phone.

5 Likes

Thanks, working on it.

those of you who use the BSG mod, are you able to use the flash? on my FP4 with CalyxOS the flash toggle just shows “unavailable” with flash controls turned off. the flash however works fine in Calyx’ default camera app.

Yes, I am using the latest 8.8 built on FPOS A12 and the flash is working fine.