FP4 - gcam-port

What port are you guys using at the moment? Wichaya hasn’t received an update in months so I wondered if I should switch ports.

1 Like

I’m using BSG at the moment.

I’m using the development version: BSG: MGC_8.5.300_A10_V5
There’s also the stable version, about 2 months old: BSG: MGC_8.1.101_A9_GV2a

It doesn’t have an option for third party gallery apps, does it?

Not that I can find, nope :expressionless:

Hi, thinking of getting an fp4 as my fp2 is creaking now. Does gcam solve most camera issues? Do I need to root the fp4 and does that bring consequences? Like banking apps not working etc.

Is it likely fairphone will publish camera-api2 updates soon to allow 48M and ultra wide lens access?

Cheers

Hello. In my opinion, it solves most of the issues, but to be fair, the stock camera app also got much better over the last updates. You don’t have to root the phone to use gcam. You just need to enable installation of apps from unknown sources. (It should prompt you when you try to install the apk file.)

Is it likely fairphone will publish camera-api2 updates soon to allow 48M and ultra wide lens access?

Yes, but we currently have no idea how long it’ll take. (Note that the issue has been reported for more than 7 months.)

4 Likes

Thanks Razem that’s a great reply. It’s probably a tough thing to get right without the resources of a Google, Samsung, Apple etc. where they can just throw enormous amounts of money at the software to get the most out of the hardware,

Is it possible to install gcam in parallel with stock?

1 Like

Yes, it’s what I did :slight_smile:
I can take photos with both.

3 Likes

Does anyone use one of the mentioned GCam ports under CalyxOS?

What has to be done exactly, when I don’t have (and don’t want) install Google Services (nor microg)?

I understand that there are some open bugs to fix by Fairphone so that e.g. all 48MPixel can be used as well as all lenses (wide angle camera is missing right now) etc. - Camera & Camera2 API - missing features & bugs

But which port should finally be used and how to set it up?

I saw and tried:

No matter which one I tried it directly crashes after the start.

Hadn’t used them before, but I just tried it and all three work fine on the latest Calyx release with their GCam Photos Preview installed.

With microG though, if you don’t want to use it have a look at Gcam Services Provider, that only implements the necessary APIs for GCam to function. Haven’t tried it on the FP4 (yet), YMMV :man_shrugging:

1 Like

I tried the Gcam Service provider, but is always says:
“App not installed as package conflicts with an exiting package.” (I should use the photos apk in my case I assume, but the basic apk shows the same problem)

Wondering what the package name of it it is and why it thinks, that it is is already there :thinking:

Are you trying to install the app-photos-release.apk version? That one get’s installed as com.google.android.apps.photos (the other one as de.lukaspieper.gcam.services rather unlikely to conflict with sth).

I’m not sure if CalyxOS ships with GCam Photos Preview installed by default, either search for it in the settings or use adb shell pm list packages -f com.google.android.apps.photos.
That’s using the same package name as the GCam Services Provider “photos” version to achieve the same thing, faking Google Photos.

Edit: Ah, sorry didn’t read that second part that both show the same behaviour :man_facepalming:
Interesting, you don’t have microG installed at the moment, right? :thinking:

Yes I already tried to figure out what is the issue here.
I used termux on the phone directly to check for google packages:
pm list packages -f | grep google

I saw a com.google.android.apps.photos and removed it. Still the service provides apks fail to install :thinking:

And yes also right, the “GCam Photos Preview” apk creates a com.google.android.apps.photos as well.

I don’t have microg installed, that is true.

Another package confused me → com.google.android.gsf probably another fake package, which was installed during one of my attempts to make this working.

Were you able to simply uninstall it or did you use pm uninstall --user 0 com.google.android.apps.photos? If it’s the latter have a look at the earlier discussions in this topic, starting here.

Could you check the path that’s installed to? :pray: pm list packages -f gsf (you don’t need to pipe to grep, pm will just search on its own).
The microG one is located in /product/app/GsfProxy/GsfProxy.apk, so clearly recognizable.

Hm seems to be the microg one:
package:/product/app/GsfProxy/GsfProxy.apk=com.google.android.gsf
No clue when this was set up.

The photos package is here:
package:/data/app/~~CbeWB6Mq5Xwe2ny48G3o-Q==/com.google.android.apps.photos-io4BjoYsdmyFyFrr9bwQqA==/base.apk=com.google.android.apps.photos

I will read the linked topic. Thx

Are you sure you removed microG in the setup wizard? :thinking:
Calyx ships with microG by default, and you have to untick the checkbox on first boot to remove it.

I don’t remember that I un-ticked something explicitly. I just remember that I skipped the setup during the phone setup.

If you have a microG app in your app drawer, or you find something when searching for microG in the settings, you are definitely running microG.

Huh, if that’s the case, those GCam versions should have worked just fine :thinking:

I looked for micro and gsf in all apps (showed system apps before) + in settings there is no microg stuff (used the search there as well)

Maybe I can just remove the gsf package as well with pm uninstall ...

Btw. what was the difference again between:
pm uninstall com.google.android.apps.photos
and
pm uninstall --user 0 com.google.android.apps.photos
?

Uninstall for user 0 versus uninstall completely (only possible with root)

3 Likes