FP4 - gcam-port

Next to the often mentioned Wichaya, BSG and Arnova it’s worthy to try “greatness”.
Correct me if I’m wrong, but it’s the only one with a sunset mode.
Everything else should be basicly the same to Wichaya. (maybe greatness isn’t that stable)
(Oh and Wichaya didn’t show the astrophotography mode correctly… Wich maybe don’t work correctly anyway? Does it really work for someone?..)

Normal mode:


With sunset mode:

Also works with streetlights in the night.

2 Likes

Discussion reg. Astrophotography

1 Like

Holiday in @hirnsushi homeland

BigKaka 8.4.300 v8

6 Likes

Hündleskopfhütte, well well, I hope you tried the excellent Kaiserschmarrn :smiley:

Käsespätzle and Radler :wink:

4 Likes

Sadly, this does not work for me. I always get the error message “App wurde nicht installiert” (App wasn’t installed).

Did you uninstall Google Photos before trying to install it? :thinking:

The app has the same package name as Google Photos, that’s why it works, but that also means both can’t be installed at the same time

1 Like

Yes, I have. When running the apk, it does not ask me if I want to update an existing app.

Hmmm :thinking:

Could you try adb install GCamPhotosPreview-1.apk, I just tried it again and that works for me.

1 Like

Vielleicht über ADB Commando deinstallieren

adb shell pm uninstall --user 0 PACKAGE

That’s not enough, that only “uninstalls” it for the main user, you need com.google.android.apps.photos completely gone.

so you need root for this, because ?

 That’s why, if you omit the –user 0 and -k part of the uninstall command, the command won’t work. These two flags respectively specify the system app will only be uninstalled for the current user (and not all users, which is something that requires root access) and that the cache/data of the system application will be preserved (which can’t be removed without root). 

1 Like

Yes you need root to uninstall or overlay it with Magisk, or a custom ROM without GMS.

But you can also use something like Shelter to create a Work Profile, copy over the FPCamera (or GCam in this case) and install the GCamPhotosPreview in there, just tried it and that works :smiley:

Edit: But make sure you have a way to get the photos out of there:

I’d set up a Syncthing backup just in case!

2 Likes

on the FP3 I just use an older GCam Port (Version 7.4) , because on my FP3 v8… slows down the whole device, I dont see any benefit reg. quality and with v7.4 I still have the preview using a third party gallery…

Das habe ich mir bereits gedacht. Das es komplett weg muss und nicht nur im User-Kontext.

Da ich den calyx Fork ja auf meinem iodé nutze hatte ich damit nicht die Probleme.

Ok, I see. I only uninstalled for the user and don’t think that I want to try that shelter thingy. So I’ll return to my previous solution of a Google Photos that is blocked by firewall.

Or changing the OS, what may result in peace and happiness

2 Likes

Hello!
I’m using the GCam_Wichaya_V1.5_Snapcam for several month now, and I’m quite happy with it.

This weekend however, I noticed a strange bug: when doing a selfie in a sunny environment :sun_with_face: the colours are somehow mixed, some blue points appears on the face and some browns points are present in the sky:

The poor guy in the background wasn’t really like that, at least I hope so :rofl:

I noticed the bug later on, so I couldn’t make the same trial with stock camera. I’ll investigate next time I go to the beach :sunglasses:
Does any of you already see something similar?

5 Likes

Wild guess: Maybe the sun reflection on the sunglasses (frame) played a part in it?
(Or maybe just a built-in anti-Berlusconi filter in the cam)

6 Likes

Try deactivating white balance or try bigkaka port