FP4 camera freezes

At regular intervals, my camera freezes / goes completely black. Even when I start a different camera app (e.g. OpenCamera) the camera remains black, and the apps do not respond. The only way to solve the problem is to re-start the FP4.
Does anybody else experience the same issue?

1 Like

Hi @thomash,
can you add a few information that might help to find a root cause?

Which Operating System do you use in which Version (under settings, about the phone, build number)?
Which camera, Selfie or Main or both?
Which mode (e.g. HDR?)
Which lens and which resolution?
Did you try to turn off the screen by pressing the power instead of restarting?

1 Like

I did notice a similar problem when I use the camera a lot: When I was on holidays and often took out my phone to take pictures, I had to restart it 2 or 3 times in a single day for this issue.

At some point the camera app (stock FP OS camera as well as GCam) only shows a black screen. Trying to switch to selfie camera crashes the app. I also found no other way except for a restart of the phone. It looks to me like some related software/driver component crashes at some point, but have not investigated further. It would be interesting to know if you can reproduce the issue and how often that happens.

3 Likes
  • Fairphone 4 5G
  • Android 11
  • Build number FP4.FP3V.A.116.20220414
  • The problems happens with the Main camera
  • Most of the time I use “gcam”; but once the camera is frozen, no camera app works any more. Also, the interface seems to be frozen. (I just noticed that now: in that case it would not be for Fairphone to solve that problem. Will keep on looking out if it also happens with the Fairphone camera app.)
  • I had to restart the phone to get the camera to work again.
  • I have not been able to reliably reproduce the problem.
2 Likes

Which Gcam Port do you use? So maybe if it only happens with it, it might be worse to try another?

For completeness: I’m using the Nikita GCam port 8.2.300-1.5 at the moment. I have not used the original app long enough to reliably say if that would also cause the issue. But once things are messed up, it does not work any more either, as reported previously.

I experienced the same issue today when I tried to take a photo directly in Facebook Messenger. Suddenly the camera went black and the app crashed. I then tried opening both GCam (Nikita) and stock camera app and the screen was also black. I tried force stopping all affected apps, but it didn’t help. The only way to fix it was to restart the phone. I’m running stock OS with latest update. As @mde suggested, it seems the driver completely crashed and the OS didn’t restart it.

2 Likes

Same thing here. I have had the same problem using gcam.

Could it perhaps be an issue related to 3rd party cameras such as Gcam? Just a thought, because I frequently use the camera, no issues. I only have one camera installed, the stock one. Of course I sometimes do use apps that use the camera as well to scan a QR code and things like that. But I don’t have another camera installed, or set as the default.

Never had such issues. Using only gcam (different mods) and excessively.

I have the same problem

Today it happened again. I tried to kill all apps with the camera permission, but it didn’t change anything. Even the Torch tile in the quick settings menu claimed that the camera was in use:

I managed to take a few screenshots of failing camera tests (*#*#2886#*#*) and also exported logcat and I sent it all to support. Hope they’ll fix this soon.

I also noticed another interesting thing: My Automate scripts were no longer able to register volume keys presses. Maybe this is somehow connected (some media engine)? To be clear, I could change volume with no problem. I just couldn’t set any action to the key presses. (I use this to turn on the flashlight from lock screen. I also tried restarting Automate, but it didn’t help either.)

2 Likes