FP4 camera (driver) freezes/crashes

It has not happened to me recently.

Mine crashed for the first time today as well cant really say why however when it happened nothing than a restart helped…seems my mail to support is getting longer every day🙃


while typing my mail to support I was trying to remember what I actually did before this happened beside of trying to take pictures with stock cam app and GCam port. The only I think happened before that and was different to other occasions when I used the 2 apps in parralel is, that I had the proximity sensor again going crazy when I tried to listen to a WhatsAppp Voice message in sunlight and after that I noticed the ambient light adjusting too often and not adequate… so I’m wondering if the proximity sensor bug could somehow have influenced this, although I cant explain how?

1 Like

Just to record in case support stops by, it happened today again this time twice within one hour


I have never installed Gcam and regularly get this issue. My torch never works and always says ‘camera in use’. I’m going to try restricting access to the camera to see if I can find the culprit app.

Hi and welcome to the community. This could be a slight different issue, I myself never saw a message as you described, for me its just a black screen irrespective of the app used

It’s the same issue. The black screen is the result of the camera being in use. See:

1 Like

Ah thanks did not notice the mention of the torch and never checked this when this happens, will check the next time it happens

1 Like

Yep I also get the black screen - quite often on third party apps e.g. Instagram or WhatsApp. The stock camera app usually works OK or at least always will after a reboot. I can’t remember the last time the camera worked on a third party app.

As others have noted restricting access to apps other than stock camera made no difference.

Hi all, I wanted to mention that I am having the exact same issue and can confirm @mde observations. Just returned from holidays, Fairphone 4, Stock Camera app AND Wichaya GCam port; taking lots of pictures, camera reliably goes black after a few times removing phone from pocket, switching on, taking pictures.

I did not observe the flashlight issue.

What and How it happens:
starting app - no issue. Switching to video (GCam): SOMETIMES it never opens. Switching back to camera: ok. In other times, it goes black and BOTH GCam and stock app remain black.
Switching in Video mode from normal Video to Time Lapse or Slow Motion: App entirely crashes.
Both Stock app and GCam: Camera not showing anything → closing and re-opening app helps in 50% of the cases. In other cases, only restart helps.

I have tried deleting cache - and twice also storage. Helped only initially.
Switching camera apps has no effect. But Stock app is less likely to crash in video mode.
Once it even happened that both camera apps remained black even after restart.
GCam only: app freezes (not: black screen) when switching to Slow Motion.

Why I use both apps:
GCam has slightly more options and better HDR quality. But stabilization doesn’t work for me. For that, I use the stock app. Also: stock app is less likely to crash in slo-mo mode.
It is thus clear that the issue is not isolated.

I am ready to approach support. What do I need?
@mde what was your workaround?

Thanks for your input!

I don’t really have a workaround apart from restarting the phone when this happens, which has always fixed it reliably for me. This does not seem to be the case for you?
The only time I’m running into this is pretty much on holidays as I don’t usually take pictures that often.

Thanks for the reply.
Got the error again, easily. It is 100% repeatable, simply by using the camera often. A few photos or videos, switching off, switching on again after 1 minute and taking another picture (with any camera app) will reliably crash the camera. Only restart helps, which is VERY annoying.
I checked the torch and indeed it says “camera in use”, despite killing the app.

If you have multiple camera apps that may cause a problem if one doesn’t quite let go of the software switching.

have you tried clearing the cache and storage of each camera app more frequnelty and have you tried using the phone in Safe mode where only the default camera with be available?

Support is only likely to help resolve this if you remove GCam to start with and from then . . .

This does not seem to be related to using different apps at the same time or GCam ports…

Havent managed to crash mine for quite some time now, even when using several apps to have comparison pictures

Also happening using the Camera with other apps

Or systems

1 Like

So with the sun back outside it seems the issues increase, the driver crashed several times the past days without extensive use.

I had some issues last week on holidays as well. The use was not really even that intense. But I’m not sure if I can see a connection to light conditions. Sometimes it was also only the selfie camera that failed - even though it was the first time I tried to use it after the last reboot. Another reboot always fixed it, though.

1 Like

This bug happened twice in one day in Prague two days ago. Has anyone heard anything from the support or whatever about this now over 1 year old issue?

No thats kind of a dead end, as hardly reproducible… With the beginning of summer and sun it happend multiple times to me, however not always, so how to investigate?

It happened to me twice in a row in September, but after the A13 update, so far so good.

Same here. It hasn’t happened since A13. I was a beta tester for that so I’ve had it for a lot longer than most.