FP4 bootloop after restart

Hi!
I just restarted my FP4 (after quite some time) and am now stuck in a bootloop similar to the one described in this post:

The screen says:
Android recovery
Fairphone/FP4eea/FP4
11/RKQ1.210503.001/FP4G
User/release-keys

Android system can’t be loaded. Your data might be damaged… (Freely translated).

I tried the suggested fix from the thread in the Fairphone forum Stock fp3(+) (factory reset) boot loop (workarounds in first post) - #407 by tb06 (deinstall Google play service updates), but that didn’t help unfortunately.
I absolutely don’t want to do a factory reset, as I am currently on vacation with unbacked data and very limited internet access (using a friend’s phone for this). As I can only use a phone for “research” on this problem: did I miss the solution for the FP4, as the forum solution is for the FP3? Or do you have any other tips or ideas what to do? Or do you know how to get the data (pictures/videos) from the phone?

Thanks a lot!

Hi there,
if you didn’t enable developer options and/or have the original OS installed, nobody can help you with your data. It will be lost. This is also the case if you don’t have access to a device that can run ADB.
But out of my own experience: You will live :joy:
„Save often and early“…
Or in German: „Kein Backup, kein Mitleid“.
In 2017, I lost all data because Android ?7? encrypted my sd card without asking me. Also on holidays, I feel with you.
Since then I have my own Nextcloud and I hate encryption that is not for pure communication.

Edit:
It just came to my mind, if it’s just pictures you want to keep safe: Put in a sd card!

1 Like

I doubt your issue is related to what was reported for the FP3… So I understand your system boots for a few seconds and then starts again? I would take out all cards (SIM and SD) and see what happens. Is the battery properly in place? can cou boot into safe without bootloop #dic:safemode

2 Likes

Hey, thanks for replying!
The SD card also came to our minds, but with the large internal storage it just felt unnecessary. But this might change my point of view :wink:
@yvmuell: yes, when the phone starts, it does as usual (the dancing dots, then Fairphone logo, then asking for the pin and then asking to unlock the phone). Then there is a 5 to 10 second window to do something and then a screen comes up “factory reset, rebooting”. Afterwards the screen with the try again or factory reset shows up. We already tried to remove the SIM card (there was no SD card) and tried to reboot but still the same issue.
HOWEVER: we kind of fixed it. After deleting all updates from Google Play Services and Google Play Store (in more than one run) and then force quitting the services and play store (in one run, in that order) the phone doesn’t go back into the bootloop. We saved the data and updated the services, checked if the number is at least the one which was determined to be working in the forum thread and restarted the phone. That was a mistake, as the phone now was back in the bootloop. Several tries and more than an hour later we got the phone running again. We won’t turn it off for now, but a solution or a hint what could be wrong would be very nice.
Thanks so much!

EDIT: just because I forgot to answer before: I wasn’t really aware of a safe mode for Android so I didn’t try that. I will do so if the problem reoccurs, but hopefully not.

Unless you want to download from the Google Play store, keep it disabled or remove it via ADB.

It seems that the GP Store updates the GP Services and other things that seemed the root of a similar problem with FP3 Android 11 but that was resolved when a new GP Services was available etc.

1 Like