FP4 Android Setup starts at system boot and hangs

I’m the Fairphone Angel from Ghent, .be, and I had a visitor today with a problem I haven’t seen before.

After system boot, his Android Setup would start and give a pop-up message ‘tap to complete installation’ or something of the sort, but tapping the notification just showed the non functional home screen with only a back button. The only way to escape from here was too lock the screen, and from the lock screen close the running app.

I tried just disabling notifications for Android Setup but it would still give the non functional screen (I assume the app is hanging).

Finally I disabled the app altogether, which serves as a workaround but shouldn’t be necessary.

Any FP4 users with suggestions? System was up to date and all apps were updated as well.

Thanks.

Which app? Overall I would consider it a glitch if not occurring repeatedly, else I first would check if App was recently updated and if there are any reports in the app store, that its faulty?

And does the user use stock or another launcher?

Everything stock, and the app seems to be 'Android Setup '. When I disabled the app, it doesn’t happen anymore. I tried clearing cache to no avail.
Also, it was recurring repeatedly - he mentioned having to force close the app every few hours or days

1 Like