🇬🇧 🇩🇪 FP3 WLAN/Wifi Problems

I just bought a FP3 and everything seemed to be allright. But from the beginning the connection to WLAN/Wifi was very unstable and by now it does not connect any more. Other devices dont’t have such difficulties with our WLAN-AP. Does anybody know about this topic. Is it a known problem with FP3?
Any help would be very useful.

1 Like

I would check the logs of the WLAN AP.

Hey have the same issues, any updates?

1 Like

I solved the problem for me by buying another Wifi-AP. Before I used our Fritz!Box 6490 Cable as AccessPoint, but the FP3 definetily didn’t get a stable connection to it. So I bought a tp-link AC 1750, with which everything works fine - til now :wink: .
Perhaps the FP3 has problems with a certain Wifi chipset?
Hope this might help you, bruce.
@JeroenH: I was unable to read logs on the FP3, because it isn’t rooted and I didn’t want to do so.

1 Like

Leider erkennt mein eben ausgepacktes FP3 auch nicht mein WLAN Netz. Es zeigt nur an, dass es gespeichert ist, aber verbindet nicht. Deshalb hatte jch bereits mein FP2 weg gegeben. Das Smartphone zwischendurch hatte diese Probleme nicht. Woran liegt es?

1 Like

Zumindest beim Fairphone 2 helfen wohl vorerst bestimmte Funkkanal-Einstellungen im Router …

Das würde ich aus Sicherheitsgründen absolut nicht empfehlen und das hat @AnotherElk auch nicht gemeint.

1 Like

Verzeihung, da hatte ich mich falsch ausgedrückt. Danke für den Hinweis, den WiFi Standard zu verändern.

WIFI connection problem FP3 to Speedport Smart 3 solved by setting up a guest network with WPA/WPA2 encryption. Reason for the connection problem is the encryption level, which is very annoying for a new cellphone.
Hope this will help.

Ich hatte ursprünglich auch Probleme mit der WLAN-Verbindung zu meiner Fritz!Box 6490 Cable (Fritz!OS 07.12).

Nach ein bisschen Testen scheint das Fairphone 3 bei mir “nur” ein Problem mit dem WLAN-Standard 5 GHz 802.11ac zu haben.

Die instabile Verbindung kam wohl daher, dass das Fairphone 3 in der Standardeinstellung automatisch zwischen 2,4 GHz und 5 GHz wechselt, was es bei mir wohl einfach häufiger tut, da sich hier viele WLANs in der Gegend überlagern. Und wenn es zu 5 GHz gewechselt ist, hat es zuerst 802.11ac versucht … ging nicht, also wieder zurück zu 2,4 GHz, dann bei nächster Gelegenheit wieder zu 5 GHz, 802.11ac versucht … ging nicht, usw. usw. …

Lösung in den Einstellungen der Fritz!Box 6490 Cable:

WLAN - Funkkanal - Weitere Einstellungen - WLAN-Standard 5-GHz - 802.11n+a - Übernehmen

Lösung in den Einstellungen vom Fairphone 3 (wenn man die Einstellungen des Routers nicht ändern kann):

Netzwerk & Internet - WLAN - WLAN-Einstellungen (das ist unten unter der Netzwerk-Liste) - Erweitert - Wi-Fi frequency band - Nur 2.4 GHz

Jede der beiden Lösungen für sich bringt bei mir eine stabile WLAN-Verbindung zur Fritz!Box 6490 Cable.


Ich weiß nicht, wie verschieden die WLAN-Unterstützung der Fritzboxen ist.
Hier funktioniert mein FP3 problemlos an einer Fritzbox 7490 Firmware 7.12 mit 802.11ac/n auf 2.4 und 5 GHz mit WPA2. Laut Fritzbox unterstützt das FP3 PMF, 11k und 11v.
Bandwechsel klappt gut und ich bekomme 433Mb/s als maximale Geschwindigkeit angezeigt.

Sollte ac nicht an der Fritzbox 6490 funktionieren, ist das vielleicht eher etwas, das AVM beheben sollte


Ich kann das gleiche bestätigen für eine Fritz!Box 7590 (Fritz!OS 07.12).

Könnte auch am WLAN Kanal liegen / could also be related to the wifi channel:

I had a weird issue where my FP3 would frequently stop connecting to my WiFi and kick me out for a few seconds. I seem to have solved it by going to Developer options and disabling Tethering hardware acceleration (which might have been disabled by default and maybe I had enabled it by accident). It seems different to the issues described in here though, in that my phone would connect to my WiFi without any issues, stay connected for several minutes or even hours, then kick me out for a few seconds.

I had connectivity hiccups between my FP3 and my Fritzbox 7490 with different symptoms for a while now, especially when using the 2,4 GHz range. My Fritzbox has the latest software update.
Sometimes my network couldn’t be found, then it took ages to establish a connection, the connection could be stable for 30 minutes and suddenly got interrupted and so on. Also when using flight mode my 2.4 GHz Wifi network could never be found but showed up when deactivationg flight mode. Strange.
Other devices had no problems at all using the 2.4 GHz range.

I don’t know if it has already been mentioned in this forum, so excuse me writing down some information everybody knows but me :wink:

Today I had a look at the 2.4 GHz Wifi settings of my Fritzbox and stumbled upon the auto channel setting. I changed it to channel 8 since that was not so overcrowded as the others.
The first thing I noticed was that my FP3 immediately logged into my 2.4 GHz Wifi network after the Fritzbox had finished rebooting. I used it for some surfing and email and found it rock stable. So I returned to the Fritzbox settings and changed it back to auto channel and noticed a setting to provide channels 12 to 13 that was activated. That draw my attentions since not all channels are allowed or tolerated in all countries and maybe these conditions are dependend on the language selection or location settings.

To make it short - I let auto channel active and deactivated channel 12 and 13 using the corresponding option.

All of my initial Wifi problems have gone now.